Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

All Other Software All Other Software
Search Search
Search for:
Tech Support Guy > > >

Firefox focus issues


(!)

8BitKronik's Avatar
8BitKronik 8BitKronik is offline
Computer Specs
Member with 52 posts.
THREAD STARTER
 
Join Date: Mar 2009
Experience: Intermediate
25-Apr-2012, 11:57 PM #1
Firefox focus issues
So, I've gone to Mozilla and even a nifty little website about this unique issue I'm having with Firefox.

It is irritating, no infuriating..just plain annoying..Firefox always seems to auto focus on search bars. I do not always want the browser to focus onto a search bar for every single page I am on and I most certainly do not want it to continue to focus on the search bar. No. Matter. What. I. Do.

I use key bindings. I find it a hassle to click around pages to navigate them when I can do it in half the amount of time by pressing a key. I would like to choose whether or not I want to focus on the search bar. I am always grateful for answers and support. However. If your answer resembles any of the links posted above I am not interested. I am obviously asking for assistance here because I need a different answer from the run of the mill ones I have been having. Thanks.
jessi_mac03's Avatar
jessi_mac03 jessi_mac03 is offline
Computer Specs
Member with 3 posts.
 
Join Date: Apr 2012
Experience: Intermediate
26-Apr-2012, 09:49 PM #2
which version of firefox do you have?
8BitKronik's Avatar
8BitKronik 8BitKronik is offline
Computer Specs
Member with 52 posts.
THREAD STARTER
 
Join Date: Mar 2009
Experience: Intermediate
27-Apr-2012, 09:13 AM #3
12.0
Ent's Avatar
Ent   (Josiah) Ent is offline Ent is a Trusted Advisor with special permissions.
Computer Specs
Trusted Advisor with 5,270 posts.
 
Join Date: Apr 2009
Location: United Kingdom
Experience: Intermediate
27-Apr-2012, 01:01 PM #4
Could you suggest a few of the sites which cause this problem?
Ent's Avatar
Ent   (Josiah) Ent is offline Ent is a Trusted Advisor with special permissions.
Computer Specs
Trusted Advisor with 5,270 posts.
 
Join Date: Apr 2009
Location: United Kingdom
Experience: Intermediate
27-Apr-2012, 01:18 PM #5
Meanwhile, have you seen this?
http://superuser.com/questions/45376...n-web-browsers
Or more specifically according to Mozilla, this:
http://kb.mozillazine.org/Security_P..._form_focusing
8BitKronik's Avatar
8BitKronik 8BitKronik is offline
Computer Specs
Member with 52 posts.
THREAD STARTER
 
Join Date: Mar 2009
Experience: Intermediate
28-Apr-2012, 09:38 AM #6
I have tried the solution with user.js/prefs.js it however it does not work. If there was however a way to modify it into the about:config that might work. I tried your first solution which actually gave me hope however it did not work.

My main issues are with google. (I know there's google instant but isn't that javascript?) And the Mozilla webpage. Most webpages with search engines do the thing I have described previously. The reason however the .js files do not work is because everytime Firefox is started or re-started they are overwritten. I even put write-protection and it didn't work. I think for the values to be recognized they have to be modified in about:config.
Ent's Avatar
Ent   (Josiah) Ent is offline Ent is a Trusted Advisor with special permissions.
Computer Specs
Trusted Advisor with 5,270 posts.
 
Join Date: Apr 2009
Location: United Kingdom
Experience: Intermediate
28-Apr-2012, 10:23 AM #7
I think that google uses javascript to focus, not conventional autofocussing features. You could try disabling javascript to see whether the issue stops.
8BitKronik's Avatar
8BitKronik 8BitKronik is offline
Computer Specs
Member with 52 posts.
THREAD STARTER
 
Join Date: Mar 2009
Experience: Intermediate
28-Apr-2012, 10:46 PM #8
Wouldn't that make other webpages unstable or seem not complete?
Ent's Avatar
Ent   (Josiah) Ent is offline Ent is a Trusted Advisor with special permissions.
Computer Specs
Trusted Advisor with 5,270 posts.
 
Join Date: Apr 2009
Location: United Kingdom
Experience: Intermediate
29-Apr-2012, 09:17 AM #9
Yes, it would.
I'd suggest you try that though, because if it solves the immediate problem we can look at a more precise response. Obviously turn the JS back on afterwards.
8BitKronik's Avatar
8BitKronik 8BitKronik is offline
Computer Specs
Member with 52 posts.
THREAD STARTER
 
Join Date: Mar 2009
Experience: Intermediate
29-Apr-2012, 11:59 AM #10
Ah. I finally get what you're saying. If it was an issue with Javascript then scripting the problem away would work. I updated my java console/add-on. I then disabled them and the problem persists.
Ent's Avatar
Ent   (Josiah) Ent is offline Ent is a Trusted Advisor with special permissions.
Computer Specs
Trusted Advisor with 5,270 posts.
 
Join Date: Apr 2009
Location: United Kingdom
Experience: Intermediate
29-Apr-2012, 12:04 PM #11
What do you mean by disabled the "java console/add-on"? Java is as distinct from Javascript as Latin is from French. To disable Javascript in Firefox follow the following instructions:

Open Firefox (duh)
Press Alt
Click Tools
Click Options
Click Content (in the list of tabs across the top)
Click on the checkbox by "Enable Javascript"
Click OK.

To undo it, merely repeat the process.
throoper's Avatar
Computer Specs
Trusted Advisor with 5,021 posts.
 
Join Date: Jan 2007
Experience: Intermediate
29-Apr-2012, 12:42 PM #12
It is scripts that target the focus.
Give this extension a try. It was primarily for SeaMonkey but works well on all versions of FF I've tried it on.
https://addons.mozilla.org/en-US/sea...don/yesscript/

It will allow you to turn off the ability of selected sites to run any scripts with the benefit of having a button to toggle them back on. It's the only thing I've found that will reliably stop the Google Auto suggest and the annoying Search as you type functions.
Ent's Avatar
Ent   (Josiah) Ent is offline Ent is a Trusted Advisor with special permissions.
Computer Specs
Trusted Advisor with 5,270 posts.
 
Join Date: Apr 2009
Location: United Kingdom
Experience: Intermediate
29-Apr-2012, 12:51 PM #13
No-Script also works, blocking all scripts and requires that you explicitly allow them on a host-by-host basis.
Does your extension let to distinguish between different scripts from the same host?
throoper's Avatar
Computer Specs
Trusted Advisor with 5,021 posts.
 
Join Date: Jan 2007
Experience: Intermediate
29-Apr-2012, 01:20 PM #14
It works almost the opposite of NoScript, which blocks all sites unless specifically allowed.
YesScript allows all sites unless they are added to the list to block.
It blocks ALL scripts from any site on the list, but it can be quickly toggled to allow scripts to run on that site.
8BitKronik's Avatar
8BitKronik 8BitKronik is offline
Computer Specs
Member with 52 posts.
THREAD STARTER
 
Join Date: Mar 2009
Experience: Intermediate
29-Apr-2012, 02:41 PM #15
Alright Ent. I did as you said and the problem disappeared.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


Tags
annoying, focus, mozilla

(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑