Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

All Other Software All Other Software
Search Search
Search for:
Tech Support Guy > > >

Solved: Coupon Printer


(!)

karvel's Avatar
karvel karvel is offline
Junior Member with 7 posts.
THREAD STARTER
 
Join Date: Jun 2004
Experience: Computer Illiterate
13-Aug-2009, 12:47 PM #1
Question Solved: Coupon Printer
I am having a terrible time getting Coupon Printer (from Coupons.com) to work. Here's what happens:
When I click on a link to print a coupon, it says I need to install the coupon printer. So I download and install it and when it's done it says it was successful and I may now print my coupon. When I try to print my coupon, it goes back to "install coupon printer". I can do this 10 times in a row and it never works. I have tried allowing everything I could think of, everywhere I could think of, and even turned off my firewall at one point. I've tried on Firefox, WindowsXP, and Safari. This is the the most frustrating thing ever.
Can anyone help me, please??

I forgot to say that I have used this in the past with no trouble whatsoever.

Last edited by karvel; 13-Aug-2009 at 12:50 PM.. Reason: Additional information
widewiilover's Avatar
widewiilover widewiilover is offline
Junior Member with 3 posts.
 
Join Date: Aug 2009
Experience: pretty good but not great
13-Aug-2009, 06:36 PM #2
try opening the app up and doing it from there
Hughv's Avatar
Computer Specs
Member with 8,450 posts.
 
Join Date: Jul 2006
Location: Annapolis, MD
Experience: Intermediate
14-Aug-2009, 02:15 AM #3
Worked perfectly for me with FF.
Try uninstalling and re-installing.
karvel's Avatar
karvel karvel is offline
Junior Member with 7 posts.
THREAD STARTER
 
Join Date: Jun 2004
Experience: Computer Illiterate
14-Aug-2009, 11:56 AM #4
I uninstalled and re-installedboth Firefox and the coupon printer.
Worked perfectly!!
Thank you Hughv, so much!!!!
ecc's Avatar
ecc ecc is offline
Computer Specs
Junior Member with 1 posts.
 
Join Date: Sep 2009
Experience: Intermediate
27-Sep-2009, 12:04 AM #5
I am having the same problem with IE. And uninstall and reinstall couldn't fix the problem.
Trying to print from coupon.com, I am getting the page to install coupon printer. But if I use the link to brick coupon for specific product, I am getting a line of text showing the product name and a text box asking for zip code.
I was able to print coupons with no problem until this week. I think what trigged it was I clicked on a link with "gi&o" in the URL. There is a online posting saying this type of link will keep asking to install printer. Now I am stuck in that mode. It is very frustrating. Can anyone help, Please?
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑