Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

All Other Software All Other Software
Search Search
Search for:
Tech Support Guy > > >

default_exe.reg revoked my ability to open .exe files with anything.


(!)

MaxxS's Avatar
MaxxS MaxxS is offline
Junior Member with 4 posts.
THREAD STARTER
 
Join Date: Mar 2011
19-Mar-2011, 09:44 PM #1
default_exe.reg revoked my ability to open .exe files with anything.
I accidentally made the default program that .EXE files open with cmd, and had to use default_exe.reg to repair this. However, I can't open .exe files with any programs anymore. I'm using Windows 7 Home Premium. Is there any easy way to solve this?
Phantom010's Avatar
Phantom010 has a Photo Album
Computer Specs
Trusted Advisor with 32,318 posts.
 
Join Date: Mar 2009
Location: Cyberspace
Experience: Advanced
19-Mar-2011, 09:48 PM #2
Not sure what you did exactly.


Try this fix: EXEFIX

Unzip the fix and extract the .REG file to the Desktop. Right-click the .REG file and choose Merge. Note that you need to be an Administrator to apply this fix.

Reboot the computer.

If the fix only opens as a text file, right-click it and select Open With > Choose Program... Then, select the Registry Editor.

If the Registry Editor is not in the list, browse to C:\WINDOWS and select regedit.
__________________

• Please read instructions and questions carefully, and reply in a timely manner... Thank you.

• Why don't you just Google it?
• If your problem is solved, please click on the Mark Solved button.
MaxxS's Avatar
MaxxS MaxxS is offline
Junior Member with 4 posts.
THREAD STARTER
 
Join Date: Mar 2011
19-Mar-2011, 09:59 PM #3
That didn't do anything. Is there anything I can clear up?
Elvandil's Avatar
Computer Specs
Moderator with 51,993 posts.
 
Join Date: Aug 2003
Location: Vermont
Experience: "Been through the mill."
19-Mar-2011, 10:11 PM #4
Quote:
I can't open .exe files with any programs anymore.
That's the way it is supposed to be. You are not supposed to open exe's with anything else. Try Unassoc. Unzip the file and rename unassoc.exe to unassoc.com. Then run it.
MaxxS's Avatar
MaxxS MaxxS is offline
Junior Member with 4 posts.
THREAD STARTER
 
Join Date: Mar 2011
19-Mar-2011, 10:18 PM #5
That program tells me that I am a user despite it being opened as administrator, so it didn't work.
EDIT: Sorry, I missed that you said to change it to .com. However, the remove file association button does not work, as there is no file association for .exe files.

Last edited by MaxxS; 19-Mar-2011 at 10:24 PM..
Elvandil's Avatar
Computer Specs
Moderator with 51,993 posts.
 
Join Date: Aug 2003
Location: Vermont
Experience: "Been through the mill."
19-Mar-2011, 10:28 PM #6
That is the way it is supposed to be. Did it run as an exe? What happened when you clicked on it? If it did, then you have a different problem.

Can you explain in detail exactly what you did? What makes you think you changed the association to CMD (since it has none now)?
__________________
Microsoft MVP
異驚の界世 Ąpןɹoʍ ǝɥʇ ɟo sɹǝpuoʍ ǝɥʇ ɟo ǝuo sı ǝpoɔıun ʞuıɥʇ ı
MaxxS's Avatar
MaxxS MaxxS is offline
Junior Member with 4 posts.
THREAD STARTER
 
Join Date: Mar 2011
19-Mar-2011, 10:35 PM #7
I chose "open with" CMD for an .exe file that was meant to be opened with CMD, but didn't uncheck the "always use the selected program for this kind of file" box so every .exe file opened with CMD. I used default_exe.reg, which I got from Microsoft's website, which removed the default file association for all .exe files, but I can't use "open with" on .exe files anymore, so I can't open the .exe files with CMD anymore, at least not through Windows Explorer.
Elvandil's Avatar
Computer Specs
Moderator with 51,993 posts.
 
Join Date: Aug 2003
Location: Vermont
Experience: "Been through the mill."
19-Mar-2011, 10:55 PM #8
You will end up with problems if you try to use OpenWith with exe files. You are not supposed to open them with anything at all and that option should not be available. You "open" exe files by clicking on them, not by using cmd.

If you want to use cmd to open a file, you open a command window first, then navigate to the file you want to open inside that window. If you do not know how to do this, then you probably shouldn't be trying to open files that way.

So, in other words, you have no problem, since OpenWith is not supposed to exist in the menu for exe files.
jeanluc1986's Avatar
jeanluc1986 jeanluc1986 is offline
Computer Specs
Junior Member with 1 posts.
 
Join Date: Apr 2011
Experience: Enough to really screw up
29-Apr-2011, 01:45 AM #9
Quote: "So, in other words, you have no problem, since OpenWith is not supposed to exist in the menu for exe files."

I beg to differ, if only by utilizing logic to the conversation thus far. . .

Also, I am experiencing the same problem, though in my case, I believe I deleted the wrong thing when manually deleting a virus. I saw that in the Task Manager menu the virus showed up as "rng.exe" and so I searched for it, and deleted everything I could find that had anything to do with it. Now, when I try to open .exe files, I am presented with an "Open With" menu, and I cannot figure out what to do with my computer now.

P.S. - I apologize if this thread is necro-ed, but I am going a little crazy about this problem. . .
Phantom010's Avatar
Phantom010 has a Photo Album
Computer Specs
Trusted Advisor with 32,318 posts.
 
Join Date: Mar 2009
Location: Cyberspace
Experience: Advanced
29-Apr-2011, 09:17 AM #10
Quote:
Originally Posted by jeanluc1986 View Post
Quote: "So, in other words, you have no problem, since OpenWith is not supposed to exist in the menu for exe files."

I beg to differ, if only by utilizing logic to the conversation thus far. . .

Also, I am experiencing the same problem, though in my case, I believe I deleted the wrong thing when manually deleting a virus. I saw that in the Task Manager menu the virus showed up as "rng.exe" and so I searched for it, and deleted everything I could find that had anything to do with it. Now, when I try to open .exe files, I am presented with an "Open With" menu, and I cannot figure out what to do with my computer now.

P.S. - I apologize if this thread is necro-ed, but I am going a little crazy about this problem. . .
Try this fix for Windows XP: EXEFIX

Save the .reg file to your desktop. Double-click it to merge it to the registry.

Reboot.

If the fix only opens as a text file, right-click it and select Open With > Choose Program... Then, select the Registry Editor.


If the Registry Editor is not in the list, browse to C:\WINDOWS and select regedit.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑