Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Business Applications Business Applications
Search Search
Search for:
Tech Support Guy > > >

Excel hangs saving large files


(!)

QB-Paladin's Avatar
QB-Paladin QB-Paladin is offline
Junior Member with 15 posts.
THREAD STARTER
 
Join Date: Aug 2003
21-Aug-2003, 09:33 AM #1
Excel hangs saving large files
I've got a PC on my network running Windows XP Pro and Office XP. When attempting to save extremely large Excel files (one is 13MB and the other is 72MB - they're full of $@$#@ charts) to a network folder, Excel locks up. Additionally, when the user opens these files, it's common for Excel to report it's repairing the file. Saving to the local hard drive works fine.

This mess seemed to start after we upgraded our NT4 file server to Windows Server 2003. The Windows Server 2003 was set up by a MSCE, which I am not. I'm self taught, and this is my first exposure to server operating systems beyond NT4. The server is configured to be a DNS and PDC, as well as Active Directory. It's the only Windows server we have.

The workstation Event Log records the follow entries on boot up:
Event Type: Error
Event Source: AutoEnrollment
Event Category: None
Event ID: 15
Date: 8/20/2003
Time: 8:14:25 AM
User: N/A
Computer: BLACK
Description:
Automatic certificate enrollment for local system failed to contact the active directory (0x8007054b). The specified domain either does not exist or could not be contacted.
Enrollment will not be performed.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Event Type: Error
Event Source: Userenv
Event Category: None
Event ID: 1030
Date: 8/20/2003
Time: 8:13:54 AM
User: SOWATRECO\******** (the username is purposely deleted form this post)
Computer: BLACK
Description:
Windows cannot query for the list of Group Policy objects. A message that describes the reason for this was previously logged by the policy engine.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

And I get these two when Excel freezes:
Event Type: Error
Event Source: Application Hang
Event Category: None
Event ID: 1001
Date: 8/20/2003
Time: 3:17:50 PM
User: N/A
Computer: BLACK
Description:
Fault bucket 15831402.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 42 75 63 6b 65 74 3a 20 Bucket:
0008: 31 35 38 33 31 34 30 32 15831402
0010: 0d 0a ..

Event Type: Error
Event Source: Application Hang
Event Category: (101)
Event ID: 1002
Date: 8/20/2003
Time: 3:17:42 PM
User: N/A
Computer: BLACK
Description:
Hanging application EXCEL.EXE, version 10.0.4109.0, hang module hungapp, version 0.0.0.0, hang address 0x00000000.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 41 70 70 6c 69 63 61 74 Applicat
0008: 69 6f 6e 20 48 61 6e 67 ion Hang
0010: 20 20 45 58 43 45 4c 2e EXCEL.
0018: 45 58 45 20 31 30 2e 30 EXE 10.0
0020: 2e 34 31 30 39 2e 30 20 .4109.0
0028: 69 6e 20 68 75 6e 67 61 in hunga
0030: 70 70 20 30 2e 30 2e 30 pp 0.0.0
0038: 2e 30 20 61 74 20 6f 66 .0 at of
0040: 66 73 65 74 20 30 30 30 fset 000
0048: 30 30 30 30 30 00000

I assume the problems are related, but I'm not sure how or why. Saving non-Excel files seems to work ok, although nothing else approaches these two spreadsheets in file size. Saving Excel files smaller than 2MB seems to work fine. I haven't tried any files between 2MB and 13MB to see if/when I can hit a file size where the lockups start. The XP machine is configured to use the server as it's primary DNS.

The XP Pro machine is a P4-1.8 with 512MB and a 40GB hard drive that's no where near capacity. The server is running Dual P3-500's, has 256MB of RAM, and a 4 drive IDE-RAID array configured to 2 18GB striped/mirrored drives. Those are partitioned with the OS on a 2GB C: partition and data stored on the 16GB D: partition. The systems are connected via 10mbit Cat3 (the building's wiring is old and inaccessable, and wireless is unreliable due to the building's construction).
stod73's Avatar
stod73 stod73 is offline stod73 has a Profile Picture
Senior Member with 832 posts.
 
Join Date: Aug 2003
Location: Istanbul
Experience: Karma Chameleon
21-Aug-2003, 04:45 PM #2
Maybe size isn't the problem. Are there links in these spreadsheets to other spreadsheets? Are there pivot tables, macros? What happens if you try and save them localy?
QB-Paladin's Avatar
QB-Paladin QB-Paladin is offline
Junior Member with 15 posts.
THREAD STARTER
 
Join Date: Aug 2003
21-Aug-2003, 07:48 PM #3
Saving them locally works fine. They just don't get backed up that way, and I'd have to make some adjustments to make the local files sharable. I'd rather keep all the files that need to be shared on the server.

Yes, they do contain links to other spreadsheets. It asks if we want to update the data when we load. Since the data only changes when we change months, the links only need to be updated once a month.

The files are so huge because there are a large number of charts in them, as well as a lot of data. There may be pivot tables, I don't know. Turning off the autorecalculate and the recalculate at save doesn't seem to affect the problem. No macros though.
stod73's Avatar
stod73 stod73 is offline stod73 has a Profile Picture
Senior Member with 832 posts.
 
Join Date: Aug 2003
Location: Istanbul
Experience: Karma Chameleon
21-Aug-2003, 07:53 PM #4
We had the same problem and it seemed to be connected to spreadsheets having links. By chance, are any of the links no longer active (i.e. the spreadsheet trying to connect to another that no longer exists)? I don't think the size is your problem.
QB-Paladin's Avatar
QB-Paladin QB-Paladin is offline
Junior Member with 15 posts.
THREAD STARTER
 
Join Date: Aug 2003
22-Aug-2003, 08:42 AM #5
The links are all valid, and the linked files accessable by the user account and computer we're trying to save these spreadhseets from.

We just moved this computer about a three weeks ago to a different room. The wiring in the building is Cat3, and inaccessable, and the building itself is an amazing blocker of wireless connections. Still, it had Cat3 in the old room too, a much longer run of it in fact. Despite that, pings from the desktop to any of the computers on the network work fine, <2ms, and I'm not seeing any packet loss or collision errors.

I feel like it must have something to do with either how the computer is being recognized by the 2003 server, or how it is handing network file transport.
cahallmxj's Avatar
cahallmxj cahallmxj is offline   cahallmxj has a birthday soon!
Member with 158 posts.
 
Join Date: Feb 2003
Location: Delaware
Experience: Intermediate
22-Aug-2003, 10:06 AM #6
QB-Paladin:

Here is a link that deals with auto enrolment from the microsoft it might help if you are still running NT on your other work stations:

http://support.microsoft.com/default...b;en-us;310461

Also the problem may be in the upgrade itself, if some settings werent changed to reflect the upgrade then that could be the problem, it also may be the cat 3 cable not being able to transfer the data fast enough.

For more network help you may be better off posting this problem in the network forum.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑