Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Business Applications Business Applications
Search Search
Search for:
Tech Support Guy > > >

Any way to stop Word 2010 displaying "Error! Main Document Only"


(!)

Mulderator's Avatar
Member with 51,018 posts.
THREAD STARTER
 
Join Date: Feb 1999
19-Apr-2011, 08:28 PM #1
Any way to stop Word 2010 displaying "Error! Main Document Only"
Okay--apparently 3 or 4 years ago I used a document to create a form template (not technically a form or template in the sense it did not have any fields--just used it to bring up to create new documents based on it). In any event, the document and apparently had some codes in it that I did not see and everything was fine for until moving to Word 2010. Now, virtually any document I pull up comes up with an error. I tried "Open and Repair" and that did not work.

But here is the issue--THIS NEVER SHOWED UP IN PRIOR WORD VERSIONS! I can go right now and pull the same document up on any one of 3 or 4 different computers in the office all running Office 2007 and the document displays fine. So there must be a way to stop Word from displaying the error. I don't want to have to go in an take out all of those codes from all the documents we have that includes them.
__________________
Weapon of Mass Instruction!
Mulderator's Avatar
Member with 51,018 posts.
THREAD STARTER
 
Join Date: Feb 1999
25-Apr-2011, 03:18 PM #2
Bump
DaveA's Avatar
Computer Specs
Trusted Advisor with 11,157 posts.
 
Join Date: Nov 1999
Location: Renton, Washington
Experience: Advanced
25-Apr-2011, 04:27 PM #3
Try opening a new document and then insert the problem document into the new one.
This may get rid of the code.
Mulderator's Avatar
Member with 51,018 posts.
THREAD STARTER
 
Join Date: Feb 1999
04-May-2011, 10:58 PM #4
That didn't work--any other suggestions?
DaveA's Avatar
Computer Specs
Trusted Advisor with 11,157 posts.
 
Join Date: Nov 1999
Location: Renton, Washington
Experience: Advanced
05-May-2011, 10:35 AM #5
Then the code is in your Normal template. Try renaming it and then start up Word, a new should be made.
Mulderator's Avatar
Member with 51,018 posts.
THREAD STARTER
 
Join Date: Feb 1999
05-May-2011, 02:20 PM #6
Quote:
Originally Posted by DaveA View Post
Then the code is in your Normal template. Try renaming it and then start up Word, a new should be made.
I have a highly customized template with macros and the like so that's not an option. And by the way we all use the same template on different computers and it ONLY DOES THIS IN WORD 2010. The codes are there but in earlier versions, they don't display errors. In other words--you can see the codes with ALT-F9 but they don't cause an error to display. This is obviously a bug in 2010 I am looking for a way around it because there are literally thousands of documents that have this problem that we have developed over the years and I don't want to have to delete every code in every document. I can't imagine MS would deliberatly cause Word to display errors that it had never displayed in any earlier version with no way to hide it.
Mulderator's Avatar
Member with 51,018 posts.
THREAD STARTER
 
Join Date: Feb 1999
05-May-2011, 02:49 PM #7
I tried a new normal.dotx (or whatever that last letter is forget right now) and same problem so that's not it. And remember these documents do not show up in 2007 as an error--only in 2010.

I uploaded an example of the document to look at. If you open it in 2007--no errors--open it in 2010 and there are errors. You can see the codes that cause the errors with ALT-F9.

BTW--if I can't stop this, can you help with a macro to delete the codes? I tried, but couldn't figure out how to search and replace the codes. But If I could install a macro to fix it, that would work almost as well as hiding it. Just copy and paste the code here and I'll incorporate it in a quick keyboard macro--that would be greatly appreciated.
Attached Files
File Type: docx example.docx (27.5 KB, 57 views)
Mulderator's Avatar
Member with 51,018 posts.
THREAD STARTER
 
Join Date: Feb 1999
06-May-2011, 08:29 PM #8
bump
Mulderator's Avatar
Member with 51,018 posts.
THREAD STARTER
 
Join Date: Feb 1999
09-May-2011, 03:55 PM #9
Bump again--looking for a macro to delete the codes.
DariusSupport's Avatar
DariusSupport DariusSupport is offline
Computer Specs
Member with 409 posts.
 
Join Date: Apr 2011
Experience: Intermediate
09-May-2011, 04:11 PM #10
are the codes or any part of the documents dynamically linked to anything else?
Mulderator's Avatar
Member with 51,018 posts.
THREAD STARTER
 
Join Date: Feb 1999
09-May-2011, 08:09 PM #11
Quote:
Originally Posted by DariusSupport View Post
are the codes or any part of the documents dynamically linked to anything else?
No--they are old codes in the documents--don't need to be there--I attached an example of the document above. The problem I am having is that I can't record a macro to delete them because I can't get into the text box to do the search. So I need that macro hard-coded.

The code is the same and repeated four times total (twice in the first text box then once in two subsequent text boxes all in the first page header). The code is as follows:

{ SEQ CHAPTER \h \r 1} and the spacing is right on that. Have no idea what that means. But if is there four times so I need a macro that

1. Opens up the header
2. Searches within text boxes (there are 3 running horizontally across the first page header)
3. Replaces the code with nothing. I can get it to work by using ^d in the search field, but I don't know how to make it work by way of macro and it would be nice to just execute one macro that would delete all four codes and exit the header.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑