Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Do It Yourself (Not Computer-Related) Do It Yourself (Not Computer-Related)
Search Search
Search for:
Tech Support Guy > > >

USB 2.0 Hub Problem


(!)

jemcobill's Avatar
jemcobill jemcobill is offline
Computer Specs
Junior Member with 1 posts.
THREAD STARTER
 
Join Date: Jan 2008
Location: Iowa
Experience: Advanced
09-Jan-2008, 11:27 PM #1
Unhappy USB 2.0 Hub Problem
I have a SIIG 02-0680B hub that works OK on a back usb port. However a Belkin F5u234 Rev 3 will not work. Will powered hubs work on front ports?
VIA KM266A-8235 MB running 1.5 GHz AMD Sempron. 2 GB MEM
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
10-Jan-2008, 10:24 AM #2
Many times devices have a problem connected to a hub. My fix is normally to install a PCI USB 2.0 card and avoid the use of a hub, much more satisfactory results as a rule.

Here's a whole list of them, I recommend you stick with one with the NEC chipset: http://www.newegg.com/Product/Produc...on=PCI+USB+2.0

Here's one I've used several times in the past and has always worked well: http://www.newegg.com/Product/Produc...82E16815124049
__________________
Remember: Data you don't have at least two copies of is data you don't care about.
spudmister's Avatar
spudmister spudmister is offline
Senior Member with 141 posts.
 
Join Date: Mar 2007
Location: Virginia
Experience: Advanced
11-Jan-2008, 12:31 PM #3
Funny I had just the opposite happen. The USB mouse would not work (machine never wold see it) on the laptops usb port but when I plugged in a usb hub, and pluggen the mouse into it..it started working..go figure
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
11-Jan-2008, 06:04 PM #4
Quote:
Originally Posted by spudmister View Post
Funny I had just the opposite happen. The USB mouse would not work (machine never wold see it) on the laptops usb port but when I plugged in a usb hub, and pluggen the mouse into it..it started working..go figure
That's the first time I've ever heard of it working the other way.
spudmister's Avatar
spudmister spudmister is offline
Senior Member with 141 posts.
 
Join Date: Mar 2007
Location: Virginia
Experience: Advanced
11-Jan-2008, 06:41 PM #5
Trust Me
Makes 2 of us...never seen that one before..
a c0mputer guru's Avatar
a c0mputer guru a c0mputer guru is offline
Junior Member with 1 posts.
 
Join Date: Feb 2008
Experience: Advanced
17-Feb-2008, 03:56 PM #6
Cool Found this on another forum
http://forums.windrivers.com/vb/showthread.php?t=31231

Apparantly Belkin has a bad batch of these things and are taking them back...from what I read on the thread....
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑