Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Games Games
Search Search
Search for:
Tech Support Guy > > >

None of my games work, DirectX 9.0b problem?


(!)

KAChris2351's Avatar
KAChris2351 KAChris2351 is offline
Junior Member with 6 posts.
THREAD STARTER
 
Join Date: Feb 2004
Location: Im my own little world!
14-Feb-2004, 10:55 PM #1
Question None of my games work, DirectX 9.0b problem?
I currently downloaded the patch for DirectX 9.0b and ever since, none of my games requiring DirectX have worked... they all come of up with similar errors all concerning DirectX or Direct3D. I have a GeForce2 video card (been meaning to update) and I'm thinking that it is because of this outdated video card. Warcraft III comes up with the error "Warcraft III was unable to initialize DirectX. Please ensure you have DirectX 8.1 or newer installed and that your display drivers are current. DirectX may be found on your Warcraft III CD under Options." The error for Diablo 2 is "Error 25: A critical error has occurred while initializing Direct3D." For other various games it comes up with something like "3D Graphics Not Supported!" or similar. I have all my drivers updated for my GeForce2 and I have tried installing older versions of DirectX like 8.1 and I have tried reinstalling DirectX 9.0b just to make sure that there were no problems while installing also I have looked at similar threads and none of them have helped... somebody please help?
kyleesgrandm's Avatar
kyleesgrandm kyleesgrandm is offline
Member with 38 posts.
 
Join Date: Jan 2004
14-Feb-2004, 11:43 PM #2
Question....we were wondering how you installed the older version of Direct X? We tried to get rid of Direct X 9 and couldn't.
KAChris2351's Avatar
KAChris2351 KAChris2351 is offline
Junior Member with 6 posts.
THREAD STARTER
 
Join Date: Feb 2004
Location: Im my own little world!
15-Feb-2004, 12:10 AM #3
It was on my WC3 CD and I just pressed install hoping that it would work.... it didnt though.
monkeyj's Avatar
monkeyj monkeyj is offline
Member with 201 posts.
 
Join Date: Aug 2003
Location: GA, USA
Experience: Intermediate
15-Feb-2004, 12:14 AM #4
KAChris2351's Avatar
KAChris2351 KAChris2351 is offline
Junior Member with 6 posts.
THREAD STARTER
 
Join Date: Feb 2004
Location: Im my own little world!
15-Feb-2004, 12:17 AM #5
I have already tried and update my drivers but it didnt do much, the same errors come up every time for all of the programs that need DirectX
Rollin' Rog's Avatar
Computer Specs
Member with 45,855 posts.
 
Join Date: Dec 2000
Location: North of Hollywoodland
Experience: I know when to fold em'
15-Feb-2004, 12:47 AM #6
What Windows version? If XP or ME, you can revert through "System Restore".

Try this fix first though. Some directx installs cause the DirectX3d button to incorrectly indicated that it is enabled when it is really disabled.

http://support.microsoft.com/default...b;en-us;812491
kowboi21's Avatar
kowboi21 kowboi21 is offline
Junior Member with 1 posts.
 
Join Date: Aug 2004
Experience: Computer Illiterate
21-Aug-2004, 03:46 PM #7
Direct3d acceleration isn't there
I tried that solution because i've been having trouble getting warcraft III to start. I get the usual can't find directx error even though I have the brand spanking new one. So anyway, when I open dxdiag and go to display, I can't enable or disable directdraw acceleration or direct3d acceleration because the option buttons aren't there. Like they're there but unclickable. It just says unavailable next to it. They were there once before. I did reinstall windows ME about 3 months ago and dind't take notice becuase I haven't had time to play games until now. know what I mean? And I dont' get it. Anyone help me, Please! Thanks
Graham
noob01's Avatar
noob01 noob01 is offline
Junior Member with 2 posts.
 
Join Date: Sep 2007
Experience: Beginner
11-Sep-2007, 03:35 AM #8
yeah i have the same problem with wracraft 3 to. I also can't ajust the enable or disable settings in the display tab. I played normally until the start of the year when they introduced a new patch. I deleted warcraft and re-installed, downloaded daemon tools, but now comes up with that error.
Krash's Avatar
Krash Krash is offline
Computer Specs
Member with 309 posts.
 
Join Date: Jun 2007
Location: India
Experience: Beginner
11-Sep-2007, 04:35 PM #9
Try this.

Use the tool - DirectX Eradicator 2.0 from here http://www.softpedia.com/get/Securit...adicator.shtml

Remove Direct X.
Update your drivers for the graphic card (make sure that these drivers are compatible with the version of Dx version you want to install).
Then install Dx9.0c straight.

If this doesnt do the trick. Use the same tool to remove Dx once again and install Dx 8.1 from the disc you got.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑