Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Games Games
Search Search
Search for:
Tech Support Guy > > >

Sims 2 Language Translator


(!)

simsluver's Avatar
simsluver simsluver is offline
Junior Member with 1 posts.
THREAD STARTER
 
Join Date: Feb 2005
Experience: Beginner
25-Feb-2005, 08:12 PM #1
Sims 2 Language Translator
Hi, I am new and I have a question about a Sims 2 game that I got off Ebay. Unfortunately, when I got it the game was the Thailand version, which I was unaware of until after I had bid on and purchased the game. The game is unplayable because the whole thing is in Thai and I cannot understand a thing! I figured out how to install it okay, but that is as far as I can get; nothing else. So, what I am asking is, is there any kind of converter or translator that will somehow convert the game during installation/setup to English? Please, please, please! If anyone knows how or where to get one reply.

Thanks a million!
nennapuppy's Avatar
nennapuppy nennapuppy is offline
Junior Member with 2 posts.
 
Join Date: Mar 2005
04-Mar-2005, 11:51 PM #2
Angry Having the same problem
Hi
I have the same problem. However I did at one stage have the english file to replace the Thai one with (so they do exist) but have since formatted my computer and no longer have it or the address of where to find it
So someone please help!!
Super-D-38's Avatar
Computer Specs
Member with 3,798 posts.
 
Join Date: Apr 2002
Location: Southern Oregon
05-Mar-2005, 12:09 AM #3
Have you tried to update it with an english patch?
Not sure if that would work but you can allways try.
nennapuppy's Avatar
nennapuppy nennapuppy is offline
Junior Member with 2 posts.
 
Join Date: Mar 2005
05-Mar-2005, 04:39 PM #4
Angry Having the same problem
The language needs to be changed before the game is installed or else the instructions are in Thai. I remember having to copy some folders from the CD and then replacing the language file with an English one before installing. I can't remember exactly how to do it and have no idea where to find this file. And of course the person I bought the game off is not responding to my emails and therefore not sending me the instructions.
ap10's Avatar
ap10 ap10 is offline
Junior Member with 2 posts.
 
Join Date: Mar 2005
Experience: Intermediate
21-Mar-2005, 03:49 PM #5
Sims 2 language change
Hi, I have some instructions on how to do the language change prior to installation. I haven't tried them as I don't own the game though. If anyone tries it, please let me know if it works. Here goes :

Disable autorun and insert disk 1 (this can be done by holding down the shift key while inserting the disk). Go to My Computer, right click on the cd drive with The Sims 2 in and select 'Explore'. Copy all the files and folders on the CD to the desktop. Open the file called 'Autorun' (on the desktop, not the CD), then the document 'Autorun.cfg' using Notepad. Find the line which reads 'Thai=1' and change to 'Thai=0'. Find the line reading either 'English UK=0' or 'English US=0' and change the 0 to a 1 (only one of them, not both). Save and close the file. Install from the desktop.

Hope this helps, and don't forget to reply if it works.
TennIdiot's Avatar
TennIdiot TennIdiot is offline
Junior Member with 1 posts.
 
Join Date: Apr 2005
Experience: Intermediate
01-Apr-2005, 03:43 PM #6
It Works
I tried your suggestion and it worked like a charm. Thought you might like to know.
ap10's Avatar
ap10 ap10 is offline
Junior Member with 2 posts.
 
Join Date: Mar 2005
Experience: Intermediate
02-Apr-2005, 03:20 PM #7
Thanks for the reply
Thanks for the reply. I also now have a Sims 2 Multilanguage Installation Disk which I can supply to anyone who needs it (for a small fee of course). This disk will install the game in a choice of about a dozen different languages. For an ebay seller who guarantees the games will be in English (or full instructions to install in English given) search for seller "esalestiger". Yes, it's me!
laughLOL's Avatar
laughLOL laughLOL is offline
Junior Member with 3 posts.
 
Join Date: Jul 2005
28-Jul-2005, 06:19 PM #8
Hi I have the same problem but unlike you I can't get those instructions to work!!!! Please help every time I go to save it says I can't because the file already exists and if I save it under another name it doe'snt work (when I press setup it does nothing) PLEASE HELP ME
Super-D-38's Avatar
Computer Specs
Member with 3,798 posts.
 
Join Date: Apr 2002
Location: Southern Oregon
28-Jul-2005, 08:15 PM #9
Welcome to TSG!!

It needs to be saved as the original name.. (The one that exists)
So, at the end of the existing one put ".orig" (without the quotes), then try to paste or save the new file.. It should be able to be placed now..

See the game looks for a specific named file, so the replacement needs to be the same as the original.. But you should keep the original, in case the replacement doesn't work.

If it works is another matter.. Just get it there with the correct name, and well move on from that point.
laughLOL's Avatar
laughLOL laughLOL is offline
Junior Member with 3 posts.
 
Join Date: Jul 2005
28-Jul-2005, 08:53 PM #10
Hi me again sorry I tried it but it did'nt work I still came up with nothing when I clicked on setup!! Thanks for the advice though!!!
laughLOL's Avatar
laughLOL laughLOL is offline
Junior Member with 3 posts.
 
Join Date: Jul 2005
28-Jul-2005, 11:25 PM #11
Smile Thanks
Thanks for all of your help but I figured it out don't ask me how because I don't really know myself well bye the!!!!
Soyers's Avatar
Soyers Soyers is offline
Junior Member with 2 posts.
 
Join Date: Aug 2005
Experience: Advanced
26-Aug-2005, 06:31 AM #12
Ive read several help posts on how to change the language once disc 1 has loaded BUT i need help before this.
When i am loading disc 1 i am asked where i would like to put the files, however, all of the pop ups and options are in Thai, and as my computer doesnt read symbols all i get to view is '????????', when i chose to place the files in C or desktop (or anywhere else for that matter) i am faced with another pop up with a great big red X and the following '??????????????? ??????? ????????' SO i am stuck of what the big red X pop up is saying (apart from- no i dont like it there), and what to do next!
Any help?
I am working on windows 98 with the Thai version of the sims2
cyberchik77's Avatar
cyberchik77 cyberchik77 is offline
Junior Member with 1 posts.
 
Join Date: Sep 2005
Experience: enough for basic stuff
02-Sep-2005, 06:13 PM #13
i did what apr1o said to do...but now i dont know what folder to open to install or whatever..or if i do or what...whenever i click on autorun or setup or sims orsomething it asks me to insert disk one and then it doesn't read it...HELP!
hermit63's Avatar
hermit63 hermit63 is offline
Junior Member with 4 posts.
 
Join Date: Sep 2005
Experience: Intermediate
03-Sep-2005, 04:02 PM #14
Uninstall your present game. I know this works as I have just done it. I hope this helps you. Copy disk 1 to a folder on your c:/ drive call it SIM2D1

Then look AUTORUN folder Using notepad open up autorun.cfg then alter the following lines.

Language sellection screen=0 change to Language sellection screen=1
English UK=0 to English UK=1
Thai=1 to Thai=0

Then save as autorun.cfg

Then click on autorun.exe and follow prompts
hp0416's Avatar
hp0416 hp0416 is offline
Junior Member with 2 posts.
 
Join Date: Sep 2005
Experience: Intermediate
29-Sep-2005, 03:07 PM #15
Quote:
Originally Posted by Super-D-38
Welcome to TSG!!

It needs to be saved as the original name.. (The one that exists)
So, at the end of the existing one put ".orig" (without the quotes), then try to paste or save the new file.. It should be able to be placed now..

See the game looks for a specific named file, so the replacement needs to be the same as the original.. But you should keep the original, in case the replacement doesn't work.

If it works is another matter.. Just get it there with the correct name, and well move on from that point.
I have the same problem. If I try to change the language and save the autorun file, it says it is read-only. I've also tried renaming the orignal as you suggested and also tried changing it from read-only, but it doesn't work.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑

Content Relevant URLs by vBSEO 3.3.2