Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Games Games
Search Search
Search for:
Tech Support Guy > > >

Warcraft 3 TFT and Hamachi problem


(!)

white0ut442's Avatar
white0ut442 white0ut442 is offline
Member with 39 posts.
THREAD STARTER
 
Join Date: Sep 2005
Experience: Intermediate
21-Apr-2007, 08:14 PM #1
Unhappy Warcraft 3 TFT and Hamachi problem
My friends are trying to play LAN on WC3:TFT through Hamachi, but it's not working. Whenever I or someone else create a game, nobody can see it. We can ping each other on Hamachi fine, but gaming is a no-go. What could be wrong?
Beef246's Avatar
Beef246 Beef246 is offline
Member with 132 posts.
 
Join Date: Jan 2004
22-Apr-2007, 11:21 AM #2
Sometimes for some strange reason when using hamachi, the computer will not use hamachis IP address, It will instead use the IP address of your router when used for gaming. Try hosting a LAN game and checking the IP there to see if it matches the hamachi one.
white0ut442's Avatar
white0ut442 white0ut442 is offline
Member with 39 posts.
THREAD STARTER
 
Join Date: Sep 2005
Experience: Intermediate
22-Apr-2007, 02:56 PM #3
Thanks for replying!

How would I check the IP from warcraft?
Beef246's Avatar
Beef246 Beef246 is offline
Member with 132 posts.
 
Join Date: Jan 2004
22-Apr-2007, 03:18 PM #4
Its been a long time since I played that but usually, when you host a LAN game it should display your IP address somewhere on the screen of the match setup
white0ut442's Avatar
white0ut442 white0ut442 is offline
Member with 39 posts.
THREAD STARTER
 
Join Date: Sep 2005
Experience: Intermediate
22-Apr-2007, 03:54 PM #5
It's not there.. I can't find it anywhere :/
It seems like a few others on the Hamachi forums are having the same problem, but I don't see anyone answering them. Most people have no problem with this, which troubles me.
blurvan's Avatar
blurvan blurvan is offline
Junior Member with 1 posts.
 
Join Date: May 2007
Experience: Intermediate
02-May-2007, 06:24 AM #6
i am having the exact same problems, i was just wondering if you managed to fix it.
i have forwarded ports 80 for hamachi and 6112 - 6119 for warcraft but we still cant see each others games.
does anyone have some advice?
white0ut442's Avatar
white0ut442 white0ut442 is offline
Member with 39 posts.
THREAD STARTER
 
Join Date: Sep 2005
Experience: Intermediate
02-May-2007, 08:40 PM #7
Still not fixed .....maybe fixed?
I also fowarded and nothing happened. On the hamachi forums, someone said to go into command prompt and type route -f
this worked for someone but i haven't tried it yet
romtale's Avatar
romtale romtale is offline
Junior Member with 1 posts.
 
Join Date: May 2007
06-May-2007, 01:12 AM #8
I have some other problems... I am hosting by not hamachi but by my LAN network connection and no1 joins I gotta wait so loong !! can someone help me ??? Ooh and I did exeption on firewall ... do I need any program ????
Overkill1010's Avatar
Overkill1010 Overkill1010 is offline
Computer Specs
Junior Member with 1 posts.
 
Join Date: Sep 2007
Experience: Intermediate
08-Sep-2007, 09:33 AM #9
Hi guys , i have the same problem but ive made it work!!
Simply use hamachi along with lancraft, and for some reason it works!

1)Decide who you want to play with. One of you should then host a LAN server normally (Make sure hamachi is on and you are both on the same hamachi network)

2)The other places lancraft.exe in the wc3 directory, starts it, enters the hosters ip (the one hamachi assigns) and clicks join.

3)Go to LAN and the game will be there!!

I dont know how this works, but I had the same problem, and with this method it always works now.
StFu.oR.dIE's Avatar
StFu.oR.dIE StFu.oR.dIE is offline
Junior Member with 1 posts.
 
Join Date: Nov 2007
Experience: Intermediate
01-Nov-2007, 10:40 AM #10
I'm playing warcraft III...the 1st time i download the hamachi ,my fren created a network and ive joined it.then i create a game and we can meet and play together,then in the night i create a network and ask my other fren to join,and then i create a game,but my fren cant find any game there in the LOCAL AREA NETWORK... what shud i do?
kr4zy4zn's Avatar
kr4zy4zn kr4zy4zn is offline
Member with 30 posts.
 
Join Date: Aug 2007
Experience: Intermediate
04-Dec-2007, 05:01 PM #11
Someone please solve this
noooooop's Avatar
noooooop noooooop is offline
Junior Member with 1 posts.
 
Join Date: Jan 2008
11-Jan-2008, 10:19 AM #12
I'm having the same problem. Anyone found a fix for this yet?
rhommel's Avatar
rhommel rhommel is offline
Computer Specs
Junior Member with 1 posts.
 
Join Date: Jan 2008
Experience: Beginner
20-Jan-2008, 11:52 AM #13
my game is not visible to others (and vice versa)
Hi, I had the same problem to play TFT with hamachi, also tried the hamachi/lancraft combination but it didn't work. I have a router and a LAN at home, and can play normally in this LAN, so I thought that warcraft was trying to use my "real" LAN instead of the hamachi "virtual" one.
Then I tried to join my friend's game (both us in the same hamachi LAN) using lancraft, providing his hamachi IP to lancraft, but it failed. He does not have a "real" LAN as I do, so I think that warcraft uses the IP of the connection being used to connect to the internet instead of the hamachi IP, so that having a real LAN really doesn't matter...
If lancraft forces the warcraft player who wants to join to use the hamachi IP (of the host player) then what is missing is a way to force the host to have its warcraft use the hamachi IP as well, but I really don't know how to do this, and I'm not preety confident on my assumptions either, so, can anyone help?
Thanks in advance
Rawrmae's Avatar
Rawrmae Rawrmae is offline
Computer Specs
Junior Member with 1 posts.
 
Join Date: Apr 2008
Location: A.C.T, Australia
Experience: Advanced
12-Apr-2008, 12:17 AM #14
Its really simple.

1. Make sure you all have the same Warcraft Version. (1.20e is recommended)
2. Uninstall Hamachi.
3. Download Hamachi 1.0.1.5
4. Reinstall Hamachi 1.0.1.5
5. Set up network
6. Play

If you still have problems after installing 1.0.1.5 your computer then:
1. Your computer hates you
2. You are gay
3. You should visit this link: http://logmeinwiki.com/wiki/Hamachi:..._Frozen_Throne
Teclcly's Avatar
Teclcly Teclcly is offline
Junior Member with 1 posts.
 
Join Date: Aug 2008
07-Aug-2008, 04:31 PM #15
Warcraft III often wont use the Hamachi connection by default.

Wc3 determines what IP to use dependent upon the Windows hierarchy for network devices. You need to move Hamachi to the top of this hierarchy in order for Wc3 to use that IP. You must do this on ALL computers that will be playing Wc3.

1. Open Network Connections.
2a. (VISTA) Press ALT to activate the Menu Bar.
2b. Click "Advanced" found in the menu bar.
3. Click Advanced Settigns (Opens the "Advanced Settings" dialog box).
4. In the top box, select "Hamachi".
5. Click the up arrow to the right until hamatchi is at the top.
6. Click "OK"
7. Restart/Start Wc3
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑

Content Relevant URLs by vBSEO 3.3.2