Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Games Games
Search Search
Search for:
Tech Support Guy > > >

Sims 3 - No supported graphics card error


(!)

Cleric's Avatar
Cleric Cleric is offline
Computer Specs
Junior Member with 25 posts.
THREAD STARTER
 
Join Date: Nov 2006
Location: Florida
Experience: Intermediate
24-Jun-2009, 05:15 PM #1
Sims 3 - No supported graphics card error
Hello all,

I'm not sure if this question has been asked and answered quite yet, but I could not find it anywhere on the forums, and since each case is slightly different due to different system set ups, I figured I'd go ahead and throw this out there.

Every time I try and run The Sims 3, I repeatedly get the same error message over and over again:
"Unable to start game

Device 0 cannot run this title.
No supported video graphics card detected. Please check your system hardware."

I don't know why I am getting this message since when I built this computer I put an Nvidia 9800GTX in it, and that card is most definitely supported by the game. I have tried all sorts of solutions such as updating my video drivers (which I have done twice now since Nvidia released another new driver on the 18th), updating DirectX, changing my monitor's screen resolution, going in to the task manager and ending all non-essential tasks to see if there was a process interfering with the game, etc... I even emailed EA customer support to ask them if there was a solution, and they gave me what seemed like a copy-and-paste response email with a bunch of solutions that I had already tried or ones that didn't work, which indicated to me they never actually read what I wrote to them. It makes me wonder why they even asked for a DxDiag file from me. Anyway, I'm including a DxDiag printout along with my post here, so if anyone out there reads this and has some sort of solution that I might try to get this thing up and running, I'd be greatly appreciative.

Many thanks,
Cleric
Attached Files
File Type: txt DxDiag.txt (50.0 KB, 915 views)
Elvandil's Avatar
Computer Specs
Moderator with 51,993 posts.
 
Join Date: Aug 2003
Location: Vermont
Experience: "Been through the mill."
24-Jun-2009, 05:23 PM #2
If you updated the drivers, you might try uninstalling and reinstalling the game in case it detects the card during installation.

Do you have your slider for troubleshooting all the way to the right? Are all DirectX features available? Try running the DirectDraw and Direct3D tests in dxdiag.

Do you have more than one card listed under Display Adapters in Device Manager?
__________________
Microsoft MVP
異驚の界世 ípןɹoʍ ǝɥʇ ɟo sɹǝpuoʍ ǝɥʇ ɟo ǝuo sı ǝpoɔıun ʞuıɥʇ ı
lanaerin's Avatar
lanaerin lanaerin is offline
Junior Member with 6 posts.
 
Join Date: Jun 2009
Experience: Advanced
24-Jun-2009, 06:29 PM #3
I am having the same problem and I went so far as calling my computers manufacturer- Stayed on the phone for 2.5 hrs and no help. I've spoken with 5-6 EA Games reps, no help either. I did the e-mail thing too, they tell you the BASIC reasons why it won't work (I.E your video card isn't strong enough....but my card is supported.) I have seen quite a few blogs/forums/Yahoo! questions with this very same problem.....None of which have answers...
Cleric's Avatar
Cleric Cleric is offline
Computer Specs
Junior Member with 25 posts.
THREAD STARTER
 
Join Date: Nov 2006
Location: Florida
Experience: Intermediate
24-Jun-2009, 10:36 PM #4
Thank you for your speedy response, Elvandil.

Unfortunately, uninstalling and reinstalling did not work. And all of the DirectDraw tests and Direct3D tests were successful, no problems. Also, there is only one card listed under Display Adapters in the Device Manager, the GeForce 9800 GTX. Everything seems to be in order, but I am still as stumped as ever. I am about ready to snap the game disc in half and call it a day, heh. Any other suggestions or ideas?
lanaerin's Avatar
lanaerin lanaerin is offline
Junior Member with 6 posts.
 
Join Date: Jun 2009
Experience: Advanced
24-Jun-2009, 10:39 PM #5
Try running device manager in admin mode and click View-> Show hidden

See if another display adapter shows up then.

my old video card showed up when i tried that... I uninstalled it and reinstalled the new drivers.... it worked for my neighbor but not for me
Cleric's Avatar
Cleric Cleric is offline
Computer Specs
Junior Member with 25 posts.
THREAD STARTER
 
Join Date: Nov 2006
Location: Florida
Experience: Intermediate
24-Jun-2009, 10:47 PM #6
Ah yes, Windows is a very sly piece of software with its hidden content everywhere, but still just the one display adapter even when displaying the hidden devices.
lanaerin's Avatar
lanaerin lanaerin is offline
Junior Member with 6 posts.
 
Join Date: Jun 2009
Experience: Advanced
24-Jun-2009, 10:58 PM #7
Jinkies. I think we're stuck either waiting for the patch, or mailing our game back to EAGAMES for a refund.

What kills me is that I can play games like WOW on FULL settings and do 25man raids and have no lag. I'm at a lost with this one. EAGames is getting on my bad side!
Cleric's Avatar
Cleric Cleric is offline
Computer Specs
Junior Member with 25 posts.
THREAD STARTER
 
Join Date: Nov 2006
Location: Florida
Experience: Intermediate
24-Jun-2009, 11:07 PM #8
Yeah, back when I used to play WoW I could run everything maxed out and have no problems with lag or anything. Now I mainly play TF2 and L4D, and have the graphics set pretty high with no issues running either game. It is pretty frustrating when I look at it that way, but hopefully someone will have a solution to the issue before I decide to send the game back.
Cleric's Avatar
Cleric Cleric is offline
Computer Specs
Junior Member with 25 posts.
THREAD STARTER
 
Join Date: Nov 2006
Location: Florida
Experience: Intermediate
25-Jun-2009, 10:05 AM #9
A small update on the situation:

I updated my question to EA using their customer support system and pretty much told them that if they cannot offer me a solution I haven't tried yet or at least produce a response more personalized to my specific needs than a broad spectrum template email, then I am going to be sending the game back for a refund. I do not mind retrying solutions if the circumstances on my system change or something, but it didn't even seem like they actually read my original support ticket, so they are not exactly blessed with the luxury of my patience at the moment.

Still, if anyone out there has some ideas to fix the problem, I'm more than willing to give it a go. Don't let my frustration with EA discourage brain storming. EA is supposed to be a professional company and when I asked them about their product they didn't even take the time to address the issue with a real email, and this is a voluntary message board, so the situation is a little different here, heh.
baboongoof's Avatar
baboongoof baboongoof is offline
Junior Member with 1 posts.
 
Join Date: Jun 2009
26-Jun-2009, 11:15 PM #10
Same problem
I have the same problem, with a brand new gaming PC with slick graphics cards. The thing is... it worked earlier. I spent the day playing it before I came back and got this error. I've since uninstalled and reinstalled the game, my drivers, AND reinstalled Windows just for kicks. It is infuriating. I hope somebody figures out what's going on here.
peterh40's Avatar
Computer Specs
Member with 1,239 posts.
 
Join Date: Apr 2007
Location: England
Experience: Advanced
27-Jun-2009, 07:16 AM #11
TRy changing the options.ini file so that the game runs in Windowed mode:

1. Open C:\Users\username\My Documents\Electronic Arts\Sims 3
2. Open Options.ini in Notepad
3. Change line fullscreen=1 to fullscreen=0
4. Save file and exit
5. Try game again.
Cleric's Avatar
Cleric Cleric is offline
Computer Specs
Junior Member with 25 posts.
THREAD STARTER
 
Join Date: Nov 2006
Location: Florida
Experience: Intermediate
27-Jun-2009, 09:23 AM #12
Well, since I've never actually gotten the game to run even once, there was no options.ini file. But I went ahead and created one with the single line "fullscreen=0". Unfortunately, this did not work, but that could very well be because I do not have the rest of the code lines for the options.ini file.
lanaerin's Avatar
lanaerin lanaerin is offline
Junior Member with 6 posts.
 
Join Date: Jun 2009
Experience: Advanced
27-Jun-2009, 02:40 PM #13
I had someone send me a copy of the options file with the Fullscreen changed. Still did notwork.

Last night I got SO frustrated, I reformatted, for kicks. Did it work, you ask? HELL NO. Now the the can you run it thing answers change every time I click it now.
peterh40's Avatar
Computer Specs
Member with 1,239 posts.
 
Join Date: Apr 2007
Location: England
Experience: Advanced
28-Jun-2009, 07:41 AM #14
Some other things to try:
1. Update or switch graphics card drivers. Drivers supplied with new cards may be older than you think.
2. Change screen resolution to standard modes eg. 800x600, 1024x760, 1280x1024
3. Change the colour resolution - 16bit or 32bit
4. Adjust the hardware acceleration slider (try maximum first, then lower it and see if it makes a difference).
See http://www.pptfaq.com/FAQ00129.htm.
5. If you have two graphics cards (or a graphics card and an internal one), make sure you TURN OFF the one you are not using or unplug it, if you can.

Last edited by peterh40; 28-Jun-2009 at 07:41 AM.. Reason: URL for h/w acceleration faq.
Cleric's Avatar
Cleric Cleric is offline
Computer Specs
Junior Member with 25 posts.
THREAD STARTER
 
Join Date: Nov 2006
Location: Florida
Experience: Intermediate
28-Jun-2009, 03:17 PM #15
I tried a lot of these already, but a couple I had not. For the hell of it I did them all but still no luck. Unless EA comes out with a statement addressing this issue specifically, I do not think that it will be fixed. The good news is, since it seems that a lot of people are having this error when they shouldn't be (i.e. because their system meets the requirements), EA will likely have to fix it soon. So now we begin the waiting game...
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑