Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Hardware Hardware
Search Search
Search for:
Tech Support Guy > > >

Solved: Motherboard Wont Detect Speakers In Windows 7


(!)

Ram012593's Avatar
Ram012593 Ram012593 is offline
Computer Specs
Junior Member with 12 posts.
THREAD STARTER
 
Join Date: Sep 2011
Location: Massachussets
Experience: Computer Illiterate
07-Oct-2011, 09:06 PM #1
Solved: Motherboard Wont Detect Speakers In Windows 7
Ok here is my problem. First off I have an ASUS Crosshair V Formula Motherboard.

>When I install Ubuntu my audio works perfectly.

>When I install Windows 7 ultimate 64 bit and install the chipset drivers and audio drivers that come on the cd that came with the motherboard and the ones off there website the computer wont detect my speakers.

> When I have my audio controller in my BIOS set to HDMI output and I boot up windows and right click on the speaker in the bottom right and go under playback devices it just says Realtek HDMI output.

>When I have my audio cotroller set to SPDIF output and right click on the speakers it just says SPDIF output.

>In both occasions there are speakers listed in the playback devices but no matter what I plug into any audio jack it says they are not plugged in. (And ive tried my speakers and different headphones into both the front and rear audio jacks in every possible combo plus my speakers work fine on my laptop.)

> I also went into control panel and into the device manager and uninstalled the audio drivers and reinstalled them both from the ASUS website and from the cd that came with my mobo.

>The last things I tried is to reinstall Ubuntu and again the sound worked perfectly.

>I then immediately installed Windows again and even after reinstalling the chipset drivers and the audio drivers Windows did not detect that anything was plugged in.

Normaly I wouldnt mind just leaving Ubuntu as my OS however I am a gamer and all the games that I play only work on Windows.

This is FRUSTRATING me severly so any help would be greatly appreciated. THANKS IN ADVANCE!!!!
Oddba11's Avatar
Member with 3,848 posts.
 
Join Date: May 2011
Experience: Advanced
09-Oct-2011, 02:38 AM #2
A few thoughts. You would only select the HDMI output, if you are using the HDMI output for your audio. Speaker detection is hardware and driver based. And unless I'm mistaken, speakers won't show connected via a digital output (ie: HDMI or SPDIF). Also, if you are testing using the "rear jacks" and "front panel", then it sounds like you are using the 3.5mm analog jacks. In which case, you wouldn't select SPDIF in the audio setup.
Ram012593's Avatar
Ram012593 Ram012593 is offline
Computer Specs
Junior Member with 12 posts.
THREAD STARTER
 
Join Date: Sep 2011
Location: Massachussets
Experience: Computer Illiterate
09-Oct-2011, 11:13 AM #3
Ok i got the sound working now by reinstalling windows and installing some random old realtek drivers.
Then reinstalling the new ones on top of it. However now windows thinks my back ports are my front ones. This is preventing me from using my microphone headset in the front jacks. Also i found out u were right i had to set it to hdmi not spdif.

Thanks tons for the help!

If anyone could help me with the whole windows thinking my back anolog jacks are the front ones it would be great?

Also under recording devices it shows that i have a mic plugged in even though i know i dont. This isnt that much of a bother exept that it doesnt make sense.
Oddba11's Avatar
Member with 3,848 posts.
 
Join Date: May 2011
Experience: Advanced
09-Oct-2011, 11:38 PM #4
There are known driver issues with Win7 and Realtek. I could never get it work properly on my older motherboard (Asus M2N Sli-Deluxe). I can only suggest testing different driver versions until you find one that works for you.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑