Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Search Search
Search for:
Tech Support Guy > > >

WD Passport unplugged while in use


(!)

hoff88's Avatar
hoff88 hoff88 is offline
Member with 1 posts.
THREAD STARTER
 
Join Date: Mar 2012
05-Mar-2012, 04:28 PM #1
WD Passport unplugged while in use
I have a WD Passport that got unplugged while I was watching a movie on it, and ever since when I plug it in it beeps for a little bit them comes up as "USB Mass Storage Device" under safely remove hardware, and the light still comes on. The password window does not come up like it used to nor can I access it from My Computer. I checked the USB ports that I'm plugging it into, thay're not the problem, and I'm running Windows Vista on the computer I use it with. I'm worried that it might be completely shot, but I hope that it can be salvaged.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


Tags
hard drive, passport, troubleshooting

(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑