Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Hardware Hardware
Search Search
Search for:
Tech Support Guy > > >

Capture Card not working on my computer


(!)

TheMcMillionator's Avatar
TheMcMillionator TheMcMillionator is offline
Member with 2 posts.
THREAD STARTER
 
Join Date: Mar 2012
19-Mar-2012, 03:01 PM #1
Unhappy Capture Card not working on my computer
My capture card doesn't work on my computer, but it works on my sister's. I am using a Sabrent USB-AVCPT device. My first capture card I ever used was a Mygica EZGrabber2 and it worked fine until it suddenly stopped working. since then I've had the USB-AVCPT and the Sabrent VD-GRBR Capture Box and they both haven't worked. Everytime I try to capture the software says: "capture card could not be opened. make sure it is plugged in correctly and not being used by another program" or "Unable to switch to capture mode. Check to see if drivers are installed correctly. Failed to build a Preview graph." or "No input signal or signal is unclear." The device shows up in device manager and it says its working properly but those messages come up when I try to capture and there is a blank screen. I installed and uninstalled the drivers and software to no avail, but like I said, it works on mu sisters PC perfectly. My PC and my sister's both run Windows 7. My computer is an
eMachines EL1850G-42w and hers is a Compaq. I updated all the latest drivers and my video card and my capture card still isn't working.
Attached Thumbnails
Capture Card not working on my computer-example.png  
Oddba11's Avatar
Member with 3,848 posts.
 
Join Date: May 2011
Experience: Advanced
21-Mar-2012, 07:02 PM #2
Check the device status in Device Manager to ensure it is installed correctly and properly recognized. If the software was installed before the capture card, you may want to uninstall, reboot, and then reinstall the software.
TheMcMillionator's Avatar
TheMcMillionator TheMcMillionator is offline
Member with 2 posts.
THREAD STARTER
 
Join Date: Mar 2012
21-Mar-2012, 08:07 PM #3
I already did. It says that the device is working properly and I unistalled and reinstalled the software and the same messages still come up.
Compiler's Avatar
Computer Specs
Member with 5,855 posts.
 
Join Date: Oct 2006
Location: Dallas
Experience: Advanced
22-Mar-2012, 12:01 AM #4
Sorry, but Sabrent is a generic computer accessories company. They buy stuff, stick their name on it and sell it to the public. I have a Sabrent brand USB external 2.5" Drive enclosure... worst one I ever bought in terms of functioning properly.

Looking at what is said on Newegg... its pretty bad reviews for their products, not reliable.

I bought this for $50, http://www.newegg.com/Product/Produc...82E16815144044 And it works quite good for me. I use it on 3-4 of my computers, the software is pretty good. I have converted my VHS collection to a single 2TB HD and then sent the tapes to a recycle center.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


Tags
capture, driver, failure, sabrent, video

(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑