Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Search Search
Search for:
Tech Support Guy > > >

External HD suddenly not found.


(!)

Grims's Avatar
Grims Grims is offline
Member with 1 posts.
THREAD STARTER
 
Join Date: Aug 2012
Experience: Intermediate
18-Aug-2012, 05:55 PM #1
External HD suddenly not found.
To explain the situation, I have an external USB hard-drive from western digital that I use for storing movies etc. A few days ago, suddenly the harddrive cannot be seen among the other drives in My Computer. I've pulled out and reconnected cables, restarted the computer, tried plugging it into another port and tried connecting it to another computer. It just no longer shows up among the different stations in My Computer, but I do find it when I look at the hardware list in control panel. In the details it's described as not initialized. Also, the computer makes that "dadum" sound whenever I connect or disconnect the HD, but as I said it doesn't show up when I do this. I've also reinstalled drivers and deactivated/reactivated the HD, but it still doesn't show up among the other drives as a useable drive, and it still says "not initialized" in the details when I look it up on the hardware list in control panel.

I've got about 1.8 terras of stuff on it, both movies and also backup storage for another laptop, so I'd really like to be able to get the HD working again without losing this.

It's about a year old, and it has not been moved or otherwise taken damage when it failed (though it has been moved around and been put in backpacks before, but it's worked afterwords. I've had a problem with it once before 3-6 months ago when it also "disappeared", but it "came back" within a day and was fully functional without me really doing anything. In this instance I think it went away as a result of me yanking out the USB and shutting down the computer while watching a movie stored on the HD but it just came back a day later or so on it's own.

The HD makes a very faint clicking noise when connected to both power and my computer, and the light on the back is constant. The clicking noise is a similar to the sound it makes when I'm accessing data, except when I access data the sound is chaotic and random, wheras now it's rhythmic. When I disconnect the USB (while keeping power connected) both the clicking and the light goes out, the clicking immediately and the light after blinking for a few seconds. When I reconnect it the light starts blinking for maybe half a minute to a minute before it stays constant, the clicking starts a little while before that.

The computer is a dell xps laptop running windows 7 and the HD is a western digital 2 TB harddrive with supplemental power if that makes any difference.

Last edited by Grims; 18-Aug-2012 at 06:20 PM..
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


Tags
external harddrive

(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑