Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Hardware Hardware
Search Search
Search for:
Tech Support Guy > > >

cannot install any new USB device


(!)

sequoia55's Avatar
sequoia55 sequoia55 is offline
Computer Specs
Junior Member with 1 posts.
THREAD STARTER
 
Join Date: Nov 2006
Experience: Intermediate
12-Nov-2006, 08:50 PM #1
cannot install any new USB device
I've tried installing USB devices recently and for all new USB device installation, I get an error message that says:
"There was a problem installing this hardware:
USB 2.0 Hub controller (or shows the appropriate USB device)
An error occurred during installation of the device.
The data is invalid"

This message came up when I tried to install a D-Link 4 port USB hub. I'm able to install the hub on other computers with no problems. I've tried this USB hub on all USB ports on my laptop - no difference. I do have other USB devices that are working OK on this laptop so I know USB does work.

I've also had a similar problem recently preventing me from installing any/all USB devices including a USB memory card reader, a USB Logitech webcam, etc. I get the same line at the end of the error that states "The data is invalid".

The USB hub controller installation tries to use Windows 'Generic USB Hub' driver for the installation. It shows up in Device Manager as a 'USB 2.0 Hub Controller' so the device is being recognized correctly, just not installing the driver correctly. The Logitech USB webcam shows up as a 'USB device' in Device Manager but it does say 'Logitech USB Camera (Fusion)'.

Any suggestions on what may be causing the error "The data is invalid" and blocking all USB device installations? Any ideas on how to correct this problem?

My system is a Compaq Presario R4000 laptop (Athlon 64) with Windows XP Pro SP2. USB devices I have installed and working correctly are a IOGear USB 7-port hub, USB external HDD, USB KVM, USB printer.
Rollin' Rog's Avatar
Computer Specs
Member with 45,855 posts.
 
Join Date: Dec 2000
Location: North of Hollywoodland
Experience: I know when to fold em'
13-Nov-2006, 12:32 AM #2
First set a System Restore point and test it: start > run: msconfig > Launch System Restore.

The standard approach to these problems is to remove all the USB devices in the Device Manager and let Windows reinstall them. But there is a special technique to it.

I am uploading a registry patch you will need to download, unzip and run. Confirm the merge to the registry.

It is the patch described in JohnWill's note here:

http://forums.techguy.org/hardware/4...ml#post3435808

Once you have installed the patch, follow the rest of his instructions.

Note: in some cases Windows does not have the proper install path for the information files required. If the New Hardware Wizard prompts you for an install location, point it to:

c:\windows\INF

or if c is not your root drive just use %systemroot%\INF

This is a hidden directory, so you will need to have "show Hidden Files" enabled in Folder Options > View to see it.
Attached Files
File Type: zip usbghosts.zip (247 Bytes, 4437 views)

Last edited by Rollin' Rog; 13-Nov-2006 at 12:37 AM..
gfxrelay's Avatar
gfxrelay gfxrelay is offline
Member with 588 posts.
 
Join Date: Oct 2005
Location: 127.0.0.1
Experience: A button!
13-Nov-2006, 10:42 AM #3
Haunted
Your USB ports are haunted! Who you gonna call? Does it do it with all of your USB ports or just some. It could be a driver issue or a blown port. Go into the device manager. If you see a yellow exclamation mark next to the usb devices it is just a driver issue. If not it could be that he ports are blown
Rich-M's Avatar
Computer Specs
Member with 22,220 posts.
 
Join Date: May 2006
Location: Eastern Pa
Experience: Advanced
13-Nov-2006, 11:16 AM #4
If I read this correctly, I cannot help but wonder if a laptop can power 2 usb hubs to begin with. Aree both connected at same time?
rarprior's Avatar
rarprior rarprior is offline
Computer Specs
Junior Member with 1 posts.
 
Join Date: Jul 2007
Experience: self taught... patchy details
16-Jul-2007, 10:09 AM #5
Same issue
I have the same issue though my motherboard seems ok thankfully!

after using the reg. file and proceeding with the unistalling of the usb drivers, rebot. Now im being presented with the same problems...

The usb root hub went in ok but the individual usb controllers when installing came up with the data invalid error!

Im at a loss of what to do and will try anything to avoid reinstalling windows...
gfxrelay's Avatar
gfxrelay gfxrelay is offline
Member with 588 posts.
 
Join Date: Oct 2005
Location: 127.0.0.1
Experience: A button!
16-Jul-2007, 10:20 AM #6
It seems to be a problem between Windows and some USB devices I get the same error when I try to install a printer on my computer I think the only way to repair this is to re-install windows
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑