Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Hardware Hardware
Search Search
Search for:
Tech Support Guy > > >

Computer won't recognize DVD drive


(!)

pr0wler's Avatar
pr0wler pr0wler is offline
Member with 118 posts.
THREAD STARTER
 
Join Date: Aug 2002
07-Dec-2006, 04:23 AM #1
Computer won't recognize DVD drive
Ok so my DVD drive in my computer turns on fine, I can open it and put in CD's/DVD ok, but when I go to 'My Computer' it doesn't show up. In addition, CD's that normally autoplay won't automatically play on my screen. Everything has been fine for like 10 months up until today - i tried reboot but I'm not sure what else to do.
tinkthelizard's Avatar
tinkthelizard tinkthelizard is offline tinkthelizard has a Profile Picture
Computer Specs
Senior Member with 215 posts.
 
Join Date: Apr 2006
Experience: Advanced
07-Dec-2006, 07:43 AM #2
check the IDE cable within your machine that attaches to your drive and to your motherboard.
If this is loose or the cable is faulty, your drive will still open and close etc since the power cable is still running to it, but theres no data being passed from it to the motherboard.
buddythedog's Avatar
buddythedog buddythedog is offline
Senior Member with 284 posts.
 
Join Date: Feb 2005
Experience: Intermediate/Advanced
07-Dec-2006, 09:00 AM #3
Look in Device Manager for information. Drive listed as working? Any problem codes?
pr0wler's Avatar
pr0wler pr0wler is offline
Member with 118 posts.
THREAD STARTER
 
Join Date: Aug 2002
07-Dec-2006, 04:31 PM #4
Hmm...not good - it gives me this msg saying like "The device drivers are installed, but the hardware doesn't exist" or something. I also tried putting in a CD/RW drive on my other computer into my current one...and again the thing doesn't show up under my computer. I tried both of the available IDE cables, and still no luck.
Triple6's Avatar
Triple6   (Rob) Triple6 is offline
Computer Specs
Moderator with 42,807 posts.
 
Join Date: Dec 2002
Location: Canada
Experience: Advanced
07-Dec-2006, 04:41 PM #5
Easy fix for that.

Copy the following into a blank Notepad, save it as FIXCD.REG, and then double click on the file to merge it into the registry. Reboot the computer and the drive should be back.


REGEDIT4

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}]
"UpperFilters"=-
"LowerFilters"=-

[-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdr4_2K]

[-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdralw2k]

[-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdudf]

[-HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\UdfReadr]
MysticEyes's Avatar
Computer Specs
Account Disabled with 4,825 posts.
 
Join Date: Mar 2002
Location: USA
Experience: Semi-advanced
07-Dec-2006, 05:09 PM #6
Or for those who fear the registry there's this.

http://www.dougknox.com/xp/scripts_d...cd_dvd_fix.htm
pr0wler's Avatar
pr0wler pr0wler is offline
Member with 118 posts.
THREAD STARTER
 
Join Date: Aug 2002
07-Dec-2006, 05:17 PM #7
WOW thank you guys. I tried the notepad registry method and it worked perfectly and the DVD drive is now recognized - never thought there would be such a simple solution. You guys are genius's. Thx again!
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑