Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Hardware Hardware
Search Search
Search for:
Tech Support Guy > > >

Toshiba laptop power cord failure


(!)

digitalruki's Avatar
digitalruki digitalruki is offline
Computer Specs
Junior Member with 3 posts.
THREAD STARTER
 
Join Date: Mar 2007
Experience: Beginner
03-Mar-2007, 10:32 PM #1
Toshiba laptop power cord failure
I have a Toshiba satellite a55-s209. I've had it for two years, and this problem arose about 4 months ago. Sometimes, my power cord stops working. I'm not sure what's going on, but basically the light on the front of the laptop that indicates wether the cord is connected turns off and my laptop goes into long-life battery mode, as if I've pulled the cord out. At first, jiggling or twisting the cord helped. More recently I've taken to inserting the cord at different angles until the computer recognizes the charge.

I tried another power cord, one of those all-in-one laptop power cord converters. It didn't work either, but I'm not sure if it was the wrong type or if the problem is with my laptop. Is there something I can do to my cord that will help? Is it my computer that's not working?

Any info or tips are much apreciated.
kiwiguy's Avatar
Member with 17,584 posts.
 
Join Date: Aug 2003
Location: New Zealand
03-Mar-2007, 11:20 PM #2
Your description suggests that the laptop has a damaged DC power jack, where the power cord (from the AC adapter) plugs in.

This is very serious, but if you get repairs done before you use it again it may save the cost of a new motherboard. If you use it without immediate repair, it might be "too late" to save its life.

The power will be arcing at the "poor connection" point in the damaged jack, this can permanently the motherboard inside the laptop, as the power jack is soldered to the laptop.

This problem is not at all uncommon with laptops.
digitalruki's Avatar
digitalruki digitalruki is offline
Computer Specs
Junior Member with 3 posts.
THREAD STARTER
 
Join Date: Mar 2007
Experience: Beginner
04-Mar-2007, 08:51 AM #3
I've heard that you can hook the hard drive up to another computer to retrieve files... if my computer is beyond repair, could I possibly do this?
rodeognome's Avatar
Member with 1,318 posts.
 
Join Date: Dec 2003
04-Mar-2007, 09:10 AM #4
Yes - its not that hard. Step usually involved are

1) Remove HDD from laptop.

2) Remove plastic cover off PINS

3) User 2.5 > 3.5 Adaptor so a desktop PC can read it

4) Attach this adaptor to an IDE cable on the desktops motherboard.

5) The laptop hdd should appear as an extra letter in "My Computer"



Kiwiguy - a damaged DC powerjack is a very common problem alright - what kind of sucess rates have you had with this problem?
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
04-Mar-2007, 10:46 AM #5
If you don't deal with it, this is what is likely to happen, then the MB is most certainly toast! You need to deal with the issue before this happens.

I've had 100% success in fixing the jacks if I get to them before a short occurs. Although they're somewhat expensive, I've found that www.laptopjacks.com has the exact replacements in most cases.

__________________
Remember: Data you don't have at least two copies of is data you don't care about.
rodeognome's Avatar
Member with 1,318 posts.
 
Join Date: Dec 2003
04-Mar-2007, 11:34 AM #6
Cool photo Johnwill!

A stitch in time saves nine...do the jacks have to be welded on?
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
04-Mar-2007, 11:38 AM #7
Welded? No, just soldered.

That photo was actually the second laptop I got with the issue, this one I was present while the owner "demonstrated" what her problems was. Before I could say how bad an idea it was to wiggle the jack, flames were shooting out the back of the machine! Needless to say, it required a new motherboard. I happened to have the MB handy, since another of these laptops had been partially run over and destroyed the LCD, but the MB survived.
digitalruki's Avatar
digitalruki digitalruki is offline
Computer Specs
Junior Member with 3 posts.
THREAD STARTER
 
Join Date: Mar 2007
Experience: Beginner
04-Mar-2007, 12:19 PM #8
I let a self-proclaimed laptop expert fool around with my laptop, to see if he could fix it. He did a couple of things before he tried to dissasemble it: he took out the battery and put it back in, and then he screwed the back screw in tighter (telling me that it was loose and that was why I was having problems with it), and now the jack works (for the time being). I don't think it's fixed, but I'm backing up my harddrive while its running anyway. Was tightening the screw what did it? Is my laptop fixed or not?
digitalruki's Avatar
digitalruki digitalruki is offline
Computer Specs
Junior Member with 3 posts.
THREAD STARTER
 
Join Date: Mar 2007
Experience: Beginner
04-Mar-2007, 12:27 PM #9
update: the jack stopped working again, turns out it wasn't fixed. argh.
qblitz's Avatar
qblitz qblitz is offline
Member with 81 posts.
 
Join Date: Jun 2001
Location: MD
04-Mar-2007, 05:51 PM #10
Exact same symptoms happened with my hp pavilion at about the same 2 1/2 lifecycle. I took it to a place. They said they metered the incoming current to the motherboard and claimed it was normal They tried replacing parts, ram, etc. but nothing fixed the problem. They said i would have to replace the motherboard. This is where I sit now. Does that make sense? They said it would cost under $500 for a refurbished board. What should i do.

BTW - see my qblitz post. when i told them i would take it and think about it for a while, I find that I cannot restart, even under batter power. See my qblitz post for symptom. John Will, can you help. Please!
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
04-Mar-2007, 07:19 PM #11
See the picture in post #5, you'll be seeing that soon if you don't fix the jack and stop screwing around trying to take half measures.
qblitz's Avatar
qblitz qblitz is offline
Member with 81 posts.
 
Join Date: Jun 2001
Location: MD
04-Mar-2007, 07:50 PM #12
Let me try this again.
I took my laptop to a company that advertises itself as a place that fixes laptop. they charged me $45 to diagnose the problem.
They said that it definitely was not a broken connector. they said they put meters and measured the incoming voltage. The voltage was normal.

Is that consistent with a broken connector?

They said that they then started replacing parts. they said nothing made a difference. then by a process of elimination, they said wanted to replace the motherboard.

Is that how you would do it?

I told them not to touch anything, but button the box back up.
i am not keen on replacing the motherboard with a refurbished boards.

Do you agree?

When i got the laptop back, it would no longer boot up, on either external or internal power. with the cord plugged in, i get nothing. with it pulled, the on indicator light comes on, but the system does not boot?

Could they have broken something else?

Could it always have been a connector, but they told me it was the motherboard, so that they could charge me more money but not replace the motherboard. Now to cover their tracks, could they have broken the board?

Other opinions?
digitalruki's Avatar
digitalruki digitalruki is offline
Computer Specs
Junior Member with 3 posts.
THREAD STARTER
 
Join Date: Mar 2007
Experience: Beginner
04-Mar-2007, 08:14 PM #13
This time we took the laptop apart, cleaned out the dust, and re-soldered the power jack as directed by a do-it-yourself resolder-your-jack website tutorial. When we took it apart we saw that it was burned a little where it had been soldered originally, but not that much.

Also, i was suprised how little dust i had inside--judging by how many times it has overheated and shut off, I thought the dust would be caked on, but there was barely any. From what I've read in Toshiba Satellite reviews, the the overheating and jack failures seem to be common in this model.

I'm going to start saving up for a new machine, are there any out there that don't have these problems?
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
04-Mar-2007, 08:15 PM #14
Your first symptom description screams power jack problem, I'll be surprised if it turns out to be something else. They broke the machine, I'm not sure where you go from here.
captain_hug99's Avatar
captain_hug99 captain_hug99 is offline
Computer Specs
Junior Member with 1 posts.
 
Join Date: May 2007
Location: VA
Experience: Advanced
08-May-2007, 06:57 PM #15
I have a similar problem, but wasn't sure if I should start a new thread or not. This is my problem. I have an A25-S2792 Toshiba Laptop. The original battery charger just died on me about 10 months ago. Jiggling didn't help at all. I bought a new battery charger online, plugged it in and it worked just fine.

That battery charger started having problems internally. It seemed to be arching inside the transformer box (at least that's what I call the boxy part). The green light would dim and flicker. I stopped using it, ordered a new battery charger and sent the old one back for repair or replacement (it was replaced a few weeks later). The new battery charger came and it worked fine, until today. . That one died. I had the replacement battery charger (still with me, this is BC charger #4 now) and it works perfectly fine.

I'm not sure I'm having the same problem as the OP since my chargers keep dying and the battery WILL accept a new charger just fine. What is going on? 4 battery chargers in 4 months is ridiculous!

I am very careful with my laptop, I don't drop the charger. The charger is usually plugged into the wall all the time, however, it is not always plugged into the laptop, it is only plugged into the laptop for charging (and only after I get the low battery warning).

The last battery charger didn't even give any warning that it was going to fail. It just worked one minute and then was dead the next, no flickering, nothing.

Any thoughts would be appreciated.

Melissa
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑

Content Relevant URLs by vBSEO 3.3.2