Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Hardware Hardware
Search Search
Search for:
Tech Support Guy > > >

My USB ports aren't working...PLEASE HELP!


(!)

misslongino's Avatar
misslongino misslongino is offline
Computer Specs
Junior Member with 1 posts.
THREAD STARTER
 
Join Date: Jan 2009
Location: Chicago
Experience: Intermediate
28-Jan-2009, 09:06 AM #1
Unhappy My USB ports aren't working...PLEASE HELP!
Ok so here's the deal I have a Powerspec V305,



and its not the greatest computer ever, but it works pretty decently w/o too much error. Three days ago I installed Registry Mechanic and now my USB ports in front don't work, the ones in the rear, do work. but the ones in front where I very often attach my Iphone and camera no longer work at all it seems. I used the restore option on the registry mechanic...no luck...I did a complete system restore no luck. Any ideas?

Last edited by misslongino; 28-Jan-2009 at 09:11 AM.. Reason: photo not showing
craigw76's Avatar
craigw76 craigw76 is offline
Computer Specs
Junior Member with 3 posts.
 
Join Date: Jan 2009
Location: Lancashire, UK
Experience: Intermediate to Advanced
28-Jan-2009, 10:11 AM #2
Try the device manager. See if any errors are logged against any usb entries. If there are, then try reinstalling the usb drivers, there should be an option with the device propities somewhere.
bigbear's Avatar
Computer Specs
Member with 4,715 posts.
 
Join Date: Apr 2004
Location: Southampton UK
Experience: Advanced
28-Jan-2009, 04:11 PM #3
Try this registry fix for missing usb ports by JohnWill

Johnwill's solution

Create a file with NOTEPAD containing the following lines and save it as FIX.REG
-------------------------- Use text after this line --------------------------------
REGEDIT4

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment]

"DEVMGR_SHOW_NONPRESENT_DEVICES"="1"
-------------------------- Use text before this line --------------------------------

Double click on FIX.REG and say yes to the Merge Into Registry question.

Unplug ALL USB devices.
Open Device Manager.
View, Show Hidden Devices.
Uninstall all devices under USB Controllers.
Uninstall all devices under Disk Drives that you know are not present.
Uninstall all devices under Storage Volumes. Say no to any reboot prompts until you are finished. Also, if a Storage Volume doesn't uninstall, ignore it and move to the next one.
If you have a yellow ? with unknown devices, uninstall all of the entries there as well.

When this is done, reboot TWICE.

Reconnect the USB devices and see if they're recognized properly.

NOTE: If you have a USB keyboard and/or mouse, you'll have to modify the instructions and leave enough parts for those to function. I don't have one yet, so I haven't had time to modify the instructions.
__________________
Microsoft MVP - Shell/User
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


Tags
powerspec, registry mechanic, usb, usb failure

(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑