Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Hardware Hardware
Search Search
Search for:
Tech Support Guy > > >

Solved: Iomega Hard Drive not Recognized


(!)

llcunnyll's Avatar
llcunnyll llcunnyll is offline
Computer Specs
Junior Member with 4 posts.
THREAD STARTER
 
Join Date: Apr 2009
Experience: Beginner
16-Apr-2009, 01:02 PM #1
Unhappy Solved: Iomega Hard Drive not Recognized
I have had this iomega 500gb external hardrive for about 5 months and it has been working fine, untill this morning. For some reason my computer cant find the hard drive now. There is a blue light indicating that the hard drive has power running to it (it has a seperate power source to the computer) but there is no flikering light wich usually comes on when the computer is reading it. I have made sure all the cables are in properly but the hard drive can't be found in either my computer or device manager. I tried the hard drive on another computer and it worked but it still wont work on my computer.
Im using windows vista ultimate on an "s-series mother board".
Processor: Intel(R) Pentium(R) 4 CPU 3.00GHz
RAM: 2.00GB
System type: 32-bit opperating system

Last edited by llcunnyll; 16-Apr-2009 at 01:10 PM.. Reason: more specification needed
Elvandil's Avatar
Computer Specs
Moderator with 51,993 posts.
 
Join Date: Aug 2003
Location: Vermont
Experience: "Been through the mill."
16-Apr-2009, 01:03 PM #2
Is it USB? Do other USB devices work?

Does the drive appear under the USB section of Device Manager? Disk Management?

Right-click Computer > Manage > Disk Management.
llcunnyll's Avatar
llcunnyll llcunnyll is offline
Computer Specs
Junior Member with 4 posts.
THREAD STARTER
 
Join Date: Apr 2009
Experience: Beginner
16-Apr-2009, 01:16 PM #3
Is it USB? Yes
Do other USB devices work? Yes

Does the drive appear under the USB section of Device Manager? No
Disk Management? No
Elvandil's Avatar
Computer Specs
Moderator with 51,993 posts.
 
Join Date: Aug 2003
Location: Vermont
Experience: "Been through the mill."
16-Apr-2009, 01:21 PM #4
Start simple.

USB Device Cleanup
llcunnyll's Avatar
llcunnyll llcunnyll is offline
Computer Specs
Junior Member with 4 posts.
THREAD STARTER
 
Join Date: Apr 2009
Experience: Beginner
16-Apr-2009, 01:40 PM #5
It still doesn't appear anywhere.
llcunnyll's Avatar
llcunnyll llcunnyll is offline
Computer Specs
Junior Member with 4 posts.
THREAD STARTER
 
Join Date: Apr 2009
Experience: Beginner
17-Apr-2009, 11:22 AM #6
Today I switched my computer on and the drivers for the hdd installed themselves. The hard drive is working now. Thanks for the help.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


Tags
hard drive, iomega, problem

(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑