Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Hardware Hardware
Search Search
Search for:
Tech Support Guy > > >

USB mouse not working properly?


(!)

wytewidow's Avatar
wytewidow wytewidow is offline
Junior Member with 23 posts.
THREAD STARTER
 
Join Date: Sep 2009
22-Sep-2009, 01:52 AM #1
Unhappy USB mouse not working properly?
Hi all on TSG,
First time posting here so dont be too mean thnx!

My laptop has a problem with it's USB ports
Im currently using a Windows Vista Home Premium with SP1

Im using a ASUS Notebook A8 series (about 2-3yrs old?)

The USB ports on my computer have all gone a little wonky but (thankfully) my laptop cooler and thumbdrive still work on it (although albeit crazy at times)

---------
The problem

When i plug in the Plug and Play mouse from microsoft or any mouse except for the ASUS mouse which came with the laptop none of them work. The light comes on so I know the power is working. But when i move the mouse there is no response from the screen.
When i check the controlpanel->mouse no other devices pop up apart from my synaptics touchpad.
When i check the device manager ->
[i also get this problem with many Bluetooth Peripheral Devices which keep asking to be installed (its such a hassle to keep closing them)] the mouse does not appear even after trying to update the hardware. basically the laptop does not detect the mouse. the mouse is Microsoft Notebook Optical Mouse
I tried many other mice and i always get the same problem

Basically all my USB ports are ****ed.
I think there might be something wrong with the USB files in my computer?
Or smth to do with the INF files.

Please help and ask for any extra details which you might require in order to assist me

This issue has been bugging me for such a long time.

Cheers
markomus's Avatar
markomus markomus is offline
Computer Specs
Member with 773 posts.
 
Join Date: Aug 2007
Location: California, USA
22-Sep-2009, 02:13 AM #2
If it were me, I'd try downloading an updated/fresh copy of the drivers for my specific model notebook from Asus's web site and just reinstall over the old ones.
wytewidow's Avatar
wytewidow wytewidow is offline
Junior Member with 23 posts.
THREAD STARTER
 
Join Date: Sep 2009
22-Sep-2009, 03:27 AM #3
sorry to sound like a totally noob but im not sure which drivers or where to get them? i mean i've looked under the ASUS site and im looking at the drivers but i dont know which ones to get?

i've also got the recovery DVD and the driver&utility ver 1.0(DVD) from ASUS

can i use those?
markomus's Avatar
markomus markomus is offline
Computer Specs
Member with 773 posts.
 
Join Date: Aug 2007
Location: California, USA
22-Sep-2009, 03:35 AM #4
You can use them if they worked the first time. If this is a recent development, i.e., connecting USB mice in the past hasn't been an issue, then you should consider using the disc b/c it would be faster. If the mice have NEVER worked, then d/l the updates or fresh copies.

What model, exactly, of A8 do you have?
TBH-LSVC's Avatar
TBH-LSVC TBH-LSVC is offline
Computer Specs
Member with 91 posts.
 
Join Date: Aug 2008
Experience: Advanced
22-Sep-2009, 03:44 AM #5
However, the USBs in the device manager seem to have the drivers installed correctly. Can you connect any USB device other than mice, such as flash memories or other devices. This could be due to power problems, though the ASUS mouse works correctly.
wytewidow's Avatar
wytewidow wytewidow is offline
Junior Member with 23 posts.
THREAD STARTER
 
Join Date: Sep 2009
22-Sep-2009, 03:53 AM #6
cheers mate,

it's the A8SC 18DPM

at least thats what i've got written here on the receipt.

i dont exactly know what will happened when i put the disks in. will it wipe any of my stuff on my computer away? im really wary of these recovery disks type

oh yeah i think it's actually always been an issue with this laptop

i wouldnt recommend it! ;(
markomus's Avatar
markomus markomus is offline
Computer Specs
Member with 773 posts.
 
Join Date: Aug 2007
Location: California, USA
22-Sep-2009, 03:58 AM #7
Quote:
Originally Posted by TBH-LSVC View Post
However, the USBs in the device manager seem to have the drivers installed correctly. Can you connect any USB device other than mice, such as flash memories or other devices. This could be due to power problems, though the ASUS mouse works correctly.
Now that you mention it, there was mention of the USB ports running a little "wonky," but still able to support a laptop cooler and a thumb drive, though not perfectly.

You'd be right: that does sound more like a hardware problem.
markomus's Avatar
markomus markomus is offline
Computer Specs
Member with 773 posts.
 
Join Date: Aug 2007
Location: California, USA
22-Sep-2009, 04:03 AM #8
Reinstalling drivers won't hurt anything. Reinstalling the operating system (i.e., Windows) might. So you'd want the drivers.

Vista 32 or 64?
wytewidow's Avatar
wytewidow wytewidow is offline
Junior Member with 23 posts.
THREAD STARTER
 
Join Date: Sep 2009
22-Sep-2009, 04:04 AM #9
it's strange because my ipod works perfectly fine and the other asus mouse that came with the laptop works fine! but i have misplaced that mouse which has forced me to get another one.

the laptop does say that it detects something has been stuffed into the USB port. and that it is installing the driver. and then says that the human USB interface has been successfully installed .

BUT this does not reflect on the screen when im trying to move the mouse. the mouse does detect when i move it because it turns a brighter red when i move it.

i dont know if it is so much a hardware problem

but i know that somewhere in my laptop the USB settings must be messed up
wytewidow's Avatar
wytewidow wytewidow is offline
Junior Member with 23 posts.
THREAD STARTER
 
Join Date: Sep 2009
22-Sep-2009, 04:06 AM #10
yes my thumb drive works fine. it is a cruzer 8gb

HOWEVER
some other external HDs do not register on my laptop such as the maxtor 250 gig

which is what makes this so strange and puzzling
markomus's Avatar
markomus markomus is offline
Computer Specs
Member with 773 posts.
 
Join Date: Aug 2007
Location: California, USA
22-Sep-2009, 04:07 AM #11
Are you running Vista 64 or 32?
wytewidow's Avatar
wytewidow wytewidow is offline
Junior Member with 23 posts.
THREAD STARTER
 
Join Date: Sep 2009
22-Sep-2009, 04:07 AM #12
Vista 32 bit mate

thanks for all the quick replies i really appreciate it. laptop problems can be so frustrating!
markomus's Avatar
markomus markomus is offline
Computer Specs
Member with 773 posts.
 
Join Date: Aug 2007
Location: California, USA
22-Sep-2009, 04:15 AM #13
Well they've made it a bit of a challenge (of course), but you'll go here first:

http://support.asus.com/download/dow...Language=en-us

When you get there, follow the cues till you find your model and operating system. You should then download the file marked Chipset. There's no updated version, so it would be the same as on your disc, but with this you'll know you're downloading only what you'll need. Just save to Desktop, double click, and it should install.
markomus's Avatar
markomus markomus is offline
Computer Specs
Member with 773 posts.
 
Join Date: Aug 2007
Location: California, USA
22-Sep-2009, 04:17 AM #14
OH...you'll probably have to restart your computer, too.
markomus's Avatar
markomus markomus is offline
Computer Specs
Member with 773 posts.
 
Join Date: Aug 2007
Location: California, USA
22-Sep-2009, 04:18 AM #15
Quote:
Originally Posted by wytewidow View Post
Vista 32 bit mate

thanks for all the quick replies i really appreciate it. laptop problems can be so frustrating!
I work on them for a living. I have what I think is a dead one sitting lifelessly there on my workbench right now.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


Tags
mouse, not working, port, usb

(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑

Content Relevant URLs by vBSEO 3.3.2