Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Search Search
Search for:
Tech Support Guy > > >

Parallel port not working


(!)

arigsby's Avatar
arigsby arigsby is offline
Junior Member with 1 posts.
THREAD STARTER
 
Join Date: Jan 2010
Experience: Advanced
26-Jan-2010, 07:04 PM #1
Angry Parallel port not working
I work for an organization with about 300 employees and almost all have computers. I have experienced the following issue on several machines over the years and still cannot find an answer anywhere on the internet, so I am posting here.

I have an HP business desktop that has two parallel ports in it: LPT1 and LPT2. On a rare occasion the printer connected to LPT1 will jam and I have to clear the paper out of the paper path. After I clear the jam, the computer is no longer able to print anything to LPT1. If I use the application that prints to LPT1 again, I get an error in the application stating "The requested resource is in use. (170)" Others on the internet have reported similar errors and in a few cases, the exact same error, but no luck with a solution. Further, there is no error in the Event Viewer's application or system logs.

So, I have tried:
+ uninstalling LPT1 port from the Device Manager, reboot, and still no luck. Same error.
+ uninstalling LPT1 port from the Device Manager, shutdown, disable the parallel port entirely, boot into Windows, shutdown, re-enable the parallel port, boot into Windows. Same error.
+ Reassign LPT1 port to LPT3. Same error.

More info... Turns out that any other printer I try connecting to the LPT1 port is not able to printed to. Plug said printer back into LPT2 or LPT3 and it works fine again. Problem remains: can't print anything to any device in LPT1.

Even more info... The printer normally connected to LPT1 is fine. Take it to another computer and it prints beautifully.

Still more info... I know that the LPT1 port is not experiencing a hardware failure. How do I know this? Because if I delete everything on the computer's C drive (including the partitions) and reinstall Windows from scratch, the LPT1 works fine.

Finally, I will add this: I have several computers that this has happened to over the years. These machines are used at our front gate where we sell tickets to our venue. These machines are virtually identically configured and have the same models of printers connected to the same LPT ports. The printer connected to LPT1 is called a BOCA ticket printer and it is not detected at all by Windows on any computer. That is fine by us because, normally, we are able to print to the BOCA on LPT1 fine. Thus, on a typical computer here, if you go into the Printers folder in XP you will see nothing connected to LPT1.

I am stuck on this one. I configure Exchange servers, firewalls, VMWare hosts, implement SharePoint sites, yadda yadda yadda.. pretty much everything here but I can't figure out this one darn thing. Oh great Internet, is there anyone out there with an answer? I'm tired of spending the better part of a day reinstalling Windows and all the apps each time this happens to a machine.

Thank you.
Elvandil's Avatar
Computer Specs
Member with 51,993 posts.
 
Join Date: Aug 2003
Location: Vermont
26-Jan-2010, 07:42 PM #2
Parallel ports are deprecated and you'll find very little support for that obsolete interface. It has been some time since computers even had them when new. You'd be better off with USB printers are adapters.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


Tags
lpt1, parallel, port

(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑

Content Relevant URLs by vBSEO 3.3.2