Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Linux and Unix Linux and Unix
Search Search
Search for:
Tech Support Guy > > >

Solved: After booting, I have no keyboard. :(


(!)

JAILBR3AK3R's Avatar
JAILBR3AK3R JAILBR3AK3R is offline
Computer Specs
Member with 54 posts.
THREAD STARTER
 
Join Date: Aug 2012
Experience: Beginner
15-Aug-2012, 05:22 PM #1
Solved: After booting, I have no keyboard. :(
After I boot Lubuntu, it asks me for the language the first time I booted. Problem is, I can't even control the keyboard. It's like it shut off on me and doesn't like Linux lol. What can I do to fix this?

Off-topic: It seems like everytime I solve a problem, another one pops up. :/
JAILBR3AK3R's Avatar
JAILBR3AK3R JAILBR3AK3R is offline
Computer Specs
Member with 54 posts.
THREAD STARTER
 
Join Date: Aug 2012
Experience: Beginner
15-Aug-2012, 06:13 PM #2
Quote:
bump
Quote:
bump
bump
JAILBR3AK3R's Avatar
JAILBR3AK3R JAILBR3AK3R is offline
Computer Specs
Member with 54 posts.
THREAD STARTER
 
Join Date: Aug 2012
Experience: Beginner
15-Aug-2012, 08:20 PM #3
Quote:
Originally Posted by JAILBR3AK3R View Post
bump
lunarlander's Avatar
Computer Specs
Member with 5,556 posts.
 
Join Date: Sep 2007
15-Aug-2012, 08:40 PM #4
If you are using a USB keyboard, try a PS2 keyboard if you have one lying around.
JAILBR3AK3R's Avatar
JAILBR3AK3R JAILBR3AK3R is offline
Computer Specs
Member with 54 posts.
THREAD STARTER
 
Join Date: Aug 2012
Experience: Beginner
15-Aug-2012, 08:49 PM #5
I have a ps2 keyboard and its the one ive been having the problem with. Same with USB.
JAILBR3AK3R's Avatar
JAILBR3AK3R JAILBR3AK3R is offline
Computer Specs
Member with 54 posts.
THREAD STARTER
 
Join Date: Aug 2012
Experience: Beginner
15-Aug-2012, 09:44 PM #6
Sorry for this bump, but I need help desperately and no other forums are helping.
ekim68's Avatar
ekim68   (Mike) ekim68 is offline
Member with 44,549 posts.
 
Join Date: Jul 2003
Location: Eugene, Oregon
15-Aug-2012, 10:26 PM #7
How are you typing this right now? Did you try to get into the BIOS setup to see if a USB keyboard is turned on?
saikee's Avatar
Member with 3,750 posts.
 
Join Date: Jun 2004
Location: Newcastle
Experience: A Linux user gone nuts on multi-boot
16-Aug-2012, 07:40 AM #8
Each Linux distro installer could have its own way to determine the hardware. When a mistake is made that piece of hardware could lose communication as in this case, a keyboard.

One way of solving the problem is try another distro that detects the keyboard correctly. The configuration file /etc/X11/xorg.conf is then printed out (generate it if necessary) or a record is made available.

One can then edit the failed Linux's /etc/X11/xorg.conf to have the same keyboard setting of the one that works and boot the system up. This normally works fine for me. Actually if the setting of Linux B works OK I would copy it into Linux A and not bothering just changing the beyboard part.

In general Linux uses generic drivers so a truly PS2 beyboard should always work.

Last edited by saikee; 16-Aug-2012 at 04:11 PM..
JAILBR3AK3R's Avatar
JAILBR3AK3R JAILBR3AK3R is offline
Computer Specs
Member with 54 posts.
THREAD STARTER
 
Join Date: Aug 2012
Experience: Beginner
16-Aug-2012, 10:42 AM #9
Alright thanks. I'll have to look into those things. I'll be back if I have anymore questions. BTW I'm using my dad's computer to go on this forum.

Again, thanks.
JAILBR3AK3R's Avatar
JAILBR3AK3R JAILBR3AK3R is offline
Computer Specs
Member with 54 posts.
THREAD STARTER
 
Join Date: Aug 2012
Experience: Beginner
16-Aug-2012, 10:48 AM #10
Quote:
Originally Posted by saikee View Post
One can then edit the failed Linux's /etc/X11/xong.cong
Could one teach me how to find this wonderful file? XD
JAILBR3AK3R's Avatar
JAILBR3AK3R JAILBR3AK3R is offline
Computer Specs
Member with 54 posts.
THREAD STARTER
 
Join Date: Aug 2012
Experience: Beginner
16-Aug-2012, 11:33 AM #11
I have been browsing the ISO file with WinRAR and I have found nothing. I have also read that it is not included by default. LOL. So how would I create this file and where?
saikee's Avatar
Member with 3,750 posts.
 
Join Date: Jun 2004
Location: Newcastle
Experience: A Linux user gone nuts on multi-boot
16-Aug-2012, 04:16 PM #12
If you have installed Lubuntu then the installed filing system has many directories. A file called xorg.conf is the standard configuration file for the X window and is usually kept in the folder /etc/X11. This is a text file allowing a user to configure the system. If you have installed Lubuntu you can boot up any Linux, mount the Lubuntu partition and edit that file.

However if you have not installed Lubuntu and the Live CD doesn't work for you then you should try another Linux distro. Lubuntu is just one of the many members of the Ubuntu family. Usually the quickest way to use Linux is when one doesn't work try another. It is a rare for a modern Linux not detecting the hardware correctly. The other alternative is to use a standard PS2 keyboard.
JAILBR3AK3R's Avatar
JAILBR3AK3R JAILBR3AK3R is offline
Computer Specs
Member with 54 posts.
THREAD STARTER
 
Join Date: Aug 2012
Experience: Beginner
29-Aug-2012, 08:03 PM #13
Turns out it was my video card. Wierd. Bought a new one and now it works okay but i have another problem. See my other thread in this catagory
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑