Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Networking Networking
Search Search
Search for:
Tech Support Guy > > >

Solved: Atheros AR9285 can't find any wi-fi connection!


(!)

lefthanded's Avatar
lefthanded lefthanded is offline
Member with 10 posts.
THREAD STARTER
 
Join Date: Oct 2011
24-Oct-2011, 06:29 AM #1
Solved: Atheros AR9285 can't find any wi-fi connection!
Hello,

i have a samsung N130 with an Atheros AR9285, a few months ago everything was working fine, suddenly i was disconnected, and i couldn't find any wi-fi connection. i tried system restore, installing the latest drivers, nothing is solving the problem. The wireless chip is working properly according to windows device manager.

Using a D-link usb dongle i could find wireless networks and connect to the internet.

anyone knows what causing the problem? or is the chip faulty?

thank you.
etaf's Avatar
etaf   (Wayne) etaf is online now
Computer Specs
Moderator with 52,576 posts.
 
Join Date: Oct 2003
Location: Surrey, UK
24-Oct-2011, 06:42 AM #2
without the USB adapter connected
can we see a device manager screen shot and ipconfig /all also an xirrus screen shot - details below

Is the wireless switched OFF most laptops use a physical switch or a combination of FN + one of the F keys to toggle the wireless on/off
Its also possible its disabled in the bios - but then it should not appear in the device manager

------------------------------------------------------------------------
ipconfig /all
If you cannot access the internet with this PC, then you will need to paste the results into something like notepad and then copy onto a machine that can access the internet and post results here

We would like to see the results from ipconfig /all post back the results in a reply here

Hold the Windows key and press R, then type CMD then press Enter to open a command prompt box (A new dialogue box - black with white font, will appear on screen ):

In the command prompt window that opens, type the following command:

Note that there is a space before the /ALL, but there is NOT a space after the / in the following command.

ipconfig /all > network.txt & network.txt

It will export the results to notepad and then automatically open notepad.

Now all you need to do is copy and paste those results to a reply here
to do that:
From the notepad menu - choose Edit - Select all
all the text will be highlighted
Next
From the notepad menu - choose Edit - Copy
Now go back to the forum - reply and then right click in the reply box and paste
------------------------------------------------------------------------


------------------------------------------------------------------------
Run Xirrus Wi-Fi Inspector
Download and install

If you cannot access the internet with this PC, then you will need to copy the program across to the faulty PC

http://www.xirrus.com/Products/Wi-Fi-Inspector.aspx
Direct link to the program is here http://wpc.475a.edgecastcdn.net/0047...etup.1.2.0.exe

{If the above link does not work heres another link http://www.pcworld.com/downloads/file_download/fid,77196-order,4/download.html}

Then run and install the program - on a wireless enabled PC/Laptop
if you get an error - You need NET Framework installed for the WiFi Inspector to function.

Run the program

A user guide is available here http://www.xirrus.com/Products/Wi-Fi...uide1-2-0.aspx

post a screen shot of the program running - if there are a lot of networks showing can you click on "networks" top lefthand area - so we can see all the network information, and also post which network "Adapter Name" (1st column) is yours on the list

To post a screen shot of the active window, hold the Alt key and press the PrtScn key. Open the Windows PAINT application and Paste the screen shot. You can then use PAINT to trim to suit, and save it as a JPG format file.
To upload it to the forum, open the full reply window and use the Manage Attachments button to upload it here.
Full details are here http://library.techguy.org/wiki/TSG_...g_a_Screenshot

Note:
For a reliable (or robust as the Xirrus user guide says) wireless connection you need a signal of about -70 dBm or better.

If you are using the Mac OS then use http://www.istumbler.net/
------------------------------------------------------------------------

------------------------------------------------------------------------
Device Manager
Post back the results in device manager
If you cannot access the internet with this PC, then you will need to copy the program across to the faulty PC

windows key and pause Key should open to allow device manager to be seen on laptops may need to use windows key + FN key + Pause Key
if not then

Start > control Panel {Vista set to classic view}> system > {Vista, device manager on left hand side} {XP hardware Tab, device manager button} >
windows 7
start > control panel> System and Security> Device Manager

network adaptors, click on the + > post back the devices listed there
are there any ! ? or X


post a screen shot of the device manager - network adapters

To post a screen shot of the active window, hold the Alt key and press the PrtScn key. Open the Windows PAINT application and Paste the screen shot. You can then use PAINT to trim to suit, and save it as a JPG format file.
To upload it to the forum, open the full reply window and use the Manage Attachments button to upload it here
Full details are here http://library.techguy.org/wiki/TSG_...g_a_Screenshot
------------------------------------------------------------------------
__________________
Wayne
Please let us know what the final solution was to any problem posted
lefthanded's Avatar
lefthanded lefthanded is offline
Member with 10 posts.
THREAD STARTER
 
Join Date: Oct 2011
24-Oct-2011, 07:14 AM #3
Thank you Etaf for the reply, the wireless is on, on my netbook it's FN + F9, in the Bios it's also enabled. when the problem happened i called Samsung but they were pretty useless, asked me to do a full recovery which didn't help at all.

here's the results:

Windows IP Configuration

Host Name . . . . . . . . . . . . : hadi-PC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Wireless LAN adapter Wireless Network Connection 2:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Atheros AR9285 Wireless Network Adapter
Physical Address. . . . . . . . . : F0-7B-CB-06-DD-41
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek PCIe FE Family Controller
Physical Address. . . . . . . . . : 00-24-54-63-E4-16
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Attached Thumbnails
Solved: Atheros AR9285 can't find any wi-fi connection!-untitled.jpg   Solved: Atheros AR9285 can't find any wi-fi connection!-untitled2.jpg  
etaf's Avatar
etaf   (Wayne) etaf is online now
Computer Specs
Moderator with 52,576 posts.
 
Join Date: Oct 2003
Location: Surrey, UK
24-Oct-2011, 07:18 AM #4
xirrus can see the adapter but no networks

just check the services

------------------------------------------------------------------------
Services

We would like to see some status information for each of the services listed below to do this goto
Control Panel>
Administrative Tools>
Services>

then for each of the servies listed below - Please post back the following status information -
If the service is Started/Stopped
and
If the service is Automatic/Manual
  • COM+ Event System (for WZC issues)
  • Computer Browser
  • DHCP Client
  • DNS Client
  • Network Connections
  • Network Location Awareness
  • Remote Procedure Call (RPC)
  • Server
  • TCP/IP Netbios helper
  • Wireless Zero Configuration (XP wireless configurations only)
  • WLAN AutoConfig (Windows 7 & Vista wireless configurations only)
  • Workstation


If a service is not running,
right click on the service
then click on properties and now check the dependencies.

Check each of the dependencies and see which one is preventing the service from running.

Also to help us identify what may be causing the issue
Check the event log, there may be clues to what is failing. To do that
Start >
control panel >
administrative tools >
event Viewer>


------------------------------------------------------------------------
lefthanded's Avatar
lefthanded lefthanded is offline
Member with 10 posts.
THREAD STARTER
 
Join Date: Oct 2011
24-Oct-2011, 07:33 AM #5
COM+ Event System (for WZC issues) Started/Automatic
Computer Browser Started/Manual
DHCP Client Started/Automatic
DNS Client Started/Automatic
Network Connections Started/Manual
Network Location Awareness Started/Automatic
Remote Procedure Call (RPC) Started/Automatic
Server Started/Automatic
TCP/IP Netbios helper Started/Automatic
Wireless Zero Configuration (XP wireless configurations only)
WLAN AutoConfig (Windows 7 & Vista wireless configurations only) Started/Automatic
Workstation Started/Automatic
etaf's Avatar
etaf   (Wayne) etaf is online now
Computer Specs
Moderator with 52,576 posts.
 
Join Date: Oct 2003
Location: Surrey, UK
24-Oct-2011, 07:42 AM #6
looks like it maybe faulty - I would try a few more things, then i'm out of ideas

you did download the driver from the samsung site - correct ?

from device manager - uninstal the adapter - reboot PC and let windows redect the adapter

possible try a tcp/ip reset - unlikely
try safemode with networking sometimes the wireless adapter will notwork in this mode anyway - but not allways

You may be able to get to the wireless adapter - had a look but cant see anydetails - often one of the panels on the bottom will allow you to take put the adapter - you may want to try reseating a few times


- try safemode with networking
as the PC starts keep tapping F8 - a menu appears - choose
safemode with networking - see if that works
------------------------------------------------------------------------


------------------------------------------------------------------------

TCP/IP stack repair options for use with Vista/Windows 7

Start, Programs\Accessories and right click on Command Prompt, select "Run as Administrator" to open a command prompt.

Note: Type only the text in bold for the following commands.

Reset WINSOCK entries to installation defaults: netsh winsock reset catalog

Reset IPv4 TCP/IP stack to installation defaults. netsh int ipv4 reset reset.log

Reset IPv6 TCP/IP stack to installation defaults. netsh int ipv6 reset reset.log

Reboot the machine.

If you receive the message
The requested operation requires elevation.
Then please open the command prompt as administrator - as requested above
Start, Programs\Accessories and right click on Command Prompt, select "Run as Administrator" to open a command prompt.


Post back the results here - we need to know these commands worked correctly
rightclick in the box
select all
enter
control key + C key - to copy
then reply here and
control key + V to paste

------------------------------------------------------------------------
lefthanded's Avatar
lefthanded lefthanded is offline
Member with 10 posts.
THREAD STARTER
 
Join Date: Oct 2011
24-Oct-2011, 07:55 AM #7
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

D:\Users\hadi>netsh winsock reset catalog

Sucessfully reset the Winsock Catalog.
You must restart the computer in order to complete the reset.


D:\Users\hadi>netsh int ipv4 reset reset.log
Reseting Interface, OK!
Restart the computer to complete this action.


D:\Users\hadi>netsh int ipv6 reset reset.log
There's no user specified settings to be reset.
etaf's Avatar
etaf   (Wayne) etaf is online now
Computer Specs
Moderator with 52,576 posts.
 
Join Date: Oct 2003
Location: Surrey, UK
24-Oct-2011, 07:55 AM #8
that all looks ok
lefthanded's Avatar
lefthanded lefthanded is offline
Member with 10 posts.
THREAD STARTER
 
Join Date: Oct 2011
24-Oct-2011, 08:02 AM #9
i was first using an XP when this happened, i've installed windows 7 just to see if it's a problem with XP but still it's not working. so i should be 100% sure that the Atheros chip is faulty?

tried the safe mode, didn't work. I've even opened the computer to see if the white and black connectors are connected to the chip which they were.
etaf's Avatar
etaf   (Wayne) etaf is online now
Computer Specs
Moderator with 52,576 posts.
 
Join Date: Oct 2003
Location: Surrey, UK
24-Oct-2011, 08:05 AM #10
looks like this is a faulty chip -

its compatible with windows 7
http://www.microsoft.com/windows/com...os%20AR9285%20
AND
Quote:
This product installs automatically without extra software.
lefthanded's Avatar
lefthanded lefthanded is offline
Member with 10 posts.
THREAD STARTER
 
Join Date: Oct 2011
24-Oct-2011, 08:11 AM #11
Thanks Etaf, I appreciate all the help!
etaf's Avatar
etaf   (Wayne) etaf is online now
Computer Specs
Moderator with 52,576 posts.
 
Join Date: Oct 2003
Location: Surrey, UK
24-Oct-2011, 08:40 AM #12
your welcome - you could create a ubuntu cd and see if that works with the wireless only issue you may need drivers so it will only be certain if it actually works - if it does not work may still be faulty


You can mark your own threads solved using the button at the top of the page of the thread in the upper left corner.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑