Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Networking Networking
Search Search
Search for:
Tech Support Guy > > >

Solved: LG TV won't connect to DLNA server (my PC)


(!)

pcguy9441's Avatar
pcguy9441 pcguy9441 is offline
Computer Specs
Member with 417 posts.
THREAD STARTER
 
Join Date: Apr 2007
Location: Sacramento CA
Experience: Advanced
20-Jan-2012, 09:34 PM #1
Solved: LG TV won't connect to DLNA server (my PC)
I'm going nuts trying to get my new LG 47LW5700 TV to connect to a DLNA server, ie, my PC.

Here's what I have done so far:
  1. Installed Serviio DLNA app and the DLNA server is enabled and apperently running. Set up the drives/folders I want to share but don't know what to do with display shown in attachment (Renderer profile, what's that all about?).
  2. Killed MS and Norton firewalls, but rest of Norton still running. I understand I could have left MS firewall running and Serviio should punch thru it but wanted eliminate another variable for now.
  3. Verified that UPnP is enabled on router. (Actiointec GT724-WT).
  4. Selected TV INPUT from remote and DLN is still not selectable option on list (grayed out).
  5. I am on the internet via included wifi adapter that came with TV. I can get to hulu, youtube, etc.... and thus should be on my local wifi network.

Any suggestions? Do I need to do more with my router to open ports?

Called Costco Concierge service but they are clueless - DLNA stuff is over their head apparently as she'd never heard of it.
Attached Thumbnails
Solved: LG TV won't connect to DLNA server (my PC)-capture.jpg  
etaf's Avatar
etaf   (Wayne) etaf is offline
Computer Specs
Moderator with 52,565 posts.
 
Join Date: Oct 2003
Location: Surrey, UK
21-Jan-2012, 12:45 PM #2
that image should show all the IP address of devices on the network - and you can then use a dropdown to select a specifc device

see attached image

goto to the LGTV settings and find the network settings

find the IP address

and then from the PC ping that IP Address

------------------------------------------------------------------------
Ping Tests

Start> Run {search bar in Vista/W7}> CMD to open a DOS window and type:

Type the following command
Ping {plus the number thats is in the TV settings}
Post back the results
rightclick in the box
select all
enter
control key + C key - to copy
then reply here and
control key + V to paste
Attached Thumbnails
Solved: LG TV won't connect to DLNA server (my PC)-servii.jpg  
__________________
Wayne
Please let us know what the final solution was to any problem posted
pcguy9441's Avatar
pcguy9441 pcguy9441 is offline
Computer Specs
Member with 417 posts.
THREAD STARTER
 
Join Date: Apr 2007
Location: Sacramento CA
Experience: Advanced
21-Jan-2012, 02:21 PM #3
OK, making progress! I now see my TV in Serviio Renderer window. Did not know about a right click drop down to show my TV. DLNA still grayed out on TV input list.

Now what do I do?

192.168.0.2 --------- Windows Med Player -------- LG TV/Player
etaf's Avatar
etaf   (Wayne) etaf is offline
Computer Specs
Moderator with 52,565 posts.
 
Join Date: Oct 2003
Location: Surrey, UK
21-Jan-2012, 02:25 PM #4
but you dont see any devices in that screen - correct ?

192.168.0.2 - is that the PC IP-
need to know the LG IP

are you using Norton and have a fully paid up subscription?
if not then remove norton using the removal tool
--------------------------------------------------------------

Norton Removal Tool
I would recommend that you restart the PC and run the removal tool for a second time - I have found instances where the removal tool needs to be run twice to fully remove all traces of norton and symantec from the PC
http://us.norton.com/support/kb/web_...080710133834EN

All Versions - The Norton Removal Tool uninstalls all Norton 2010/2009/2008/2007/2006/2005/2004/2003 products, Norton 360 and Norton SystemWorks 12.0 from your computer.
http://majorgeeks.com/Norton_Removal...NRT_d4749.html

--------------------------------------------------------------
pcguy9441's Avatar
pcguy9441 pcguy9441 is offline
Computer Specs
Member with 417 posts.
THREAD STARTER
 
Join Date: Apr 2007
Location: Sacramento CA
Experience: Advanced
21-Jan-2012, 04:06 PM #5
I redid the connection after setting router to "G" vs B/G.

Looks like a connection exists. What am I supposed to see in Serviio that I don't see beyond the line with WMP and my TV in it? Am I supposed to put an IP addr in the "bound IP" box?

Apparently there are no step-by-step instructions on this vs trial and error and tech forums. Nothing in the LG manual besides saying "just select DLNA from input list" and Costco's Concierge service was useless as they'd never even heard of DLNA and said I had to plug a USB thumb drive into TV to accomplish what I want. How does the average Joe Sixpack get DLNA running or maybe he's not suppose to? Only UbberGeeks need apply.

Thanks for the help.

Ping results:

C:\Users\Eric>ping 192.168.0.3

Pinging 192.168.0.3 with 32 bytes of data:
Reply from 192.168.0.3: bytes=32 time=2ms TTL=64
Reply from 192.168.0.3: bytes=32 time=8ms TTL=64
Reply from 192.168.0.3: bytes=32 time=2ms TTL=64
Reply from 192.168.0.3: bytes=32 time=2ms TTL=64

Ping statistics for 192.168.0.3:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 2ms, Maximum = 8ms, Average = 3ms
etaf's Avatar
etaf   (Wayne) etaf is offline
Computer Specs
Moderator with 52,565 posts.
 
Join Date: Oct 2003
Location: Surrey, UK
21-Jan-2012, 04:12 PM #6
your first image of serviio has NO devices listed - mine has all the network devices shown

So i'm trying to establish if serviio can actually see any devices - a little confused by your replies

Next
I asked what the IP of the LG TV was - you have not answered - but mentioned 192.168.0.2 and i do not know what this relates to - hence the next question

Now
you are showing a ping result to 192.168.0.3 - still do not what this ping is for - and what device has that IP

so need a little more info
pcguy9441's Avatar
pcguy9441 pcguy9441 is offline
Computer Specs
Member with 417 posts.
THREAD STARTER
 
Join Date: Apr 2007
Location: Sacramento CA
Experience: Advanced
21-Jan-2012, 04:13 PM #7
Sorry, didn't ans all questions. the .0.2 IP, don't know what it is. The TV is .0.3 from ping in last reply. I fiddled with WMP last night and turned that server on so maybe that's the WMP IP if that makes sense??? Maybe I should kill WMP to keep it simple.

On Norton, fully licensed. Thanks for removal tool, will use when lic times out and I probably move back to free AVG to avoid rebate paper work and relicensing grief.
pcguy9441's Avatar
pcguy9441 pcguy9441 is offline
Computer Specs
Member with 417 posts.
THREAD STARTER
 
Join Date: Apr 2007
Location: Sacramento CA
Experience: Advanced
21-Jan-2012, 04:20 PM #8
sorry for the confusion. Again, the .0.3 is the TV as read off TV screen after selecting network properties.

Should I undo any streaming setup I did in WMP last night? Probably so to remove variables. I don't know what that entry means in attachment above with the .0.2 and Windows Med Player. The LG TV entry is from me doing a right click and selecting it.
pcguy9441's Avatar
pcguy9441 pcguy9441 is offline
Computer Specs
Member with 417 posts.
THREAD STARTER
 
Join Date: Apr 2007
Location: Sacramento CA
Experience: Advanced
21-Jan-2012, 04:29 PM #9
Actually, I'm not so sure now that my messing with WMP really did anything since in the attachement you can see no devices specified when I try to enable streaming in WMP. It won't let me select anything and no seen devices appear either, suggesting that WMP has the same problem as Serviio in detecting the TV. Suggests a more global problem maybe....but I am on the internet with 4 bars so seems PC and TV should be able to see each other. Hope attachment made it. I can't seem see it from preview mode.
Attached Thumbnails
Solved: LG TV won't connect to DLNA server (my PC)-capture4.jpg  
etaf's Avatar
etaf   (Wayne) etaf is offline
Computer Specs
Moderator with 52,565 posts.
 
Join Date: Oct 2003
Location: Surrey, UK
21-Jan-2012, 04:44 PM #10
how many PCs do you have on the network

Niw we know the TV is 0.3 and that you can ping it , we know its seen by the PC - and the router should be working fine

so now its a question of getting the media services working and what is on the PC thats blocking

wmp or serviio or tversity should all work ok

on the PC - what windows version do you have
in wmp - what version do you have

would you post the screen shot of serviio again

On Norton, it would be worth setting up the network IP to be allowed through the firewall
192.168.0.1 to 192.168.0.255
pcguy9441's Avatar
pcguy9441 pcguy9441 is offline
Computer Specs
Member with 417 posts.
THREAD STARTER
 
Join Date: Apr 2007
Location: Sacramento CA
Experience: Advanced
21-Jan-2012, 05:42 PM #11
Total of 2pc's. My main tower (homebrew) w cat5 to router and laptop wireless 75' away near TV. The first time I tried to get DLNA going, I could see the laptop via TV INPUT DLNA menu but folders would not open. No tower PC at that time either, then the laptop disappeared I think after I installed Nero Media Home on laptop or maybe screwed with home groups, not sure. I'm not concerned about connecting w DLNA to laptop, BUT networking wise, the laptop can see folders on tower and vice versa.

Windows 7 Home Prem, WMP 12.0.7601.17514

I've had the Norton firewall disabled for the past 2 days while I sort this out. Still need to open those ports?

On 1st screenshot, I got excited when I saw my LG TV there (I selected w right click/scroll) but now see it's just a generic set of options and does not mean it actually sees my TV. Last night I didn't have that, so new this AM.

BTW, the .0.2 seems to be IP of my network as seen when I go into router setup. There's a different IP for my WAN IP. I don't know the difference.
Attached Thumbnails
Solved: LG TV won't connect to DLNA server (my PC)-capture5.jpg   Solved: LG TV won't connect to DLNA server (my PC)-capture6.jpg  
pcguy9441's Avatar
pcguy9441 pcguy9441 is offline
Computer Specs
Member with 417 posts.
THREAD STARTER
 
Join Date: Apr 2007
Location: Sacramento CA
Experience: Advanced
21-Jan-2012, 05:48 PM #12
See attachment below for Norton firewall settings (disabled). Trying to figure how to disable specific ports you specified but don't think I can figure it out. Dozen's of settings available.
Attached Thumbnails
Solved: LG TV won't connect to DLNA server (my PC)-capture7.jpg  
pcguy9441's Avatar
pcguy9441 pcguy9441 is offline
Computer Specs
Member with 417 posts.
THREAD STARTER
 
Join Date: Apr 2007
Location: Sacramento CA
Experience: Advanced
21-Jan-2012, 06:07 PM #13
Here's another data point. My laptop is IP .4 and from it I got a good ping to TV (.3) and Tower (.2) and also the WAN IP, 71.142.244.16. All ping OK. Not sure if this tells you anything but sounds like if laptop can ping everyone, the TV should be able to see tower too. However as a non expert, it seems like a firewall thing.

Also, my Actiontec GT724-WG combo modem/router has firewall off = set to NAT only.
pcguy9441's Avatar
pcguy9441 pcguy9441 is offline
Computer Specs
Member with 417 posts.
THREAD STARTER
 
Join Date: Apr 2007
Location: Sacramento CA
Experience: Advanced
21-Jan-2012, 06:41 PM #14
And yet another data point. LG manual reads " The DLNA function is not available in some routers which do not support multicasting. For more info, see router manual....." Don't think my Actiontec GT724-wc supports mylticasting but I'm not actually trying to multicast I don't believe. Not totally clear on what is, I think 2 or more streaming paths at once to different devices.
pcguy9441's Avatar
pcguy9441 pcguy9441 is offline
Computer Specs
Member with 417 posts.
THREAD STARTER
 
Join Date: Apr 2007
Location: Sacramento CA
Experience: Advanced
21-Jan-2012, 10:03 PM #15
OK, breakthrough! I tried a direct cat5 connection to TV from laptop, removing the wifi adapter from TV. Could not get it going. First had to manually enter an IP addr, then it got hungup on a gatewaw problem I didn't understand so quit. On restoring it all to wireless, suddenly the DLNA icon on INPUT menu was lit and I could get on the laptop hard drive. I have Nero Media Home4 on laptop and it does all I want. BUT, unfortunately, there is nothing on the laptop I want to view on I TV. I guess I could get convoluted and view Tower HD via a shortcut on laptop but that's too demented and would be way slow.

At least there's a proof of concept. Router and firewall are not issues. I may go back to Nero on Tower PC and see what happens.
Email This Email  Print This Print  Bookmark This Bookmark  Tweet This Send to Facebook Send to MySpace Send to StumbleUpon Digg This | More Services More
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑