Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Networking Networking
Search Search
Search for:
Tech Support Guy > > >

Solved: need to change reserved IP address every time...


(!)

jtn3833's Avatar
jtn3833 jtn3833 is offline
Member with 437 posts.
THREAD STARTER
 
Join Date: Dec 2000
Location: st. louis, mo USA
12-Apr-2012, 11:42 AM #1
Unhappy Solved: need to change reserved IP address every time...
i have an odd router wifi issue.

my galaxy tab has a difficult time connecting to my wifi. it seems that the only time my galaxy will connect is when i change the DHCP reserved IP address i setup for it. it wouldn't connect before i setup a reserved IP address. now my galaxy tries to connect over and over and won't until i change the reserved IP address by a few digits.

the router is an older d-link wbr-2310. i know routers occasionally die, but this is the only problem i have with it.

any thoughts?

thanks,
jtn
Rockn's Avatar
Computer Specs
Member with 21,189 posts.
 
Join Date: Jul 2001
Location: Somalia of the North, MN
Experience: Disenfranchised American
12-Apr-2012, 11:46 AM #2
Make sure your IP address is NOT a part of your DHCP scope. If the scope is say 192.168.0.10 - 192.168.0.20 make the static IP address for your tab outside of that range. Then there will be no conflicts with DHCP.
TerryNet's Avatar
Computer Specs
Moderator with 66,530 posts.
 
Join Date: Mar 2005
Location: Ottawa, IL
12-Apr-2012, 11:54 AM #3
If you are using a static IP on the tablet then I agree with Rockn.

But if you are using Dhcp reservation in the router then the address must be in the Dhcp address range and I suspect that the router is mis-behaving,. Make sure you have the latest firmware for it; then reset it to factory default settings and reconfigure it.
__________________
Microsoft MVP - Windows Expert - Consumer (since July 2010)
jtn3833's Avatar
jtn3833 jtn3833 is offline
Member with 437 posts.
THREAD STARTER
 
Join Date: Dec 2000
Location: st. louis, mo USA
14-Apr-2012, 11:54 AM #4
Looks like Rockn is right. I thought i could only use the IP's within the given range, i guess my concept of the DHCP is wrong, never been much of a network guy.

This is great, thanks,
jtn
Rockn's Avatar
Computer Specs
Member with 21,189 posts.
 
Join Date: Jul 2001
Location: Somalia of the North, MN
Experience: Disenfranchised American
14-Apr-2012, 02:07 PM #5
Normally on a server when you are reserving an IP address for a given workstation you need to enter the MAC address of the NIC. I am not sure how reservations are set on a SOHO router.
jtn3833's Avatar
jtn3833 jtn3833 is offline
Member with 437 posts.
THREAD STARTER
 
Join Date: Dec 2000
Location: st. louis, mo USA
21-Apr-2012, 12:06 PM #6
Okay, I was wrong, it isn't working.

My DHCP IP Address Range is 100 - 199 (addresses within the LAN subnet, if that matters), so I changed the reserved IP for the Galaxy Tab to 250 and it worked, but it stopped working when I left the wifi range and didn't reconnect until I changed it to 249.

So I'm having the same problem, it connects almost immediately after I change the reserved IP for it, but then it won't connect again until I change the IP again. It doesn't seem to matter if the IP is in or out of the reserved range.

Could the router be crapping out on me? Or is there another setting I'm missing? I don't have this problem with any other wifi devices, though a laptop does lose the connection every now and then, and I just restart the router.

setting details:
d-link wbr-2310
Enable DHCP Server is on
DHCP Lease Time is 180 minutes
on this router I have 2 hardlined PC's, 1 wifi laptop, the Galaxy Tab, and 3 Blackberry phones (the phones are not usually connected, but when I enable the wifi they connect with no problem).

Suggestions?
Thanks,
jtn
DoubleHelix's Avatar
Account Disabled with 24,388 posts.
 
Join Date: Dec 2004
21-Apr-2012, 12:22 PM #7
Why aren't you simply allowing it to obtain an IP from the DHCP pool? Why are you trying to assign it a static IP? And if that's what you want to do, are you setting up that static IP on the Tab as well?
TerryNet's Avatar
Computer Specs
Moderator with 66,530 posts.
 
Join Date: Mar 2005
Location: Ottawa, IL
21-Apr-2012, 12:36 PM #8
My suspicion is that the D-Link WBR-2310 is the culprit here. I think that's the same model my daughter has and I wish it would completely stop working so that she would get something that works better. The problems it gives her--many devices cannot connect wirelessly, others can connect only after the router is power cycled--are kinda random and not fixable.

I hate to point a finger at the router when I cannot prove that it is faulty, but I really think that's the problem.

Now, if you set the Galaxy back to a dynamic connection and cannot connect to friends' networks or free public hotspots then I apologize to your router.
jtn3833's Avatar
jtn3833 jtn3833 is offline
Member with 437 posts.
THREAD STARTER
 
Join Date: Dec 2000
Location: st. louis, mo USA
24-Apr-2012, 03:25 PM #9
DoubleHelix - I've tried it both ways and, in the pool and static, and keep running into the same problem, it just can't get an IP address assigned.

I'm to the point where I think the router is just too old, I've replaced several in my time and this one is probably past its prime. it connects no problem with other routers.

Thanks for your help, I'll definitely be back if I have the same problem with a new router.
jtn
jtn3833's Avatar
jtn3833 jtn3833 is offline
Member with 437 posts.
THREAD STARTER
 
Join Date: Dec 2000
Location: st. louis, mo USA
14-May-2012, 10:06 PM #10
yeah - it was the router. i bought a new one and everything connects flawlessly.

thanks for all your help,
jtn
TerryNet's Avatar
Computer Specs
Moderator with 66,530 posts.
 
Join Date: Mar 2005
Location: Ottawa, IL
14-May-2012, 10:18 PM #11
You're welcome, and thanks for letting us know.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


Tags
connection, router, wifi

(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑