Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Networking Networking
Search Search
Search for:
Tech Support Guy > > >

Network Cable Unplugged


(!)

yatiya's Avatar
yatiya yatiya is offline
Computer Specs
Member with 20 posts.
THREAD STARTER
 
Join Date: Dec 2007
Experience: Intermediate
21-Sep-2012, 05:32 PM #1
Network Cable Unplugged
I'm sure a million others have asked about this, but here goes:

I've had to replace my router (lightning). My old router had gigabit LAN ports, and so does the new one. In between< i was using a temporary router with 100mbps ports only.

With this one, Windows reports "Network cable unplugged" when my NIC is set to Autonegotiate (Realtek GBEe gigabit LAN). If I change it to 100mbps Full duplex, it works fine. Forced 1000FD doesn't work.
The cable is obviously fine, since the old router waorked at gigabit speed with it, with autonegotiate.

Wireless connections to the router are unaffected.

I think, as usual, Windows has done something to its settings.

Can anyone help? Please. It's pointless I have a gigabit NIC, and router, and then am forced to use 100mbps speed!

My ipconfig /all:

Windows IP Configuration

Host Name . . . . . . . . . . . . : YahyasPC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
Physical Address. . . . . . . . . : 8C-89-A5-63-FE-22
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::24de:8cf2:3a2c:531%13(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.0.3(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : 21 September 2012 22:31:28
Lease Expires . . . . . . . . . . : 22 September 2012 22:31:28
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DHCPv6 IAID . . . . . . . . . . . : 227314085
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-17-21-06-36-8C-89-A5-63-FE-22

DNS Servers . . . . . . . . . . . : 192.168.0.1
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{C58E4104-B9F0-420A-853C-B041B86F89B5}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:0:9d38:953c:1031:102f:d67b:5308(Pref
erred)
Link-local IPv6 Address . . . . . : fe80::1031:102f:d67b:5308%11(Preferred)
Default Gateway . . . . . . . . . : ::
NetBIOS over Tcpip. . . . . . . . : Disabled
TerryNet's Avatar
Computer Specs
Moderator with 66,413 posts.
 
Join Date: Mar 2005
Location: Ottawa, IL
21-Sep-2012, 05:49 PM #2
Quote:
The cable is obviously fine, since the old router waorked at gigabit speed with it, with autonegotiate.
No; you mean the cable was obviously fine. You do not know (from what you've written) if it still is.

Sometimes you run into a situation where a NIC and the modem/router/switch/hub to which it is connected refuse to auto negotiate a speed, but I would first suspect the cable in this case.
__________________
Microsoft MVP - Windows Expert - Consumer (since July 2010)
yatiya's Avatar
yatiya yatiya is offline
Computer Specs
Member with 20 posts.
THREAD STARTER
 
Join Date: Dec 2007
Experience: Intermediate
21-Sep-2012, 05:51 PM #3
Yeah. but I tried the new cable that came with the router. Also didn't work.

Any other ideas?
TerryNet's Avatar
Computer Specs
Moderator with 66,413 posts.
 
Join Date: Mar 2005
Location: Ottawa, IL
21-Sep-2012, 06:00 PM #4
You indicated that lighting damaged the router. It is possible that anything connected by ethernet to the router was also damaged.

Make sure (you probably already have) that another computer will auto negotiate properly using the same cable and router LAN port. Try connecting something else to the problem computer (even another computer).
yatiya's Avatar
yatiya yatiya is offline
Computer Specs
Member with 20 posts.
THREAD STARTER
 
Join Date: Dec 2007
Experience: Intermediate
21-Sep-2012, 07:14 PM #5
I connected another router to it> Works fine on autonegotaite, and even forced 1000FD.

So i'm sure the router/NIC just aren't seeing eye to eye! I have no idea why. Sad thing is the router has wireless at 300mbps, and I use it for HD Video/audio to my TV. As it is, it's receiving/broadcasting at 300mbps, but then bottlenecks to the server because it's connected to it at 100mbps!

I've reverted my MB bios to a previous version, updated the NIC drivers, router firmware. No luck.

Funny thing is that the LAN LED comes on as the PC POST/starts, but as Windows is going through the motions it switches off. This says to me that Windows is fiddling with something!

I'm using a CAT 5e cable. Will buying a CAT 6 make a difference? (I don't see why, since the 5e was working fine all this time)
Courtneyc's Avatar
Computer Specs
Member with 1,897 posts.
 
Join Date: Dec 2003
Location: South Central Kansas
Experience: Advanced
21-Sep-2012, 08:32 PM #6
First of all, it wouldn't be Windows. Windows didn't provide the network card drivers, the manufacturer did (Microsoft doesn't actually provide drivers to anything).

Have you tried reinstalling the drivers? If that doesn't work, and you are positive it is the network card on the motherboard, you can always purchase a network card (costs around $15).
yatiya's Avatar
yatiya yatiya is offline
Computer Specs
Member with 20 posts.
THREAD STARTER
 
Join Date: Dec 2007
Experience: Intermediate
22-Sep-2012, 05:25 AM #7
Yes, but surely Windows can adjust network settings that affect this sort of thing?

I've reinstalled the NIC drivers. I've also tried my laptop, with a Broadcom Netlink Gigabit NIC, which works fine. Which means it is definitely a setting on the desktop or the NIC itself.

Buying a new card is an option, but that doesn't give me an answer as to WHY this is happening. It just bypasses the problem!
yatiya's Avatar
yatiya yatiya is offline
Computer Specs
Member with 20 posts.
THREAD STARTER
 
Join Date: Dec 2007
Experience: Intermediate
22-Sep-2012, 06:47 AM #8
New info:

By disabling "Use router as DHCP server" in the router config, the autonegotiate starts working. Problem is, any device trying to connect wirelessly (such as a smartphone), can't get an IP address.

So it seems there's a conflict between the router's DHCP, and Windows. I can't understand why it's only on the desktop, though. I tried checking the laptop's settings, and the only difference I could find was "Flow Control", which was disabled. Disabling it on the desktop didn't make a difference.
TerryNet's Avatar
Computer Specs
Moderator with 66,413 posts.
 
Join Date: Mar 2005
Location: Ottawa, IL
22-Sep-2012, 09:17 AM #9
With the connection set to a valid static IP configuration the speed auto negotiation works if and only if the router's Dhcp server is disabled? This just gets stranger and stranger. If the NIC is set to a static IP the router's Dhcp server should not be in the picture whether it is enabled or not????
yatiya's Avatar
yatiya yatiya is offline
Computer Specs
Member with 20 posts.
THREAD STARTER
 
Join Date: Dec 2007
Experience: Intermediate
22-Sep-2012, 11:38 AM #10
Terry, the NIC is obtaining it's IP automatically. However, I have tried a static IP, and it doesn't work,

After I made that post, I tried disabling the router DHCP again, and this time it didn't work. I'm going out of my mind!
TerryNet's Avatar
Computer Specs
Moderator with 66,413 posts.
 
Join Date: Mar 2005
Location: Ottawa, IL
22-Sep-2012, 12:09 PM #11
Your mind is too valuable to lose--try a PCI NIC and disable the integrated one.
yatiya's Avatar
yatiya yatiya is offline
Computer Specs
Member with 20 posts.
THREAD STARTER
 
Join Date: Dec 2007
Experience: Intermediate
23-Sep-2012, 03:42 PM #12
Lol.

Think I'm going to have to.

Any suggestions on which one is a good one?
yatiya's Avatar
yatiya yatiya is offline
Computer Specs
Member with 20 posts.
THREAD STARTER
 
Join Date: Dec 2007
Experience: Intermediate
24-Sep-2012, 10:39 AM #13
Guys, this gets weirder....

Even though I have now forced the connection to 100mbps FD, it is only connected at 10mbps!

I tested it with the Realtek Diagnostic utility, and thought maybe it was a mistake. But clicking "Open Network and Sharing centre", then clicking "Local Area Connection" brings up the LAN status window, which also says 10mbps!

Any thoughts?
yatiya's Avatar
yatiya yatiya is offline
Computer Specs
Member with 20 posts.
THREAD STARTER
 
Join Date: Dec 2007
Experience: Intermediate
03-Oct-2012, 06:41 AM #14
Success! I said "screw you" to Realtek, bought a D-link DGE 528T, CAT 6 cable, and I've got 1gbps, autonegotiate.
Doesn't solve the problem, since not everyone can just go buy a new adapter, but what the hell! It works, baby!
TerryNet's Avatar
Computer Specs
Moderator with 66,413 posts.
 
Join Date: Mar 2005
Location: Ottawa, IL
03-Oct-2012, 08:34 AM #15
Quote:
Doesn't solve the problem, since not everyone can just go buy a new adapter
Why do you say it doesn't solve the problem of a defective integrated NIC? Sure is a lot less expensive and less inconvenient than buying a new motherboard or computer.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑