Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Networking Networking
Search Search
Search for:
Tech Support Guy > > >

get rid of ip address 169.254._._ in xp


(!)

merceda's Avatar
merceda merceda is offline
Junior Member with 15 posts.
THREAD STARTER
 
Join Date: Apr 2004
06-Apr-2004, 12:47 PM #1
get rid of ip address 169.254._._ in xp
how to get rid of the ip address 169.254._._ in windows. tried the ipconfig /release command and no luck, installed different network card and still didn't clear this address. is there any other way beside re-installing windows.....help
Monstrous Mi's Avatar
Monstrous Mi Monstrous Mi is offline
Senior Member with 623 posts.
 
Join Date: Jul 2002
Location: Ottawa, Canada
06-Apr-2004, 01:46 PM #2
Go to TCP/IP>Properites. Does it say "Automatically Obtain IP Address"? If it does, then every time you get on the Internet, whatever ISP you are using is assigning that address again after you /Release it.

What exactly are you trying to do?
coulterp's Avatar
Senior Member with 1,625 posts.
 
Join Date: Oct 2003
Location: Surrey, UK
Experience: Advanced, but always ready to learn more!
06-Apr-2004, 02:17 PM #3
Where to start? You don't really give enough information. The IP address you are getting happens when the NIC cannot contact a DHCP server (and Windows allocates the 169.254. address as a "fix" to allow local networking.

So do you have a DHCP server (typically hardware router, or Microsoft software router ICS) on the network.
If no ... there you are then!
If yes then the problem could be various things (faulty NIC, faulty cable, faulty cable connectors, NIC not seated well in PC, etc, etc, etc). In the absence of further information it's hard to take it any further at the moment.
pinger's Avatar
pinger pinger is offline
Member with 80 posts.
 
Join Date: Oct 2003
Location: Mobile AL
06-Apr-2004, 04:11 PM #4
The reason why this is occuring is because you probably don't your NIC Cable plugged in to a router or you don't have a Static IP setup. But I agree with above not enough information to troubleshoot. Here is some stuff for you reading pleasure.

Getting a 169.x on a windows system is a feature of Automatic Private IP Addressing.

To Disable this feature in Windows XP:

To disable APIPA by editing the registry

1. You do this by adding the registry entry IPAutoconfigurationEnabled with a value of 0 (REG_DWORD data type) in the following subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Inter faces\interface-n ame

2. Use the registry editor Regedit.exe to add the above entry, and then restart the computer.
plucnik's Avatar
plucnik plucnik is offline plucnik has a Profile Picture
Member with 132 posts.
 
Join Date: Aug 2003
Location: Chicago USA
06-Apr-2004, 06:24 PM #5
If your sure all is working correctly (the network is up, the PC is connected to the hub etc).............I've had this problem from time to time and I've tried this first. Try entering a static IP and primary DNS (secondary not needed) in the NIC's properties and rebooting. This might "reinitialize" the NIC. After a day or so, try setting the IP properties back to automatic. I admit, it's a "work around" but it seems to work at times.
merceda's Avatar
merceda merceda is offline
Junior Member with 15 posts.
THREAD STARTER
 
Join Date: Apr 2004
06-Apr-2004, 09:36 PM #6
the system is connected to a LinkSys router, and I'm on cable modem, and windows is configured for dhcp setting, it was working fine, when I left for a while, I couldn't get back on my Internet. Tried to ping my router and didn't get any response. that's when i noticed my ip address changed to 169.254._._, and I couldn't release it. did try to put in static ip address, but I did not stay with it for more than a day. left the sytem running over a day with a dhcp setting, and still did not change. I will try set it up with a static ip for a day or so and see what happens......
plucnik's Avatar
plucnik plucnik is offline plucnik has a Profile Picture
Member with 132 posts.
 
Join Date: Aug 2003
Location: Chicago USA
06-Apr-2004, 10:42 PM #7
hmmmmmm.....Windows is the DHCP server. I assume that you have more than one PC because you have a router as well as a cable modem. I don't have cable internet so I'm guessing but does the modem have any settings? The router should have a default IP to enter it's interface. What I'm fishing for is it may be a conflict between the Windows DHCP server and maybe the router or modem doing the same thing. Now how does something like that all by itself? Who knows...I've seen crazier things. Just a idea, if it's a small home network, it's probably easier and less complicated to have the router use it's DHCP server instead of using Windows DHCP.
Bob Cerelli's Avatar
Member with 22,468 posts.
 
Join Date: Nov 2002
06-Apr-2004, 11:22 PM #8
It didn't sound like Windows was the DHCP server but rather "windows is configured for dhcp setting".

Can you simply find out the IP scheme on the other computers and manually configure everything the same except for the actual IP address.

Then, in order:

1. Ping another computer's IP address
2. Ping the router's IP address
3. Ping an external IP address - 1991.181.164.1
4. Pint an external name

And post the results.
__________________
Bob Cerelli
http://www.onecomputerguy.com
merceda's Avatar
merceda merceda is offline
Junior Member with 15 posts.
THREAD STARTER
 
Join Date: Apr 2004
07-Apr-2004, 06:06 PM #9
my linksys is the dhcp server, and windows is set to dhcp setting. i configured my network settings to static ip. ping the other computer and it replies with no problem, didn't get any reply when tried to ping comcast.net. but i was able to ping comcast.net from other computer and replies with no problem. the machine i'm having trouble with could not release the 169.254._._ when I put the settings back to dhcp., but when i used a static ip, i could ping the router(linksys) and other computer but could not get on the internet....
plucnik's Avatar
plucnik plucnik is offline plucnik has a Profile Picture
Member with 132 posts.
 
Join Date: Aug 2003
Location: Chicago USA
07-Apr-2004, 06:20 PM #10
I don't want to step on Bob's post (he has a great web site) but .....what IP are you pinging the router with? It should be a 192.xxx.xxx.xxx on your side of the router. Post what the IP is from the LinkSys interface. You may have a bad router.
Bob Cerelli's Avatar
Member with 22,468 posts.
 
Join Date: Nov 2002
07-Apr-2004, 06:39 PM #11
Sorry for the couple of typos in my last post.

Pinging (not pinting - too much beer) an external name should be the last thing you try. This is because unless all the others work, this last one won't. It also doesn't help determine wherer the problem might be.

For example, and why I put them in the order I did (yes there is some thought to the madness):

1. If you can't ping any local computer's IP address (and they all work ok), then you have a pretty basic problem and there is no point in going any further trying to connect to the Internet. You typically have a bad or misconfigured network card, cable or port on the hub. Start swapping with known working ones.

2. If you can ping local computers but not the router then likely either the router is configured differently for the rest of the computers or it is defective.

3. If you can't ping an external IP address, then you won't be able to ping by name. If this doesn't work then double check the gateway setting on the workstations and make sure the DSL connection is working. One way might be to directly connect a computer to the DSL/Cable modem. If this works, then the problem is likely the router is misconfigured or defective.

4. If you can ping by IP but not name, then likely DNS is not configured correctly.
merceda's Avatar
merceda merceda is offline
Junior Member with 15 posts.
THREAD STARTER
 
Join Date: Apr 2004
07-Apr-2004, 11:44 PM #12
i can ping the router when i configured the network card with static ip, i can ping the other computer that is on the same router too. but when i set my network card setting to dhcp i get 169.254._._ ip address and could not renew or release this address, so the system is not able to ping any router or other system. it's just seems like window is getting this ip address permanently when i set the network card to dhcp configuration.
merceda's Avatar
merceda merceda is offline
Junior Member with 15 posts.
THREAD STARTER
 
Join Date: Apr 2004
07-Apr-2004, 11:46 PM #13
oh by the way, my ip address for the router is 192.168._._ and this is what i used to configure for static ip....
merceda's Avatar
merceda merceda is offline
Junior Member with 15 posts.
THREAD STARTER
 
Join Date: Apr 2004
07-Apr-2004, 11:49 PM #14
I connected the computer straight to the cable modem and still can't get a new ip address and the my network card is set to dhcp. my other computer works fine with a dhcp configuration and connected to the my LinkSys router.
Bob Cerelli's Avatar
Member with 22,468 posts.
 
Join Date: Nov 2002
08-Apr-2004, 12:21 AM #15
If everything works correctly when you give it all the IP address information manually, why not just leave it that way.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑