Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Networking Networking
Search Search
Search for:
Tech Support Guy > > >

ICS Not Working (using Cat5 Crossover Cable)


(!)

cyberdeath's Avatar
cyberdeath cyberdeath is offline
Computer Specs
Member with 61 posts.
THREAD STARTER
 
Join Date: Jul 2005
Location: 127.0.0.1
Experience: Advanced
13-Aug-2005, 08:53 AM #1
Unhappy ICS Not Working (using Cat5 Crossover Cable)
Alright, I've been working on this problem for a while now on this Win XP Pro box and I'm still clueless as to what it is. Basically, I have dial-up internet because I live in an area where you have to pay $60 a month for a 5GB transfer cap per month (up/download) or get 56k for $17 a month (prepaid for the year).

Anyway, with that said, I've been trying to connect up a router with DHCP disabled and be able to share my internet connection with the computer next to me (hardwired) and my laptop (wireless) (you can view my detailed situation here).

Well, I decided to take the router out of the picture and go back to crossover cable since I haven't been able to successfully get it to working (I figure once I get that working, it'll just be a matter of swapping the cables to go to the router...hopefully). I went ahead and enabled ICS by first adding my dial-up connection again, right clicking onto my current connection, selecting properties, then advanced (NOTE: I uninstalled ALL my "Network" Hardware in Device Manager as well as I deleted my dial-up connection then readded all this back after I rebooted [I didn't physically remove anything]). I checked the box that said "Enable internet connection sharing", then I selected the box for the network adapter which I would like to share with and pressed ok. It enabled Windows Firewall, which I disabled.

Now that I had ICS enabled, it changed "Local Area Connection" to be manually configured to 192.168.0.1 and a subnet mask 255.255.255.0. It seemed to work until I looked at the client computer (which is Windows 2000 Pro) that gave me a 169.254.*.* IP address. Why is this happening? I've already checked in Services to see if the DHCP server was running or not, and it is along with the DNS service.

Also, when I manually configure the IP address on the client computer to a 192.168.0.* address (such as 192.168.0.3), ICS still doesn't work...so I'm guessing it may be more than DHCP.

The weird thing I've ran into is once I enable the Shared connection, it's impossible to disable it. That is, unless I delete the Network Devices and the dial-up connection, then reinstall it all. When I go into Network Connections with it enabled and disable it by unchecking the box and pressing ok...when I go back and look, the box is still checked...does anyone have any clue as to what's going on? Is there a patch or something out there to reset ICS completely in Win XP Pro? The only thing that I don't want to have to do is reinstall my Operating System or use the repair function with the xp disk, etc...unless that's my only option whatsoever (and it'll fix it).

Honestly, I think the answer to my problem is going to take an Einstein and then some but hopefully someone reading this post will be able to help me . I also hope this new post is easier to understand over my previous one.

Thanks for taking the time to read this even if you don't have a clue. It's just aggrivating since noone seems to know how to fix this.
blin's Avatar
blin blin is offline
Member with 272 posts.
 
Join Date: Aug 2003
Location: Chicago, USA
13-Aug-2005, 11:08 AM #2
when connecting both computers, do you see the green light on both NICs? try another cable to test it.
TerryNet's Avatar
Computer Specs
Moderator with 66,131 posts.
 
Join Date: Mar 2005
Location: Ottawa, IL
13-Aug-2005, 02:12 PM #3
Above you said, "Now that I had ICS enabled, it changed "Local Area Connection" to be manually configured to 192.168.0.1 ..." If IT (Windows) made that change, I'm really, really lost. If YOU made that change, that was your first mistake. Leave it alone (obtain IP/DNS automatically), and have any client computers obtain their IP/DNS automatically. Your computer that is sharing its internet connection will make sure that all computers on the LAN will have appropriate 169.254.*.* addresses.

Have ICS working with the crossover cable and ready to try the router again? You might want to search this forum for one of JohnWill's "connect two SOHO routers" posts (because with ICS your host computer is acting as a router). Here is my suggestion:

Patch cable from laptop or "client" desktop; configure the router to disable DHCP server and set the LAN mask to 255.255.0.0 and the LAN IP to 169.254.255.255 (and hope that this is not selected by one of your computers). Then connect the host computer to a LAN port on the router with (I think) a cross-over cable. Restart the router, the host computer and finally the client computer(s).
cyberdeath's Avatar
cyberdeath cyberdeath is offline
Computer Specs
Member with 61 posts.
THREAD STARTER
 
Join Date: Jul 2005
Location: 127.0.0.1
Experience: Advanced
14-Aug-2005, 12:50 AM #4
blin, my NIC cards are fully functional as well as all cables involved. Both NIC cards are communicating correctly as they work and have worked prior to this (again, I used to have it setup with ICS but now it doesn't seem to work... [it also worked pre-SP2 so I don't know if that has anything to do with it...oh, and Windows Firewall is Disabled]. If I setup both computers to Obtain an IP address Automatically, it'll give me a 169.254.*.* IP address and I will be able to fileshare, print, and use AnalogX proxy to be able to use the internet somewhat (I just hate having the proxy settings setup and the limited functionality). Also, I can do the same as above if I leave this computer with the 192.168.0.1 IP address and set the other computer to a 192.168.0.* (I have * set to 3 right now on the other computer so I can still somewhat have internet connectivity). But, again, my goal is to have an ICS connection working again.

Back when I had the connection working, it would give my main computer the Gateway IP address of 192.168.0.1 (and to answer your question TerryNet, Windows did configure it).

Right now I'm not even trying to involve the router (and yes, DHCP is disabled) and I'm only dealing with a crossover cable between the two computers (I want to get ICS to work first, then I'll go from there). In regards to your question TerryNet about the 169.254.*.* IP address to have ICS work...I don't think that's exactly true (someone else correct me if I'm wrong), but before when I set up this computer with ICS (and it worked), it would give this one 192.168.0.1 and the client computer got something like 192.168.0.100. The problem arose when I decided to get a wireless network going at the same time and I decided to get a PCI Wireless card and run ad-hoc (that was my mistake, I figured you could bridge the connections and have ICS work, but of course it doesn't). So, at that point, I changed ICS to the Wireless Card...then later I disabled it again and pointed it back to the old one, and that's when it stopped working. I haven't been able to get ICS to work since. Now that I have the router, I'd be able to share the connection with both my laptop and desktop. Oh, and I use a patch cable between the router and the card for my gateway box and it works fine (when I was messing with the router). You don't need a crossover for that.

Oh, I removed the Wireless PCI Card as well to see if that made a difference, but it didn't.

If you all have any more recommendations or questions to better understand my situation, I'd love to hear them!
TerryNet's Avatar
Computer Specs
Moderator with 66,131 posts.
 
Join Date: Mar 2005
Location: Ottawa, IL
14-Aug-2005, 01:22 PM #5
I'm still lost with that 192... address. My only suggestion would be to give it one more chance. Set both computers to obtain IP and DNS automatically, connect the cross-over cable, connect to the internet, run the Network Setup Wizard on the XP machine and then on the Win2k Pro.
cyberdeath's Avatar
cyberdeath cyberdeath is offline
Computer Specs
Member with 61 posts.
THREAD STARTER
 
Join Date: Jul 2005
Location: 127.0.0.1
Experience: Advanced
14-Aug-2005, 11:29 PM #6
You cannot run the Network Setup Wizard on Windows 2000 Pro, I've already tried that before. It automatically sets the IP to 192.168.0.1 (if you google ICS, that's normal behavior). I don't think you're supposted to be connected to the internet already either...I've done it while disconnected. But, thanks anyway . I appreciate you taking the time to even try and help me.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑