Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Networking Networking
Search Search
Search for:
Tech Support Guy > > >

Solved: Connect 2 routers together?


(!)

Nick8539's Avatar
Nick8539 Nick8539 is offline
Computer Specs
Member with 203 posts.
THREAD STARTER
 
Join Date: Jul 2006
Location: Miami, Florida
Experience: Intermediate
31-Jul-2006, 12:18 AM #1
Solved: Connect 2 routers together?
Sorry. Figured it out.

Last edited by Nick8539; 31-Jul-2006 at 12:51 AM..
bassetman's Avatar
Computer Specs
Moderator - Gone but never forgotten with 47,973 posts.
 
Join Date: Jun 2001
Location: Great White North (WI)
Experience: Getting somewhere I hope
31-Jul-2006, 12:56 AM #2
Care to share for others?
Nick8539's Avatar
Nick8539 Nick8539 is offline
Computer Specs
Member with 203 posts.
THREAD STARTER
 
Join Date: Jul 2006
Location: Miami, Florida
Experience: Intermediate
31-Jul-2006, 08:43 AM #3
Sure! Sorry I just got a walkthrough from a different site and wanted to try that first so that I wont bother you guys with something I could've found off the net.

Heres the walkthrough I found.

Connecting Two WRT54G Routers Together


Product Class:
WRT54G

Operating System:
N/A




Q U E S T I O N

How do I setup a WRT54G behind another WRT54G?




A N S W E R



WRT54G (first) ----------> WRT54G (second)
During this article, the two routers will be referred to as the “first” router (the main router), and the “second” router (the router that you are connecting to the first). The information assumes that both routers are Linksys WRT54G routers both with default factory settings to start; however, if you are familiar with the steps, they can apply to other routers and other manufacturer routers as well. Please contact the appropriate manufacturer for assistance.



Note: Having a “Dual Router Network” can potentially cause unexpected problems during the troubleshooting process if you were to ever have a problem. Be sure to record and remember any settings that are changed during this setup process. Settings that are changed are summarized at the end of this article.



Configuring the “second” router


1. With the “second” router powered on, and nothing plugged into any of its network ports, hold in the Reset button on the unit for about 30 seconds.

2. Connect one computer (it does not matter which one) into one of the numbered ports on the back of the “second” router, then restart or turn on that computer.

3. Verify that you are getting a Link light that matches the port to which you plugged the computer into. For example, if the computer was plugged into port 2, then the Link light on the front of the router for the number 2 port should be lit.

4. When the computer finishes its start up, open a web browser.

5. In the “Address Bar” type http://192.168.1.1 and press the [Enter] key on your keyboard

6. A box should appear asking for a “User Name” and “Password”. Leave the “User Name” field empty and type your WRT54G’s password into the “Password” field (The default “Password” is admin) and click the OK button.

7. The router “Setup” page should load.

8. You need to change two options on this page.

Local IP Address: change to 192.168.1.2

DHCP Server: set to Disable

9. Click on the Save Settings button toward the bottom of the page to save changes, and then close your web browser.



Physically connecting the two routers


10. Unplug the power to both “first” and “second” routers.

11. Take a straight-through network Ethernet patch cable and connect it to a free numbered port of the “first” router (1, 2, 3, or 4), and plug the other end of the cable into port 4 of the “second” router.

12. Plug the power cord first the “first” router, and then the “second” router.

13. At this point, the two routers are now connected and on the same network. Ports 1, 2, and 3 on the “second” router along with the remaining open ports on the “first” router are now available for other devices to plug into. You also have another wireless access point on the “second” router. Be sure to change the wireless SSID and channel on the “second” router so that they do not conflict with the “first” router.



To recap the settings of both routers:



“First” router: (default factory settings)
Local IP address: 192.168.1.1

DHCP Server: Enable





“Second” router
Local IP address: 192.168.1.2

DHCP Server: Disable



The “second” router can now be easily referred to as a Wireless 3-port switch.



If any of the steps do not work, or if you are having other difficulties, please contact Linksys Technical Support for further assistance.
Nick8539's Avatar
Nick8539 Nick8539 is offline
Computer Specs
Member with 203 posts.
THREAD STARTER
 
Join Date: Jul 2006
Location: Miami, Florida
Experience: Intermediate
31-Jul-2006, 08:45 AM #4
What I like about this the most is that I can use the second router as an access point. So I can have signal strength throughout the house. Im going to try this as soon as I get home tonight and let you guys know how it worked out.
TerryNet's Avatar
Computer Specs
Moderator with 63,945 posts.
 
Join Date: Mar 2005
Location: Ottawa, IL
31-Jul-2006, 12:46 PM #5
Just remember that the steps assume that the primary (first) router has LAN IP 192.168.1.1 and that 192.168.1.2 is NOT in its DHCP address range. You may have to make adjustments depending on your router.

If you want a concise version, do an Advanced Search in this forum for "connect two SOHO" and you will find JohnWill's oft-posted, oft-used instructions.
Nick8539's Avatar
Nick8539 Nick8539 is offline
Computer Specs
Member with 203 posts.
THREAD STARTER
 
Join Date: Jul 2006
Location: Miami, Florida
Experience: Intermediate
31-Jul-2006, 01:35 PM #6
Oh good. If these instructions dont work Ill definitely do that.
Thanks!
Nick8539's Avatar
Nick8539 Nick8539 is offline
Computer Specs
Member with 203 posts.
THREAD STARTER
 
Join Date: Jul 2006
Location: Miami, Florida
Experience: Intermediate
31-Jul-2006, 07:36 PM #7
Ok a little help here guys.

I tried getting this to work and it didnt work. When I try connecting both routers together via ethernet cable, port 3 which is the port i used to connect the 2 routers, does not light up.
I am connecting from port 3 in the new router to port "Uplink" in the old router. (i also tried port 4 in the old router and get the same results)

Here are some of my configs

Router 1
ip 192.168.1.1
DHCP: Enabled

Router 2
ip 192.168.1.254
DHCP: Disabled
(i have tried 192.168.1.2 as well and get the same results)

Any help would be appreciated.
Are there anything else I shuold make sure is checked off on either one of the routers? anything like that?

PS. I also looked at JohnWill's "connect two SOHO" but that didnt help me either.
TerryNet's Avatar
Computer Specs
Moderator with 63,945 posts.
 
Join Date: Mar 2005
Location: Ottawa, IL
31-Jul-2006, 07:55 PM #8
Are you using a known good cable? Patch or cross-over cable?

Is "old router" same as " Router 2"?

Have you tried a different port in "new router"?
Nick8539's Avatar
Nick8539 Nick8539 is offline
Computer Specs
Member with 203 posts.
THREAD STARTER
 
Join Date: Jul 2006
Location: Miami, Florida
Experience: Intermediate
31-Jul-2006, 08:10 PM #9
Quote:
Originally Posted by TerryNet
Are you using a known good cable? Patch or cross-over cable?
Yes i am using a long cable RJ45-RJ45 not sure if its patch or cross-over. I do know the cable works though because I use it to connect to this pc from the new router. I can tell you is that the cable that I have from the old router to PC #2 which is in port 1 in the old router is a patch cable. (I just bought it and didnt realize there was a difference)

Quote:
Originally Posted by TerryNet
Is "old router" same as " Router 2"?
Yes from now on new router is router 1 and old router router 2.

Quote:
Originally Posted by TerryNet
Have you tried a different port in "new router"?
Yes I have tried different ports in "new router" and get the same results in each. However if I try to put the cable in the old router in port 2 or 3 I get the 100, Full/Col, and Link/Act buttons flashing on and off.

Now with the first setup, sometimes I receive a limited or no connectivity error. and when trying to repair it cant renew the ip address.
Maybe im getting a little closer now? One more thing, I also noticed that when I disable the DHCP in the old router i can no longer go back in to the http://192.168.... window. Is this suppose to happen?

Last edited by Nick8539; 31-Jul-2006 at 08:16 PM..
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
31-Jul-2006, 08:21 PM #10
Connecting two SOHO broadband routers together.

Configure the IP address of the secondary router to be in the same subnet as the primary router, but out of the range of the DHCP server in the primary router. For instance DHCP server addresses 192.168.0.2 through 192.168.0.100, I'd assign the secondary router 192.168.0.254 as it's IP address.

Disable the DHCP server in the secondary router.

Setup the wireless section just the way you would if it was the primary router.

Connect from the primary router's LAN port to one of the LAN ports on the secondary router. If there is no uplink port and neither of the routers have auto-sensing ports, use a cross-over cable. Leave the WAN port unconnected!
__________________
Remember: Data you don't have at least two copies of is data you don't care about.
rolandk10's Avatar
rolandk10 rolandk10 is offline
Computer Specs
Senior Member with 121 posts.
 
Join Date: Oct 2005
Location: Naples, FL
Experience: OOPS! Fixed it
31-Jul-2006, 08:25 PM #11
The key to getting this to work is the wiring. The uplink port should basically create a crossover cable out of a standard cable for you thus negating one of the available ports. Don't confuse the internet port with an uplink port. You can buy or make a crossover cable as well. if you want to make one for a 100mb network, you only need a cat5 cable with two pairs. it would be something like this:

One side of the cable would be (pin1 blue, pin2 blue/white, pin3 orange, pin6 orange/white)
You would use that same configuration on the other end for a normal cable but for the cross over, switch the pairs on the other end like this:
(pin1 orange, pin2 orange/white, pin3 blue, pin6 blue/white)
Nick8539's Avatar
Nick8539 Nick8539 is offline
Computer Specs
Member with 203 posts.
THREAD STARTER
 
Join Date: Jul 2006
Location: Miami, Florida
Experience: Intermediate
31-Jul-2006, 08:27 PM #12
I tried that and connected the primary router to the uplink port in the secondary router and run a patch cable from 2nd PC to port 1 in the secondary router and get no connection.

I do received a limited or no connectivity error.

These are my configs

Primary Router
IP 192.168.2.1
DHCP Enabled

Secondary Router
IP 192.168.2.2
DHCP Disabled

Also, once I wire it together I cant log in to the 192.168.2.2... interface from the 2nd computer.

I hope im not confusing you guys. The second computer is connected to router 2 via ethernet cable as well.
rolandk10's Avatar
rolandk10 rolandk10 is offline
Computer Specs
Senior Member with 121 posts.
 
Join Date: Oct 2005
Location: Naples, FL
Experience: OOPS! Fixed it
31-Jul-2006, 08:36 PM #13
what brand/models of routers are you using?
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
31-Jul-2006, 08:36 PM #14
What is the range of the DHCP pool in the primary router? If 192.168.2.1 is in the DHCP pool range, you need to move the second router or change the DHCP pool starting address.
TerryNet's Avatar
Computer Specs
Moderator with 63,945 posts.
 
Join Date: Mar 2005
Location: Ottawa, IL
31-Jul-2006, 08:38 PM #15
Apparently you are using a patch or regular cable to connect the routers, so you have to use the uplink port on router 2. On some routers, I understand, when you use the uplink port you cannot use one of the other ports for anything. Have you checked the User Guide to make sure that, if this is the case with yours, you are not trying to use that other port.

And, as rolandk10 already stated, the uplink port is NOT the WAN/Internet/Modem port.

Oh, and after you disable Dhcp on router 2, a computer connected to it will not get assigned an IP configuration if the router 1 to router 2 connection is not working. Also, a computer connected to router 1 will, of course, not be able to communicate with router 2 until the link is working.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑