Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Networking Networking
Search Search
Search for:
Tech Support Guy > > >

Solved: Microsoft iSCSI Initiator issue


(!)

angel's Avatar
Member with 2,736 posts.
THREAD STARTER
 
Join Date: Dec 1998
Location: NE of Madtown, WI
Experience: Advanced
03-Nov-2006, 03:40 PM #1
Question Solved: Microsoft iSCSI Initiator issue
I thought this forum would be the most appropriate but if you guys would like to move it, feel free!

Windows Storage Server 2003 R2 (64bit)
Dell (EMC, actually) AX150i
Microsoft iSCSI Initiator

For the most part, everything is working. Pools and Virtual Disks setup on the AX150i, disks assigned to the server, and initialized/formatted in Windows. Drive letters and all assigned. I thought everything was peachy...

Setup a few shares on the iSCSI disks - no prob.
Restarted - problem! The shares are gone! (drives and files all still there - just the shares are no longer shared) Ok, don't panic.
I find MS KB 870964 and think this will resolve my issue.
Server service set to be dependent upon Microsoft iSCSI Initiator Service. I confirmed this is now done.
Configure persistent logons to the target. Per their instructions - already done when initially setup but have redone now too many times to count!
The problem comes in with Step 2 to Configure the BindPersistentVolumes option. I can run the iscsicli BindPersistentVolumes with no error. The problem is that the iSCSI Initiator is apparently not seeing there are any persistent Volumes to bind.
If I run ReportPersistentDevices, it shows there are no Persistent Volumes so that means that BindPersistentVolumes has nothing to bind which needs to happen according to MS.

When I run Microsoft iSCSI Initiator, it shows the 4 persistent targets that should be there but I cannot figure out how to do any bindings (see attached images). If I enter one of the drive letters of the iSCSI disks, I just get a message telling me that "The device specified does not originate from an iSCSI disk or a persistent iSCSI login" when I know that is not true.
Maybe I just do not know the correct syntax or what it is actually looking for where I need to enter "Drive letter or mount point of volume or Device" and I have not been able to find ANY screen shots or examples of this online.

Based on what I've found online, there have been numerous similar issues over the last year but I have yet to find any actual solution.

Thanks much to anyone that has any suggestions!
(the only solution at the moment to the original prob with shares disappearing is to restart the Server Service after the Server restarts. Then the shares all reappear. Not a good solution)

Angel
Attached Thumbnails
Solved: Microsoft iSCSI Initiator issue-1.jpg   Solved: Microsoft iSCSI Initiator issue-2.jpg  

Last edited by angel; 03-Nov-2006 at 03:59 PM..
angel's Avatar
Member with 2,736 posts.
THREAD STARTER
 
Join Date: Dec 1998
Location: NE of Madtown, WI
Experience: Advanced
03-Nov-2006, 03:58 PM #2
Just a little update or more information...
If I specify that actual drive letter and folder that is shared (ex. g:\home), I get "Access Denied" message when trying to add as a Persistent Volume or Device for binding. Not sure if that is a misleading error or not. I've tried as myself (domain admin) and as the local administrator account. Permissions set correctly on the share and the directory.

Wierd... I just wonder if the MS iSCSI Initiator doesn't have all the bugs worked out yet.
(oh, ya, I'm using v 2.02, btw)
angel's Avatar
Member with 2,736 posts.
THREAD STARTER
 
Join Date: Dec 1998
Location: NE of Madtown, WI
Experience: Advanced
03-Nov-2006, 09:03 PM #3
Well, I finally got it working. I do hope this helps anyone else that may run across this apparent "bug".
I also had EMC's PowerPath 4.5.1 running and that version was interfering somehow with the iSCSI Initiator. I uninstalled 4.5.1 and installed 4.6 (which isn't even an available download option - I had to get it from Dell who got it from EMC).

Anyhoo, after installing version 4.6 I was able to bind with no problems and no errors. In fact, just hit the Bind All button and my drives popped right in for me.
Of course, since that worked, my original issue is no longer an issue - since the iSCSI Initiator Service isn't allowed to complete until my bound volumes are fully ready (and the Server service [which sets the shares] isn't set to start until the iSCSI service is complete), the shares map just fine after a restart!
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑