Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Networking Networking
Search Search
Search for:
Tech Support Guy > > >

My laptop keeps connecting to a different network than mine!


(!)

supermanno's Avatar
supermanno supermanno is offline
Computer Specs
Member with 148 posts.
THREAD STARTER
 
Join Date: Jan 2004
Location: Utah
Experience: Intermediate
14-Nov-2006, 03:01 PM #1
My laptop keeps connecting to a different network than mine!
I have a problem: I have a wireless network which works great. Unfortunately for some reason my laptop keeps disconnecting from my netowrk and connecting to an outside netowork. Theres a bunch of wireless networks around here (some of which unprotected with password) and my laptop keeps switching back and forth thus disconnecting me contiually. I put my wireless network on top priority in the advanced tab, but to no avail. Is there anything I can do so that my laptop stays connected to my network? Also I go to my university and use their wireless network, so I dont wanna completely switch off all other networks, as sometimes I do need to connect to them. How do I go about doing this?
thank you very much
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
14-Nov-2006, 03:07 PM #2
Set it to only connect to preferred networks.
foneguy9's Avatar
foneguy9 foneguy9 is offline foneguy9 has a Profile Picture
Member with 196 posts.
 
Join Date: Sep 2006
Location: Pasadena, CA
Experience: Beginner to sporadically Advanced
14-Nov-2006, 03:11 PM #3
Hi Supermanno,

A few questions for you...

Are u using the Windows Wireless Network Connection?

Also, what kind of signal strength are u getting with your network? Have you secured your network?

Assuming the Wireless Network Connection that comes with Windows:
If you go to the Wireless Conection Properties
Wireless Networks Tab
Under Preferred Networks
Select each of the 'other' networks that you DO NOT want to connect to...
Press the Properties button
Go to the Connection TAB
UNCHECK the box, Connect when this network is in range.
Click OK...

Of course, this will be different if you are using a proprietary Wireless connection software....
foneguy9's Avatar
foneguy9 foneguy9 is offline foneguy9 has a Profile Picture
Member with 196 posts.
 
Join Date: Sep 2006
Location: Pasadena, CA
Experience: Beginner to sporadically Advanced
14-Nov-2006, 03:16 PM #4
As JohnWill mentioned, this would be the easier way to do it...

If you go to the Wireless Conection Properties
Wireless Networks Tab
In the Preferred Networks press the Advanced Tab
At the bottom of that window you have a check box to Automatically connect to non-preferred networks. Make sure it is UNCHECKED.

That should be it....

JohnWill is ALWAYS right on...
supermanno's Avatar
supermanno supermanno is offline
Computer Specs
Member with 148 posts.
THREAD STARTER
 
Join Date: Jan 2004
Location: Utah
Experience: Intermediate
14-Nov-2006, 03:42 PM #5
Quote:
Originally Posted by foneguy9
Hi Supermanno,

A few questions for you...

Are u using the Windows Wireless Network Connection?

Also, what kind of signal strength are u getting with your network? Have you secured your network?

Assuming the Wireless Network Connection that comes with Windows:
If you go to the Wireless Conection Properties
Wireless Networks Tab
Under Preferred Networks
Select each of the 'other' networks that you DO NOT want to connect to...
Press the Properties button
Go to the Connection TAB
UNCHECK the box, Connect when this network is in range.
Click OK...

Of course, this will be different if you are using a proprietary Wireless connection software....
My signal is very strong and is secured. But also the other signals are strong. Its kind of funny... the other wireless networks dont show up on my preferred network list BUT they show up in the "choose a wireless network" window. WHats the deal?
foneguy9's Avatar
foneguy9 foneguy9 is offline foneguy9 has a Profile Picture
Member with 196 posts.
 
Join Date: Sep 2006
Location: Pasadena, CA
Experience: Beginner to sporadically Advanced
14-Nov-2006, 03:51 PM #6
K,
So those Networks don't have a little Yellow Star on the upper right hand side of the bar of the 'Choose a wireless network'? This indicates a preferred network.
Did you also try what JohnWill suggested from the Advanced Button? That should fix you up straight away.
supermanno's Avatar
supermanno supermanno is offline
Computer Specs
Member with 148 posts.
THREAD STARTER
 
Join Date: Jan 2004
Location: Utah
Experience: Intermediate
14-Nov-2006, 07:42 PM #7
Quote:
Originally Posted by foneguy9
K,
So those Networks don't have a little Yellow Star on the upper right hand side of the bar of the 'Choose a wireless network'? This indicates a preferred network.
Did you also try what JohnWill suggested from the Advanced Button? That should fix you up straight away.
The only network with the yellow star is my network. I dont see any tab saying "only connect to preferred networks".
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
14-Nov-2006, 10:31 PM #8
The option is to allow connections to non-preferred networks, you uncheck it if you only want to connect to networks in the preferred list.
ucHiha itacHi's Avatar
ucHiha itacHi ucHiha itacHi is offline
Computer Specs
Junior Member with 22 posts.
 
Join Date: Nov 2006
Location: Mississauga - Ontario, Canada
Experience: Enought to get me into trouble..
15-Nov-2006, 12:33 AM #9
I hope you guys don't mind if I butt in..

I would just like to say that this problem is a very common problem especially if the wireless computer is in a location with a lot of other wireless networks.

The way Windows XP behaves (the Wireless Zero Configuration service, in particular) is that it will always try to connect to the strongest 'open' network. Open meaning, no encryption. Since your network has encryption, that explains why your operating system rather chooses connecting to the other network which is of equal strength to yours.

Since you mentioned Preferred Networks, I will be assuming that you are using Windows XP' Zero Utility (WZCSVC) instead of some proprietary programs. This would explain why the computer keeps on hopping to other networks.

You see, the way it works is that every time the computer loses a connection (to your router/network), it will automatically connect to the next preferred network on the list. How to get around this? Remove all the other preferred networks, or better yet, delete all preferred networks. Simple as that. After you've done that, connect the laptop to your network so that Windows XP creates a 'profile' for your connection (a Preferred Network listing)

All in all, what this does is that it basically tells your computer to only connect to your network. Now, once you connect to another network, it will create a preferred network listing and that's something you will have to remove manually if you don't want the annoying network hopping brouhaha.

Hope it helps. Thanks
supermanno's Avatar
supermanno supermanno is offline
Computer Specs
Member with 148 posts.
THREAD STARTER
 
Join Date: Jan 2004
Location: Utah
Experience: Intermediate
15-Nov-2006, 01:41 AM #10
Dont mean to sound redundant and I really appreciate you guys help... but as I said the only network in the preferred list is my network. How do you explain the switching back and forth?
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
15-Nov-2006, 10:49 AM #11
Did you uncheck the option I mentioned?
TerryNet's Avatar
Computer Specs
Moderator with 66,131 posts.
 
Join Date: Mar 2005
Location: Ottawa, IL
15-Nov-2006, 03:50 PM #12
And if you still have the problem after John's "uncheck the option I mentioned," put WZC out to pasture and use the adapter's utility. I've read that sometimes no matter what you do WZC still insists on momentarily disconnecting to look for a "better" signal.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑