Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Networking Networking
Search Search
Search for:
Tech Support Guy > > >

Sony Vaio Wireless Problems


(!)

Roasties's Avatar
Roasties Roasties is offline
Junior Member with 4 posts.
THREAD STARTER
 
Join Date: Jan 2008
17-Jan-2008, 07:38 AM #1
Sony Vaio Wireless Problems
Now bearing in mind im not very tech minded here is my problem:

I have a Sony laptop with in-built WiFi, running on vista.

Now, when im at home it finds my network and connects straightforward.

Yet, when im at my girlfriends place, it finds the network no problem, full signal yet when i try to connect to it it doesnt want to know. When I click to diagnose the problem I just get a "wireless association failed due to an unknown reason" message.

I know the router at my girlfriends place is working fine because a computer upstairs connects to it and so does the Nintendo Wii.

So basically I know the WiFi in the laptop is working an I know the router is working, they just don't work together.

Any ideas?

Any help appreciated. Thanks, Robbie
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
17-Jan-2008, 09:40 AM #2
The top suspect is a mis-matched encryption key. Have you tried disabling encryption on the machine and connecting that way? You can re-enable encryption when you get it working.

Next suspect would be an incompatibility with Vista. You can do a couple of things about that. Upgrade the router's firmware to the latest available and then reset to factory defaults and reconfigure. If that doesn't do it, try the following fixes.


Changes that may help to increase the compatibility of Vista with older networking devices:



Disable the IP Helper service:

1. Hold the Windows key and type R, enter "services.msc" (without the quotes) and press Enter
2. Scroll down to the IP Helper service, right click on it and select Properties
3. In the dropdown box that says "Automatic" or "Manual", set it to Disabled and then click on "Apply"
4. Then click on "Stop" to stop the service from running in the current session
5. Click OK to exit the dialog



Disable IPv6:

1. Hold the Windows key and type R, enter "ncpa.cpl" (without the quotes) and press Enter
2. Right click on each network connection and select "Properties"
3. Remove the checkmark from the box next to "Internet Protocol Version 6 (TCP/IPv6)
4. Click OK to exit the dialog

NOTE: You should do this for each network connection.



Disable the DHCP Broadcast Flag:

Link: http://support.microsoft.com/default.aspx/kb/928233
  1. Hold the Windows key and type R, enter regedit and press Enter.
  2. Locate and then click the following registry subkey:
  3. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Inter faces\{GUID}
  4. In this registry path, click the (GUID) subkey to be updated.
  5. If the key DhcpConnForceBroadcastFlag does not exist, use the Edit menu, point to New, and then click DWORD (32-bit) Value. In the New Value #1 box, type DhcpConnForceBroadcastFlag, and then press ENTER. If the key exists, skip this step.
  6. Right-click DhcpConnForceBroadcastFlag, and then click Modify.
  7. In the Value data box, type 0, and then click OK.
  8. Close Registry Editor.
NOTE: You should do this for each and every GUID subkey.
NOTE2: (GUID) is a mnemonic for the individual subkeys, the actual text "GUID" does not appaer.




The only program I'm aware of that currently relies on IPv6 is the new Windows Meeting Space. The first 2 changes will cause that program not to work - but will leave all of your normal (IPv4) connections unaffected. If it causes problems that you can't overcome, simply revert back to the original settings.
__________________
Remember: Data you don't have at least two copies of is data you don't care about.
Roasties's Avatar
Roasties Roasties is offline
Junior Member with 4 posts.
THREAD STARTER
 
Join Date: Jan 2008
17-Jan-2008, 10:06 AM #3
Thanks for the reply.

I have tried with no encryption and no luck.

I have fixes and still no luck.

Could you tell me how to go about updating the routers firmware?

It a d-link DI-514.

Thanks
Roasties's Avatar
Roasties Roasties is offline
Junior Member with 4 posts.
THREAD STARTER
 
Join Date: Jan 2008
17-Jan-2008, 10:22 AM #4
Forget my last post, I just upgraded the firmware and still no joy.

Could it just be that the router is to old to be compatable with Vista?
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
17-Jan-2008, 10:24 AM #5
Here's the base support page for your router. http://support.dlink.com/products/re...oductId=DI-514

You need to select the version you have to get to the support page.

Here's the generic instructions for D-Link routers firmware upgrades: http://support.dlink.com/faq/view.as...%20/%20DI-624S
Roasties's Avatar
Roasties Roasties is offline
Junior Member with 4 posts.
THREAD STARTER
 
Join Date: Jan 2008
17-Jan-2008, 10:26 AM #6
Sorry John i must have replied while you were in the middle of writing.

I tried upgrading the firmware, the newest upgrade for my router was 2005!

So could it just be that the router is to old?

Thanks again
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
17-Jan-2008, 10:33 AM #7
Yep, I have one of those that I'm about to ship to my brother, who just got DSL. It's really that old.

OTOH, if the firmware is newer than what you have, can't hurt to give it a try. Remember to reset to factory defaults after upgrading the firmware and reconfiguring.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑