Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Networking Networking
Search Search
Search for:
Tech Support Guy > > >

Solved: Cannot Communicate With Primary DNS Server


(!)

adamblacky's Avatar
adamblacky adamblacky is offline
Junior Member with 12 posts.
THREAD STARTER
 
Join Date: Mar 2008
28-Mar-2008, 10:00 AM #1
Solved: Cannot Communicate With Primary DNS Server
I have just got a vista laptop from work and when i use it with the wireless at work the internet works fine, but when i try and access my wireless internet at home it connects to the router but cannot connect to the internet. The router is working correctly as other people are using it and it's working fine. When i try and diagnose problems it says:

Cannot communicate with primary DNS server (10.0.1.200)
(Network diagnostics pinged the remote host but did not receive a response)

Then there is an option to reset the network adaptor and when clicked it trys repairing it and then it says:

Windows tried a repair but a problem still exists. Cannot communicate with primary DNS server(10.0.1.200)

Again there is an option to reset the network adaptor. It just goes round in circles.
I have googled the problem but no-one seems to have the same problem.
Any help will be very much appreciated.
Thanks ver much, Adam.
Compaq__'s Avatar
Compaq__ Compaq__ is offline
Computer Specs
Member with 458 posts.
 
Join Date: Mar 2008
Location: noyb
Experience: Advanced
28-Mar-2008, 10:06 AM #2
go to a command prompt...type IPCONFIG /ALL and post the results here.

What is the IP address of your router.
cwwozniak's Avatar
cwwozniak   (Chuck) cwwozniak is offline cwwozniak is a Trusted Advisor with special permissions. cwwozniak has a Profile Picture
Computer Specs
Trusted Advisor with 45,255 posts.
 
Join Date: Nov 2005
Location: McHenry, IL - USA
Experience: Intermediate
28-Mar-2008, 10:20 AM #3
The 10.0.1.200 IP address is a private IP address of the Domain Name Server (DNS) on your work network. A private IP address can not be accessed directly from outside that network. A Domain Name Server is used to translate a URL like www.techguy.org into the public IP address [209.183.226.152] that your browser needs for the actual connection.

You may want to talk to your IT people at work about setting up your computer to operate on other networks besides the one at work.
__________________
Chuck W.
"When you understand why you dismiss all the other possible gods, you will understand why I dismiss yours." ~ Stephen F. Roberts
Compaq__'s Avatar
Compaq__ Compaq__ is offline
Computer Specs
Member with 458 posts.
 
Join Date: Mar 2008
Location: noyb
Experience: Advanced
28-Mar-2008, 10:23 AM #4
If your work could just set you up to use DHCP instead of having the info. hardcoded (which is probably how it is) you would have more luck.
adamblacky's Avatar
adamblacky adamblacky is offline
Junior Member with 12 posts.
THREAD STARTER
 
Join Date: Mar 2008
28-Mar-2008, 10:23 AM #5
Here it is :

Microsoft Windows [Version 6.0.6000]
Copyright (c) 2006 Microsoft Corporation. All rights reserved.

C:\Users\user>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : user-PC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : Belkin

Ethernet adapter Bluetooth Network Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
Physical Address. . . . . . . . . : 00-1E-37-99-90-25
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . : Belkin
Description . . . . . . . . . . . : Dell Wireless 1390 WLAN Mini-Card
Physical Address. . . . . . . . . : 00-1F-3A-49-B4-C7
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::2c4f:71cf:dbdd:cc1a%10(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.2.5(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : 28 March 2008 14:06:25
Lease Expires . . . . . . . . . . : 28 March 2009 14:06:24
Default Gateway . . . . . . . . . : 192.168.2.1
DHCP Server . . . . . . . . . . . : 192.168.2.1
DHCPv6 IAID . . . . . . . . . . . : 167780154
DNS Servers . . . . . . . . . . . : 10.0.1.200
NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Broadcom NetXtreme 57xx Gigabit Controll
r
Physical Address. . . . . . . . . : 00-1D-09-B9-59-D7
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 6:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 02-00-54-55-4E-01
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 7:

Connection-specific DNS Suffix . : Belkin
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::5efe:192.168.2.5%13(Preferred)
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : 10.0.1.200
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Local Area Connection* 9:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 11:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

C:\Users\user>ipconfig /all


I don't really know how to find my router's IP sorry.
Compaq__'s Avatar
Compaq__ Compaq__ is offline
Computer Specs
Member with 458 posts.
 
Join Date: Mar 2008
Location: noyb
Experience: Advanced
28-Mar-2008, 11:22 AM #6
Add a DNS server to the list. 192.168.2.1

See if that works.
Wanderer2's Avatar
Senior Member with 1,428 posts.
 
Join Date: Jan 2008
Experience: Advanced
28-Mar-2008, 11:29 AM #7
In other words your dns listing in your wireless router is wrong. Correct it and you should be fine.
adamblacky's Avatar
adamblacky adamblacky is offline
Junior Member with 12 posts.
THREAD STARTER
 
Join Date: Mar 2008
28-Mar-2008, 11:32 AM #8
how do i do that please?
Compaq__'s Avatar
Compaq__ Compaq__ is offline
Computer Specs
Member with 458 posts.
 
Join Date: Mar 2008
Location: noyb
Experience: Advanced
28-Mar-2008, 11:40 AM #9
Sorry....I should have explained to you.

I'm looking at Windows XP here so there might be a variation between that and Vista but the principle is the same.

Go into CONTROL PANEL. Click on NETWORK CONNECTIONS.

You should see a WIRELESS NETWORK CONNECTION in there. Right-Click on it and click PROPERTIES.
Find INTERNET PROTOCOL (TCP/IP) in the list
Click Properties
Click ADVANCED
Click the DNS tab
Click ADD
Type the IP Address 192.168.2.1
Click ok on everything and run that repair again just to make sure it takes the new info.
adamblacky's Avatar
adamblacky adamblacky is offline
Junior Member with 12 posts.
THREAD STARTER
 
Join Date: Mar 2008
28-Mar-2008, 11:48 AM #10
Works a treat. Thanks very much for your help!

Adam.
Compaq__'s Avatar
Compaq__ Compaq__ is offline
Computer Specs
Member with 458 posts.
 
Join Date: Mar 2008
Location: noyb
Experience: Advanced
28-Mar-2008, 01:28 PM #11
You are quite welcome. If ya get a chance, just go into your thread tools at the top here and mark the thread SOLVED.

Take care.
Wanderer2's Avatar
Senior Member with 1,428 posts.
 
Join Date: Jan 2008
Experience: Advanced
28-Mar-2008, 02:30 PM #12
Guess that is one way of addressing the issue but it doesn't correct it.

You are doing dhcp at home according to your ipconfig post. The router is giving you the wrong dns entry 10.0.1.200

You put 192.168.2.1 into IE and it will present you with your routers login page. Login and go to the lan settings. Change the dns setting here. Save the config and exit.

Now you have corrected the entry permanently.
Compaq__'s Avatar
Compaq__ Compaq__ is offline
Computer Specs
Member with 458 posts.
 
Join Date: Mar 2008
Location: noyb
Experience: Advanced
28-Mar-2008, 02:38 PM #13
That DNS entry is hardcoded most likely because that is the DNS server used for WORK.

The router isn't giving him that DNS entry...if it was then it wouldn't be working for others as he said it is.

Adam, what I said corrects the issue.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑