Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Networking Networking
Search Search
Search for:
Tech Support Guy > > >

Enabling FTP access on my PC


(!)

dinushah's Avatar
dinushah dinushah is offline
Junior Member with 8 posts.
THREAD STARTER
 
Join Date: Apr 2008
06-Apr-2008, 06:22 AM #1
Question Enabling FTP access on my PC
Hi,

I am trying to enable FTP access to my PC via the internet.
I have tried the steps given in different forums. Till date I have done the following:
  • I have downloaded a free ware called Serv-U as a FTP server. It is enabled and running.
  • I have a Dlink wireless router (DI 524) and have enabled the port forwarding on the router as follows:
--- Virtual FTP server - Port 21 - TCP and have given the private IP of my PC as 192.168.0.161 as the IP on which the FTP requested should be forwarded by the router.
  • I have opened the FTP 21 on my laptop to accept FTP requests.
  • I am trying to ping my laptop from another one with the IP address of my laptop i.e. 192.168.0.161 but the request times out.
  • My laptop gets a dynamic IP address from the Dlink router which is 192.168.0.161. Do I need a static IP address to complete the procedure?

What are the additional steps that I need to complete to enable FTP access on my PC?

Responses awaited...

Thanks in advance
zx10guy's Avatar
zx10guy has a Photo Album
Computer Specs
Trusted Advisor with 4,036 posts.
 
Join Date: Mar 2008
06-Apr-2008, 08:33 AM #2
If you can't even ping your laptop internally, then you have a firewall issue on the laptop. Either turn off the software firewall on your laptop or set up rules which allow ICMP and FTP.

Off topic. You shouldn't use FTP if you are using an unsecured internet connection to gain access. A better alternative is SCP.
dinushah's Avatar
dinushah dinushah is offline
Junior Member with 8 posts.
THREAD STARTER
 
Join Date: Apr 2008
06-Apr-2008, 09:40 AM #3
Thanks for the response... I have the windows firewall on but have enabled the FTP server ports through that... whats next.. is there any other firewall I should be disabling?
dinushah's Avatar
dinushah dinushah is offline
Junior Member with 8 posts.
THREAD STARTER
 
Join Date: Apr 2008
06-Apr-2008, 09:55 AM #4
also..u spotted right.. i am not able to reach my laptop internally.. when I try to ftp my ip from the cmd prompt.. it times out and dont get any response..plz help
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
06-Apr-2008, 11:24 AM #5
Are you sure the Windows firewall is the only firewall running? Try totally disabling the Windows firewall to see if that helps.
zx10guy's Avatar
zx10guy has a Photo Album
Computer Specs
Trusted Advisor with 4,036 posts.
 
Join Date: Mar 2008
06-Apr-2008, 11:32 AM #6
Turn off all software firewalls. Verify at least the FTP server is running properly and serving up connections internally. Once this is established, then work on getting your security rules set up.
dinushah's Avatar
dinushah dinushah is offline
Junior Member with 8 posts.
THREAD STARTER
 
Join Date: Apr 2008
06-Apr-2008, 02:00 PM #7
I have turned off the windows firewall completely... I am sure that the only firewall running...

wat could be the other problem?
zx10guy's Avatar
zx10guy has a Photo Album
Computer Specs
Trusted Advisor with 4,036 posts.
 
Join Date: Mar 2008
06-Apr-2008, 02:04 PM #8
Do a netstat -an from a command prompt. Look to see if your PC has port 21 up and is listening.
dinushah's Avatar
dinushah dinushah is offline
Junior Member with 8 posts.
THREAD STARTER
 
Join Date: Apr 2008
06-Apr-2008, 02:50 PM #9
attached is the snapshot of netstat.. i m not sure how can i find whether port 21 is listening... plz guide me as I am very new to networking...

i have also attached the router port forwarding config...

plz tell me which IP I should use to ftp the server... would it be something like 192.168.*.* or the actual IP (i get a diff one when I check my ip with www.checkmyip.com)

thanks for all the help
Attached Thumbnails
Enabling FTP access on my PC-router.jpg  
Attached Files
File Type: txt netstat.txt (5.9 KB, 543 views)
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
06-Apr-2008, 04:17 PM #10
That's not NETSTAT -an.


Hold the Windows key and press R, then type CMD to open a command prompt:

In the command prompt window that opens, type type the following command:

NETSTAT -an

Right click in the command window and choose Select All, then hit Enter.
Paste the results in a message here.

If you are on a machine with no network connection, use a floppy, USB disk, or a CD-RW disk to transfer a text file with the information to allow pasting it here.
__________________
Remember: Data you don't have at least two copies of is data you don't care about.
dinushah's Avatar
dinushah dinushah is offline
Junior Member with 8 posts.
THREAD STARTER
 
Join Date: Apr 2008
07-Apr-2008, 03:00 AM #11
here's the result again...i had done the same thing earlier and result attached
Attached Files
File Type: txt netstat.txt (3.2 KB, 157 views)
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
07-Apr-2008, 09:05 AM #12
Sorry, I saw the big graphic and didn't notice the attached file.
zx10guy's Avatar
zx10guy has a Photo Album
Computer Specs
Trusted Advisor with 4,036 posts.
 
Join Date: Mar 2008
07-Apr-2008, 10:25 AM #13
The first line in the file shows you indeed have the FTP port up and listening. How are you trying to connect up to the laptop again? Are you using a command line client or a FTP app?

You might want to try establishing a local connection to see if it's a configuration problem on the FTP server. I also recall some issue I ran into a while back with establishing FTP sessions as to whether it was an active or passive type connection.
dinushah's Avatar
dinushah dinushah is offline
Junior Member with 8 posts.
THREAD STARTER
 
Join Date: Apr 2008
07-Apr-2008, 11:18 AM #14
I am trying to connect to my PC via the following command on the cmd prompt...

ftp *.*.*.* (replaced with the exact ip address of my PC which I get from www.checkmyip.com in the form of something like 86.3.*.*)

The response I get is Connected but it doesnt prompt for username and pwd...

the same thing i tried from the IE by typing ftp://86.3.*.* but I get the error msg as Page cannot be displayed...

Also, the FTP connection is in passive mode as I have a wireless router at home...
I also tried changing it to Active but with no luck...

any inputs...
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
07-Apr-2008, 08:39 PM #15
Did you port forward port 21 in the router to the local address of the machine running the FTP server? You'll never get a connection until that's correct.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑