Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Networking Networking
Search Search
Search for:
Tech Support Guy > > >

Solved: Solved: Vista unable to connect to Belkin Router


(!)

adam.jaffrey's Avatar
adam.jaffrey adam.jaffrey is offline
Junior Member with 8 posts.
THREAD STARTER
 
Join Date: Apr 2008
Experience: Intermediate
27-Apr-2008, 04:06 AM #1
Solved: Solved: Vista unable to connect to Belkin Router
Can anyone please help me?

I have just got a new computer and have attempted to wire it to the Belkin Router in our house. My PC is running Windows Vista Ultimate and the router we have is a Belkin ADSL2+ modem with Wireless G Plus MIMO Router - model # F5D9630-4. The router does have wireless capacity, however I am attempting to run it hard wired to my computer. When I connect the cable Vista automatically searches and finds the network, however it comes up as an "Unidentified network" and I cannot connect to the internet. My brother's computer is also connected to the same router (He is running Vista Home Premium) but his works fine. I have tried everything I can think of, including changing the DHCP settings in my registry as seen here: http://support.microsoft.com/kb/928233, but I have still had no success.

Any suggestions would be greatly appreciated!
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
27-Apr-2008, 09:07 AM #2
TCP/IP stack repair options for use with Windows Vista.

Start, Programs\Accessories and right click on Command Prompt, select "Run as Administrator" to open a command prompt.

In the command prompt window that opens, type type the following commands:

Reset WINSOCK entries to installation defaults: netsh winsock reset catalog

Reset IPv4 TCP/IP stack to installation defaults. netsh int ipv4 reset reset.log

Reset IPv6 TCP/IP stack to installation defaults. netsh int ipv6 reset reset.log

Reboot the machine.



Let's see this after the reboot with the cable connected to the router.

Hold the Windows key and press R, then type CMD to open a command prompt:

In the command prompt window that opens, type type the following command:

IPCONFIG /ALL

Right click in the command window and choose Select All, then hit Enter.
Paste the results in a message here.

If you are on a machine with no network connection, use a floppy, USB disk, or a CD-RW disk to transfer a text file with the information to allow pasting it here.
__________________
Remember: Data you don't have at least two copies of is data you don't care about.
adam.jaffrey's Avatar
adam.jaffrey adam.jaffrey is offline
Junior Member with 8 posts.
THREAD STARTER
 
Join Date: Apr 2008
Experience: Intermediate
27-Apr-2008, 08:07 PM #3
OK I did that and this is what I got:



Microsoft Windows [Version 6.0.6000]
Copyright (c) 2006 Microsoft Corporation. All rights reserved.

C:\Users\Adam>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : Adams-PC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8168B/8111B Family PCI-E Gigab
it Ethernet NIC (NDIS 6.0)
Physical Address. . . . . . . . . : 00-1D-7D-D1-1C-D3
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::79c9:f0ac:7561:5c7f%8(Preferred)
Autoconfiguration IPv4 Address. . : 169.254.92.127(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 134225277
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter Local Area Connection* 6:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : isatap.{63FB951A-3F8A-4705-BED0-21999EDE0
71D}
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::5efe:169.254.92.127%10(Preferred)
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Local Area Connection* 7:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 02-00-54-55-4E-01
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

C:\Users\Adam>




Also, I was having a play around last night trying to fix this nightmare of a problem I have got and I tried setting my computer with a static IP address but had no luck as it still comes up as a public "Unidentified network". However I did manage to set up my internet as a dial up connection. It seems to work, however it is running extremely slow, but I don't know if I hit something here?

Anyway, any thoughts?
TerryNet's Avatar
Computer Specs
Moderator with 66,457 posts.
 
Join Date: Mar 2005
Location: Ottawa, IL
27-Apr-2008, 09:30 PM #4
Are you sure about the quality of the cable? Gigabit ethernet uses all 8 wires.
adam.jaffrey's Avatar
adam.jaffrey adam.jaffrey is offline
Junior Member with 8 posts.
THREAD STARTER
 
Join Date: Apr 2008
Experience: Intermediate
28-Apr-2008, 02:36 AM #5
On the cable it says: Ritmo TYPE 24AWG/4PRS UTP VERIFIED CM CAT.6E PATCH CABLE TO TIA/EIA 568A CSA TYPE CMG FT4. But I don't think this is the problem as I have already tried different cables with no result (including the cable my brother's computer is normally plugged into). I have also tried using a static IP address. To me, it seems the router is not assigning the correct IPv4 address to my computer. In the network and sharing center it identifies the "Unidentified network" as a public network - it should be private which is what the other computer in the house comes up as.

Very frustrating for me!
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
28-Apr-2008, 08:17 AM #6
Here are a couple of changes. You say you already tried the broadcast flag, try the rest.



Changes that may help to increase the compatibility of Vista with older networking devices:



Disable the IP Helper service:

1. Hold the Windows key and type R, enter "services.msc" (without the quotes) and press Enter
2. Scroll down to the IP Helper service, right click on it and select Properties
3. In the dropdown box that says "Automatic" or "Manual", set it to Disabled and then click on "Apply"
4. Then click on "Stop" to stop the service from running in the current session
5. Click OK to exit the dialog



Disable IPv6:

1. Hold the Windows key and type R, enter "ncpa.cpl" (without the quotes) and press Enter
2. Right click on each network connection and select "Properties"
3. Remove the checkmark from the box next to "Internet Protocol Version 6 (TCP/IPv6)
4. Click OK to exit the dialog

NOTE: You should do this for each network connection.



Disable the DHCP Broadcast Flag:

Link: http://support.microsoft.com/default.aspx/kb/928233
  1. Hold the Windows key and type R, enter regedit and press Enter.
  2. Locate and then click the following registry subkey:
  3. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Inter faces\{GUID}
  4. In this registry path, click the (GUID) subkey to be updated.
  5. If the key DhcpConnForceBroadcastFlag does not exist, use the Edit menu, point to New, and then click DWORD (32-bit) Value. In the New Value #1 box, type DhcpConnForceBroadcastFlag, and then press ENTER. If the key exists, skip this step.
  6. Right-click DhcpConnForceBroadcastFlag, and then click Modify.
  7. In the Value data box, type 0, and then click OK.
  8. Close Registry Editor.
NOTE: You should do this for each and every GUID subkey.
NOTE2: (GUID) is a mnemonic for the individual subkeys, the actual text "GUID" does not appaer.




The only program I'm aware of that currently relies on IPv6 is the new Windows Meeting Space. The first 2 changes will cause that program not to work - but will leave all of your normal (IPv4) connections unaffected. If it causes problems that you can't overcome, simply revert back to the original settings.
TerryNet's Avatar
Computer Specs
Moderator with 66,457 posts.
 
Join Date: Mar 2005
Location: Ottawa, IL
28-Apr-2008, 08:20 AM #7
Possible causes, some of which you've already checked out, include
Router's Dhcp server disabled,
bad port on the router,
bad cable,
bad NIC or motherboard,
incorrect or corrupted ethernet driver,
3rd party firewall (internet security) blocking even Dhcp.
adam.jaffrey's Avatar
adam.jaffrey adam.jaffrey is offline
Junior Member with 8 posts.
THREAD STARTER
 
Join Date: Apr 2008
Experience: Intermediate
30-Apr-2008, 10:19 AM #8
Problem solved?
After exploring nearly every option available to me I have established that:
The router port is ok as I checked other ports.
The cable I'm using is fine as I've used my brother's computer with my cable which works.
The motherboard, ethernet port and my drivers are fine as a friend of mine tried my PC on his router and it worked fine.
I have no 3rd party firewalls installed, and I've even tried disabling windows defender.
There is obviously some issue with my computer's connectivity with my router.

HOWEVER...
I have fixed the problem!
After some more testing and playing around with my PC and also my router, I tried disabling my router's DHCP server and setting a static IP address for both my PC and my brother's PC. It worked. Interesting how it worked this time setting a static IP address as I had already tried this with no success - so the overall solution was disbling the DHCP server on my router.
So my internet, and network is working!
So what does this mean for my router? Is the DHCP server broken? And do I need a new router?
TerryNet's Avatar
Computer Specs
Moderator with 66,457 posts.
 
Join Date: Mar 2005
Location: Ottawa, IL
30-Apr-2008, 10:29 AM #9
There are some known issues between Vista and some routers. The known fixes are carefully described in JohnWill's post #6. If these fixes do not work for you then there probably is just some strange incompatibility between your specific router and specific NIC.

You can enable the Dhcp server on the router and allow everybody else to connect with dynamic addresses. Just make sure that the IP you assign is outside the Dhcp server's address range. For example, if router has LAN address 192.168.2.1 and the Dhcp assigns 192.168.2.2 through 192.168.2.100, you can manually assign any address 192.168.2.101 through 192.168.2.254.
adam.jaffrey's Avatar
adam.jaffrey adam.jaffrey is offline
Junior Member with 8 posts.
THREAD STARTER
 
Join Date: Apr 2008
Experience: Intermediate
30-Apr-2008, 08:27 PM #10
Yes, well I tried all of the fixes suggested to me and none of those worked to fix the problem - so either there is some strange incompatibility, or is there a possibility that my router is not working correctly.
And yes I turned the DHCP server back on and assigned my static IP outside it's range and was able to connect to it!
Thanks for you help guys, much appreciated.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑