Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Networking Networking
Search Search
Search for:
Tech Support Guy > > >

[Linksys router] Cannot communicate with primary DNS server


(!)

Michio's Avatar
Michio Michio is offline
Junior Member with 4 posts.
THREAD STARTER
 
Join Date: Feb 2009
28-Feb-2009, 01:03 PM #1
[Linksys router] Cannot communicate with primary DNS server
Just got a Linksys router, after a couple of hours of messing around with it, still not working. My OS is Vista x64 Premium.

I'm trying to connect wirelessly (although it wouldn't work using the LAN ports either).

Windows IP Configuration

Host Name . . . . . . . . . . . . : Computer
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Atheros AR5007EG Wireless Network Adapter

Physical Address. . . . . . . . . : 00-23-4D-06-22-23
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::6497:f4e1:4d2a:def3%11(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.1.100(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Saturday, February 28, 2009 10:41:54 AM
Lease Expires . . . . . . . . . . : Sunday, March 01, 2009 10:45:07 AM
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.254
NetBIOS over Tcpip. . . . . . . . : Enabled
lawson_jl's Avatar
Computer Specs
Senior Member with 1,056 posts.
 
Join Date: Aug 2008
Location: Illoinois, USA
Experience: Einstein
28-Feb-2009, 03:40 PM #2
Hit the reset button on the back fo the router and follow the set up instruction that came with the router or run the set up disc if it came with one.
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
28-Feb-2009, 04:47 PM #3
Since you obviously appear to be connected to the router in that IPCONFIG, perhaps you could share the exact make/model of the modem you use.


Reset the router to factory defaults by holding the reset button down for 15 seconds with power on. The following procedure should get you a connection with any broadband modem that is configured to use DHCP for the router connection, such as cable modems, and many DSL modems. If you require PPPoE configuration for the DSL modem, that will have to be configured to match the ISP requirements.
  • Turn off everything, the modem, router, computer.
  • Connect the modem to the router's WAN/Internet port.
  • Connect the computer to one of the router's LAN/Network ports.
  • Turn on the modem, wait for a steady connect light.
  • Turn on the router, wait for two minutes.
  • Boot the computer.

When the computer is completely booted, let's see this.

Hold the Windows key and press R, then type CMD (COMMAND for W98/WME) to open a command prompt:

In the command prompt window that opens, type type the following commands one at a time, followed by the Enter key:

IPCONFIG /ALL

PING <computer_IP_address>

PING <default_gateway_address>

PING <dns_servers>

PING 206.190.60.37

PING yahoo.com


Right click in the command window and choose Select All, then hit Enter to copy the contents to the clipboard.
Paste the results in a message here.

<computer_IP_address> - The IP Address of your computer, obtained from the IPCONFIG command above.

<default_gateway_address> - The IP address of the Default Gateway, obtained from the IPCONFIG command above.

<dns_servers> - The IP address of the first (or only) address for DNS Servers, obtained from the IPCONFIG command above.


If you are on a machine with no network connection, use a floppy, USB disk, or a CD-RW disk to transfer a text file with the information to allow pasting it here.
__________________
Remember: Data you don't have at least two copies of is data you don't care about.
Michio's Avatar
Michio Michio is offline
Junior Member with 4 posts.
THREAD STARTER
 
Join Date: Feb 2009
28-Feb-2009, 05:34 PM #4
My router model is WRT54GS.

Windows IP Configuration
Host Name . . . . . . . . . . . . : computer
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
Ethernet adapter Local Area Connection:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Broadcom 440x 10/100 Integrated Cont
roller
Physical Address. . . . . . . . . : 00-14-22-9C-54-F8
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.1.101
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.254
Lease Obtained. . . . . . . . . . : Saturday, February 28, 2009 3:14:36
PM
Lease Expires . . . . . . . . . . : Sunday, March 01, 2009 3:14:36 PM
Ethernet adapter Wireless Network Connection:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel(R) PRO/Wireless 2200BG Network
Connection
Physical Address. . . . . . . . . : 00-16-6F-4B-3F-B5
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.1.121
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.254
Lease Obtained. . . . . . . . . . : Saturday, February 28, 2009 3:14:31
PM
Lease Expires . . . . . . . . . . : Sunday, March 01, 2009 3:14:31 PM

C:\Documents and Settings\User>ping <computer_ip_address>
The syntax of the command is incorrect.

C:\Documents and Settings\User>ping 192.168.1.121
Pinging 192.168.1.121 with 32 bytes of data:
Reply from 192.168.1.121: bytes=32 time<1ms TTL=128
Reply from 192.168.1.121: bytes=32 time<1ms TTL=128
Reply from 192.168.1.121: bytes=32 time<1ms TTL=128
Reply from 192.168.1.121: bytes=32 time<1ms TTL=128
Ping statistics for 192.168.1.121:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms

C:\Documents and Settings\User>ping 192.168.1.1
Pinging 192.168.1.1 with 32 bytes of data:
Reply from 192.168.1.1: bytes=32 time=1ms TTL=64
Reply from 192.168.1.1: bytes=32 time<1ms TTL=64
Reply from 192.168.1.1: bytes=32 time<1ms TTL=64
Reply from 192.168.1.1: bytes=32 time<1ms TTL=64
Ping statistics for 192.168.1.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 1ms, Average = 0ms

C:\Documents and Settings\User>ping 192.168.1.254
Pinging 192.168.1.254 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Ping statistics for 192.168.1.254:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

C:\Documents and Settings\User>ping 206.190.60.37
Pinging 206.190.60.37 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Ping statistics for 206.190.60.37:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

C:\Documents and Settings\User>ping yahoo.com
Ping request could not find host yahoo.com. Please check the name and try again.
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
28-Feb-2009, 06:45 PM #5
Modem model, not router.


However, I see one odd thing there. You have a Default Gateway of 192.168.1.1, but a DNS Server Address of 192.168.1.254. This would seem to suggest you have either overridden the DNS server, or you're trying to connect to another router with a base address of 192.168.1.254.

That's why I want the make/model of the "modem" in use here.
Michio's Avatar
Michio Michio is offline
Junior Member with 4 posts.
THREAD STARTER
 
Join Date: Feb 2009
28-Feb-2009, 06:52 PM #6
Oh, my modem is a Motorola DSL Modem 2210.
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
28-Feb-2009, 09:27 PM #7
Change the base address of your router to 192.168.2.1 and see if it doesn't connect properly to that Motorola modem.
TerryNet's Avatar
Computer Specs
Moderator with 63,986 posts.
 
Join Date: Mar 2005
Location: Ottawa, IL
28-Feb-2009, 09:32 PM #8
As John suspected the LAN address of your Motorola modem/router is 192.168.1.254.

You either need to change the LAN used by the Linksys (e.g., to 192.168.3.x) or configure the Motorola into "bypass" mode (assuming it has that mode) or else connect them as follows.

JohnWill's procedure (Aug. 30, 2008) for configuring a secondary router as a switch and, optionally, wireless access point follows.

Connecting two (or more) SOHO broadband routers together.

Note: The "primary" router can be an actual router, a software gateway like Microsoft Internet Connection Sharing, or a server connection that has the capability to supply more than one IP address using DHCP server capability. No changes are made to the primary "router" configuration.

Configure the IP address of the secondary router(s) to be in the same subnet as the primary router, but out of the range of the DHCP server in the primary router. For instance DHCP server addresses 192.168.0.2 through 192.168.0.100, I'd assign the secondary router 192.168.0.254 as it's IP address, 192.168.0.253 for another router, etc.

Note: Do this first, as you will have to reboot the computer to connect to the router again for the remaining changes.

Disable the DHCP server in the secondary router.

Setup the wireless section just the way you would if it was the primary router, channels, encryption, etc.

Connect from the primary router's LAN port to one of the LAN ports on the secondary router. If there is no uplink port and neither of the routers have auto-sensing ports, use a cross-over cable. [You will not need a cross-over cable if one of the "routers" is a computer.] Leave the WAN port unconnected!

This procedure bypasses the routing function (NAT layer) and configures the router as a switch (or wireless access point for wireless routers).

For reference, here's a link to a Typical example config using a Netgear router
Michio's Avatar
Michio Michio is offline
Junior Member with 4 posts.
THREAD STARTER
 
Join Date: Feb 2009
28-Feb-2009, 10:17 PM #9
!!!

Thanks guys, it's working.
TerryNet's Avatar
Computer Specs
Moderator with 63,986 posts.
 
Join Date: Mar 2005
Location: Ottawa, IL
28-Feb-2009, 10:26 PM #10
Good! You can mark this "Solved" using the button at the upper left of your first post.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑