Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Networking Networking
Search Search
Search for:
Tech Support Guy > > >

Solved: wireless printer goes offline and stops working


(!)

JTCWCommsGuy's Avatar
JTCWCommsGuy JTCWCommsGuy is offline
Computer Specs
Junior Member with 5 posts.
THREAD STARTER
 
Join Date: Feb 2010
Experience: Advanced
15-Feb-2010, 03:49 PM #1
Unhappy Solved: wireless printer goes offline and stops working
There was a similar problem reported on this forum, but no definitive answer. I have a new Brother MFC-7840W printer, an HP laptop with Vista 64-bit and a Linksys WRT160N. I also have a desktop HP with Vista 32-bit. The desktop is connected to one port on the router. The router connects to a linksys cable modem to cox. The laptop and the printer are downstairs from the desktop/router. Both computers work just fine on the internet. I bought the wireless printer and connected it to the wireless network and installed the software on the laptop. Printing initially works fine. Later (and I'm not sure how long 'later' is) attempts to print just pile up in the print queue. The printer now shows "offline" and no amount of fooling around will get it printing again. I can delete the printer and re-install on the laptop and printing will work again for a while (again, I can't define "a while"); then stops with printer again with backlog of items to print and showing 'offline'. I called Brother Tech Support and they ran me through some steps and declared the problem to be with the linksys router. Their "evidence" was the fact that I can ping desktop to laptop and laptop to desktop, but not from either desktop or laptop to the printer. ping command reports "destination unreachable".

I've tried disabling the power saving options on the laptop but that doesn't change anything.

I even tried giving the printer a static IP address.

Any suggestions appreciated.
memphiszen's Avatar
memphiszen memphiszen is offline
Computer Specs
Member with 62 posts.
 
Join Date: Aug 2007
Experience: Intermediate
15-Feb-2010, 04:12 PM #2
Sounds like their "evidence" points to exactly the opposite IMO. What all is included with "fooling around?" When the printer stops printing, have you tried power-cycling the printer? I have seen the NICs/print servers in printers go into sleep mode, even though the printer itself isn't. Is the printer physically connected to the laptop? Also, I'd have a look at what services are running when the printer is working/not working.
JTCWCommsGuy's Avatar
JTCWCommsGuy JTCWCommsGuy is offline
Computer Specs
Junior Member with 5 posts.
THREAD STARTER
 
Join Date: Feb 2010
Experience: Advanced
15-Feb-2010, 04:25 PM #3
Well, I am not able to sit at the laptop all the time to see when it stops working. But here is what I (and the Brother tech non-support guy) tried:
1) Powered off printer and back on.
2) Setting the "Port" to "raw.
3) checking single strength at the printer and at the laptop (both "Strong")
4) Purging the print queue and trying to print again.

I asked whether re-installing would help. Answer: no. After he declared "not our problem", I did that anyway. Deleted printer and re-ran the installation software. Success for a few hours. Got up to watch some of the Olympics and went back to the computer few hours later. No longer can print.

The linksys "status" page shows the printer on 192.168.1.103 and that agrees with the printer's printout of its network settings. I set the printer's IP to be static so it wouldn't be released by the DHCP of the router and get re-assigned. Then...

I reinstalled again. Fixed. This time I waited for the printer to go to sleep - it says "Sleeping" on the LED. Tried printing - works. When to bed. Tried this morning - no printing. Conclusion: static IP isn't the reason and the problem IS NOT because the printer is "sleeping".

Still need HELP!

Last edited by JTCWCommsGuy; 15-Feb-2010 at 04:44 PM..
titantiger's Avatar
titantiger titantiger is offline
Junior Member with 2 posts.
 
Join Date: Feb 2010
Experience: Intermediate
16-Feb-2010, 05:32 PM #4
I'm having the same problem
And it's not just wireless. It does the same thing even if you plug the printer into your router with an ethernet cable. I have an iMac that is connected to the router via ethernet and a Windows/Linux dual boot laptop connecting wirelessly. The printer will work fine for a while and then inexplicably go offline and none of them can print to it. Also, I even tried setting up the printer in ad hoc mode thinking maybe my router was the problem. No difference. I've finally got it working by plugging it into the iMac via USB and having the laptop print through the iMac. But it's certainly not getting the functionality I paid for.
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
16-Feb-2010, 07:54 PM #5
I have zero faith in wireless printers, I have an HP that has wired/wireless capability. The wireless was always flaky, and since I really didn't need to use it wireless, it's wired. It's worked flawlessly for a year wired to the network.
JTCWCommsGuy's Avatar
JTCWCommsGuy JTCWCommsGuy is offline
Computer Specs
Junior Member with 5 posts.
THREAD STARTER
 
Join Date: Feb 2010
Experience: Advanced
22-Feb-2010, 11:05 AM #6
After a weekend of fooling around and trying a bunch of different things, I have concluded that the problem is NOT the router, NOT the printer, but Vista. A friend came over with his laptop which is Windows 7 and connected to my network in about 2-seconds, found my supposedly "offline" printer and printed a doc. My laptop continued to insist the printer was off line.

We went and watched a few hours of hockey (Olympics) and came back. He was still able to print and Vista claimed offline - even while the Win 7 laptop was sending docs and the printer was pooping out pages.

I'm upgrading to Windows 7 ASAP.

Call this problem solved.
titantiger's Avatar
titantiger titantiger is offline
Junior Member with 2 posts.
 
Join Date: Feb 2010
Experience: Intermediate
22-Feb-2010, 11:21 AM #7
It's not solved for me. Still won't stay online in Linux Mint 7, Windows XP or Mac OS 10.4.11.
JohnWill's Avatar
Computer Specs
Retired Moderator with 106,412 posts.
 
Join Date: Oct 2002
Location: South Eastern PA, USA
22-Feb-2010, 08:37 PM #8
titantiger, please start your own thread if you want to discuss your issue.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑