Tech Support Guy

Tech Support Guy (http://forums.techguy.org/)
-   Windows XP (http://forums.techguy.org/21-windows-xp/)
-   -   "cannot find the file specified" "during the installation of the device." (http://forums.techguy.org/windows-xp/235959-cannot-find-file-specified-during.html)

DaveBurnett 05-Jun-2004 07:44 AM

"cannot find the file specified" "during the installation of the device." SOLUTION
 
I have had this problem numerous times in the past where the installation proceeds then ends with the messages:

During the installation of the device.
The system cannot find the file specified
and it goes into a detection loop

HERE is the solution:

Windows 2000/XP has a bug that it cannot properly detect new hardware by *.inf files, if the RunOnce registry key is missing for the following location:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion

This key is often used by installers to execute post-reboot programs, but sometimes they accidentally delete this key.

IMPORTANT: This article contains information about modifying the registry. Make sure that you understand how to backup and restore the registry, in case a problem occurs. Please read the linked Microsoft Knowledge Base article prior to editing the registry.


Go to Start Run and enter "regedit."

Go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion

With CurrentVersion Highlighted, go to the Edit menu and select New Key

Name the key RunOnce, leaving everything else about the key alone.

The RunOnce key should now exist underneath the CurrentVersion key.
Once the key exists, Windows 2000/XP stops redetecting the Hardware

DaveBurnett 06-Jun-2004 02:52 AM

bump

2KThunder 24-Oct-2005 05:51 PM

TTT This thread was a lifesaver googled in and it fixed a day long probelm and finally got my GPS installed properly. Thanks!!

DaveBurnett 24-Oct-2005 05:55 PM

I spent 3 weeks looking for It. That's why I put this here.
In my case it was PC Forrester's Starter program that deleted the key.

rodeognome 24-Oct-2005 06:00 PM

I've come across that problem before...so you tip has been noted.

Thank you for solution yesterday - for Belkin slim NIC card - it worked a charm.

Vistar 18-Dec-2005 03:42 PM

RunOnce erased - shows "cannot find the file specified" error
 
Thanks so much. Used the fix to finally install TrendNet TEW-421PC that deleted RunOnce. Now the card works, but system is running extremely slowly.

apankrat 15-Jan-2006 03:20 PM

Just wanted to chime in too and say "THANKS !". I am with http://hamachi.cc and the "Not found" problem is an infrequent but major headache. At some point we spent two weeks of daily back-n-forth email with someone trying to get to the bottom of it. Looked at setupapi.log at its most verbose level, tries all things imaginable. All failed.

This was few months ago and since then we were basically telling people that they probably had run some tool that corrupted their registry and we couldn't say in which exact way.

Thanks again.

jayIT 23-Feb-2006 04:30 PM

This is one of the best tips I've seen. Solved a multi day problem with a device driver for a special instrument PCI card that could not be reinstalled. The first time it installed correctly. When I removed all the supporting software (because of another problem) it erased the RunOnce key. Imagine my surprise when I could not get the driver to detect when I wanted to reinstall!!@@!@#!!@!@!!! What a pain!!!

A+ for the tip and fix!

Device DT300 works great now!

Grey Bat 29-Mar-2006 04:50 PM

Another satisfied customer! I have had this problem repeatedly on several machines over the last year or two. Never could figure out why! I implemented this tip, and the problem is solved.

Oh yes... Guess what - I have Startman installed on all my machines!!!

Thanks again for the tip!

sturoberts 06-Apr-2006 11:34 AM

Thank you VERY much
 
This solution worked exactly as described. Is there any possibility of submitting this to Micro$oft to see if they could work up a KB article on this? - If I hadn't Google'd this, I would still be searching.

Thanks so much for posting this solution!

dragon0042 23-May-2006 12:13 AM

Thanks
 
I spent 3 days trying to figure this out. This is the best windows tip I have ever recived from the web :D :up: :up:

Geotech 27-Aug-2006 08:03 AM

Add my thanks too
 
I was having problems trying to add a USB driver for a Thales ProMark 3 GPS receiver. Looked through the vendor's documentation, FAQs, service bulletins, Google, tried two different computers, reinstallations, etc. all to no effect. Found this tip, tried it, and worked perfectly. Thanks.

ozrom1e 27-Aug-2006 08:16 AM

I put this at the top of my list, great thanks I know it will save a lot of installations. Best find in 28 plus years.

MSUStevo 17-Dec-2006 06:34 PM

Another installation saved!
 
Wow Dave!

Thanks so much for posting this tidbit. If it weren't for this forum post I don't think I'd ever figured this out on my own.

In my case I just bought a Brother PT-1650 label maker which has the option to download templates via USB from Brother's editing software. This feature one of the key reasons I went with this product.

After seeing the dreaded and inexplicable - The system cannot find the file specified - error message numerous times, looking through the .inf file to see if any files missing on the installation CD, downloading the driver from the Brother website, etc. I about at the end of my rope. It occurred to me to do a web search and I quickly found your post.

10 minutes later my new label maker downloading templates with no problems. Thanks again!! I've shared this tip with our IT guy at work in case he ever comes across this head scratcher during an install.

Steve

DaveBurnett 18-Dec-2006 02:28 PM

I am little surprised that Microsoft have not plugged the hole with there updates.
I wonder how many people have a similar problem but do not know how to find the solution,


All times are GMT -5. The time now is 06:07 PM.


Copyright © 1996 - 2014 TechGuy, Inc. All rights reserved.


Content Relevant URLs by vBSEO 3.3.2