Tech Support Guy

Tech Support Guy (http://forums.techguy.org/)
-   Networking (http://forums.techguy.org/53-networking/)
-   -   Solved: Wireless takes a long time to connect (http://forums.techguy.org/networking/923376-wireless-takes-long-time-connect.html)

Proximity 16-May-2010 12:20 PM

Solved: Wireless takes a long time to connect
 
When I start up my desktop I find that my wireless network takes a few minutes to connect to the router. I have a laptop beside me that connects instantly on start up. I'm not really sure what could be causing the problem.

I'm not really sure what kind of information is needed to diagnose the problem, so If I am missing anything, just say so.

OS: Windows 7 Professional, 32 - bit
Wireless Card: D-Link Xtreme N Desktop Adapter (DWA-552)

Drivers are up to date as far as I can tell.

pedroguy 16-May-2010 12:55 PM

Was this always a problem?
Make sure that you have only one wireless manager running.Default windows or the dlink manager,but not both.
Make sure you have the most current driver for your wireless adapter.
Delete all wireless profiles,then select and log onto your home network.
Like so:
http://mgmcc.forumotion.net/networki...ofile-t109.htm

Proximity 16-May-2010 12:57 PM

Yes, this has always been a problem as far as I can remember. What do you mean by only having one wireless manager running?

pedroguy 16-May-2010 02:21 PM

This is for XP/Vista,but hopefully ,7 will be similar.

You would be looking for wlan/or wzc AND some d-link wireless manager manager associated with the wireless card running simultaneously.
Check your Services are Started on all PCs:
• COM+ Event System (for WZC issues)
• Computer Browser
• DHCP Client
• DNS Client
• Network Connections
• Network Location Awareness
• Remote Procedure Call (RPC)
• Server
• TCP/IP Netbios helper
• Wireless Zero Configuration (XP wireless configurations)
• WLAN AutoConfig (Vista wireless configurations) This would be the Vista default wireless manager,for example.
• Workstation

Note: You can check the services in Control Panel, Administrative Tools, Services.

All of these services should be started, and their startup type should be automatic (or perhaps manual).

If a service is not running, open it's properties and check the dependencies. Check each of the dependencies and see which one is preventing the service from running. Checking the event log is also a good idea here, there may be clues to what is failing.
__________________

Proximity 16-May-2010 03:07 PM

Alright, I deleted all the profiles and I made sure all the services were running. The service 'Computer Browser' wasn't running, so I started it. I just restarted my computer and it the wireless connected right away, so it looks like one of those fixed it.

Thanks for your help! :)

pedroguy 16-May-2010 03:08 PM

My pleasure
You can mark your thread solved using the solved button top left.
Happy networking..


All times are GMT -4. The time now is 05:31 PM.


Copyright © 1996 - 2014 TechGuy, Inc. All rights reserved.