Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Software Development Software Development
Search Search
Search for:
Tech Support Guy > > >

MakeFile Help


(!)

Drawmack's Avatar
Drawmack Drawmack is offline
Junior Member with 8 posts.
THREAD STARTER
 
Join Date: Jul 2005
Experience: Bachelors w/ Field Experience
28-Jul-2005, 09:27 PM #1
MakeFile Help
nmake is giving me an error I cannot correct. The error is:
LINK : fatal error LNK1117: syntax error in option "opt:ref,icf"
NMAKE : fatal error U1077: 'link' : return code '0x16'

and then it stops. I cannot get this to make. I have tried all of the following (to no avail):
-opt:ref.icf
-opt:ref:icf
and just deleting this

None of these has corrected the problem. The first two resulted in the same error (but with the minor change you would expect). The third resulted in telling me my disk was full (which it is not any where near).

If anyone can help it would be greatly appreciated.
AGCurry's Avatar
AGCurry AGCurry is offline
Senior Member with 431 posts.
 
Join Date: Jun 2005
Location: Kansas City area
Experience: advanced but learning
29-Jul-2005, 10:06 AM #2
Quote:
Originally Posted by Drawmack
nmake is giving me an error I cannot correct. The error is:
LINK : fatal error LNK1117: syntax error in option "opt:ref,icf"
NMAKE : fatal error U1077: 'link' : return code '0x16'

and then it stops. I cannot get this to make. I have tried all of the following (to no avail):
-opt:ref.icf
-opt:ref:icf
and just deleting this

None of these has corrected the problem. The first two resulted in the same error (but with the minor change you would expect). The third resulted in telling me my disk was full (which it is not any where near).

If anyone can help it would be greatly appreciated.
It's tough without being able to see the whole thing.

Is your purpose to indicate that "opt" depends on "ref" and "icf"? If so, the syntax would be:

opt: ref icf

hope this helps.
Drawmack's Avatar
Drawmack Drawmack is offline
Junior Member with 8 posts.
THREAD STARTER
 
Join Date: Jul 2005
Experience: Bachelors w/ Field Experience
29-Jul-2005, 10:32 AM #3
I am guessing that your suggestiong fixed the problem I was having because now I get another error. My new error is:
Quote:
link -out:blib\arch\auto\DBI\DBI.dll -dll -nologo -nodefaultlib -debug -
\lib\CORE\perl58.lib oldnames.lib kernel32.lib user32.lib gdi32.lib winspool.lib
.lib uuid.lib ws2_32.lib mpr.lib winmm.lib version.lib odbc32.lib odbccp32.lib
LINK : warning LNK4044: unrecognized option "libpath:C:\Perl\lib\CORE"; ignored
LINK : fatal error LNK1181: cannot open input file "icf.obj"
NMAKE : fatal error U1077: 'link' : return code '0x4a'
Stop.
I am attaching the makefile and the MakeFile.pl script (which generates the makefile) to this post in a zip file for completeness.

Thank you for you help.
Attached Files
File Type: zip Makefile.zip (12.9 KB, 15 views)
AGCurry's Avatar
AGCurry AGCurry is offline
Senior Member with 431 posts.
 
Join Date: Jun 2005
Location: Kansas City area
Experience: advanced but learning
29-Jul-2005, 10:49 AM #4
Drawmack, that is one heck of a make file.

From the error messages, looking at the make file, I'd say your problems are here:

LDDLFLAGS = -dll -nologo -nodefaultlib -debug -opt:ref icf -libpath:"C:\Perl\lib\CORE" -machine:x86



LDFLAGS = -nologo -nodefaultlib -debug -opt:ref icf -libpath:"C:\Perl\lib\CORE" -machine:x86

The "-opt:ref icf" doesn't look kosher. In your first post, I was thinking that you were MAKEing "opt". Now I see you're not.

Obviously, the linker simply does not like the -libpath and -opt options, or the syntax is incorrect for those options. You need to consult the documentation for your linker.
Drawmack's Avatar
Drawmack Drawmack is offline
Junior Member with 8 posts.
THREAD STARTER
 
Join Date: Jul 2005
Experience: Bachelors w/ Field Experience
29-Jul-2005, 10:59 AM #5
Thank you very much, I'll dig around and see what I can find in the docs.
Drawmack's Avatar
Drawmack Drawmack is offline
Junior Member with 8 posts.
THREAD STARTER
 
Join Date: Jul 2005
Experience: Bachelors w/ Field Experience
31-Jul-2005, 02:48 PM #6
I went into the make file and did a global search and replace with ,icf to '' then namke made and installed the file with no problem.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑