Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Web Design & Development Web Design & Development
Search Search
Search for:
Tech Support Guy > > >

Running .asp scripts using IIS


(!)

JiminSA's Avatar
JiminSA   (Jim) JiminSA is online now JiminSA has a Profile Picture
Computer Specs
Member with 1,552 posts.
THREAD STARTER
 
Join Date: Dec 2011
Location: Johannesburg South Africa
Experience: Intermediate
29-Aug-2012, 08:54 AM #1
Running .asp scripts using IIS
Is anyone familiar with how to run .asp programs/scripts from my hard drive? I was informed at this link that I should create a folder inside C:\Inetpub\wwwroot and save my asp files I wish to run, there.
Well I did this and then tried (as per the link) to run it in my browser as which gives me a 404 Error...
This hasn't surprised me, because I am running xampp and use the localhost url to run xampp htdocs and I think that maybe there is a conflict of interest between xampp and IIS.
But frankly I am at a loss

Last edited by JiminSA; 29-Aug-2012 at 09:00 AM..
WendyM's Avatar
Trusted Advisor with 3,993 posts.
 
Join Date: Jun 2003
Location: Northern California
29-Aug-2012, 10:29 AM #2
You have to enable active server pages in IIS. You don't say what version of IIS you're using, but here are the instructions for IIS 6. Hope that helps.
JiminSA's Avatar
JiminSA   (Jim) JiminSA is online now JiminSA has a Profile Picture
Computer Specs
Member with 1,552 posts.
THREAD STARTER
 
Join Date: Dec 2011
Location: Johannesburg South Africa
Experience: Intermediate
29-Aug-2012, 12:55 PM #3
Thanks for your input WendyM. I am using IIS 7 - Ah, I found out here that I have to install classic asp via Control Panel/Programs/Windows Features/Internet Information Services/Www services/Application Development Features/ASP, which I did, but I'm still not able to run asp locally...
WendyM's Avatar
Trusted Advisor with 3,993 posts.
 
Join Date: Jun 2003
Location: Northern California
29-Aug-2012, 01:19 PM #4
Are xampp and IIS using the same port?
JiminSA's Avatar
JiminSA   (Jim) JiminSA is online now JiminSA has a Profile Picture
Computer Specs
Member with 1,552 posts.
THREAD STARTER
 
Join Date: Dec 2011
Location: Johannesburg South Africa
Experience: Intermediate
29-Aug-2012, 01:27 PM #5
How would I determine that? (this is a new area for me...)
JiminSA's Avatar
JiminSA   (Jim) JiminSA is online now JiminSA has a Profile Picture
Computer Specs
Member with 1,552 posts.
THREAD STARTER
 
Join Date: Dec 2011
Location: Johannesburg South Africa
Experience: Intermediate
29-Aug-2012, 01:54 PM #6
The directory paths are completely different of course...
c://xampp/htdocs/------------------------>xampp
c://inetpub/wwwroot/--------------------->asp
but ports in this context is new to me...
WendyM's Avatar
Trusted Advisor with 3,993 posts.
 
Join Date: Jun 2003
Location: Northern California
29-Aug-2012, 02:13 PM #7
For xampp, if it's running, stop the service and then open [XAMPP Installation Folder]/apache/conf/httpd.conf. Search for "Listen" and the port name should come afterward (likely either 80 or 8080).

In IIS, right-click your site and select Edit Bindings. It should show you the port you're using (again, likely 80).
JiminSA's Avatar
JiminSA   (Jim) JiminSA is online now JiminSA has a Profile Picture
Computer Specs
Member with 1,552 posts.
THREAD STARTER
 
Join Date: Dec 2011
Location: Johannesburg South Africa
Experience: Intermediate
30-Aug-2012, 02:36 AM #8
I followed the procedure for xampp and yes the port is 80...
With IIS things don't seem that straightforward... I got hold of this forum link which shows how to find the port using this command - int port = Request.Url.Port;
how and where would I use this command to discover the port (which I read, defaults to 80, anyway)?

Thank you for your patience with my ignorance...

Last edited by JiminSA; 30-Aug-2012 at 03:03 AM..
JiminSA's Avatar
JiminSA   (Jim) JiminSA is online now JiminSA has a Profile Picture
Computer Specs
Member with 1,552 posts.
THREAD STARTER
 
Join Date: Dec 2011
Location: Johannesburg South Africa
Experience: Intermediate
30-Aug-2012, 03:58 AM #9
Aha! I managed to find the IIS manager via the control panel, administrative tools and discovered that the port is 80. When I attempt to start the site it comes back with an error msg (attached)...
So I went in and changed the binding - port = 8080 - It then started ok, but when I attempted to run it in my browser I still get the 404 - I am using this URL... http://localhost/ClassAds/default.asp
So I changed it to http://localhost:8080/ClassAds/default.asp and now I get through to the IIS 7.5 - which is progress at least! But the page tells me
Quote:
HTTP Error 404.0 - Not Found
The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.
So I went to the web.config file and changed Default.asp to default.asp and now I get
Quote:
HTTP Error 401.3 - Unauthorized
You do not have permission to view this directory or page because of the access control list (ACL) configuration or encryption settings for this resource on the Web server.
Now where do I change directory permissions??
Attached Thumbnails
Running .asp scripts using IIS-iis-error.png  

Last edited by JiminSA; 30-Aug-2012 at 04:51 AM..
JiminSA's Avatar
JiminSA   (Jim) JiminSA is online now JiminSA has a Profile Picture
Computer Specs
Member with 1,552 posts.
THREAD STARTER
 
Join Date: Dec 2011
Location: Johannesburg South Africa
Experience: Intermediate
31-Aug-2012, 04:20 AM #10
This is truly frustrating
I have granted full permissions to my user account using IIS Manager and still get the 401.3 error. I have enquired at the relevant microsoft forum and they sent me this link which I have read and followed, setting everything to full permission, but still I am denied access.
I will go over this page again just to make absolutely sure
WendyM's Avatar
Trusted Advisor with 3,993 posts.
 
Join Date: Jun 2003
Location: Northern California
04-Sep-2012, 02:51 PM #11
Did you enable the Anonymous Authentication and apply it to the application pool?
JiminSA's Avatar
JiminSA   (Jim) JiminSA is online now JiminSA has a Profile Picture
Computer Specs
Member with 1,552 posts.
THREAD STARTER
 
Join Date: Dec 2011
Location: Johannesburg South Africa
Experience: Intermediate
05-Sep-2012, 02:19 AM #12
No I gave permissions to User "Jim" - my sign on, but I shall try anonymous and report back...
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑