Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Web Design & Development Web Design & Development
Search Search
Search for:
Tech Support Guy > > >

IIS 7.5 Win 7 Can't find localhost...


(!)

alpeabody's Avatar
alpeabody alpeabody is offline
Member with 37 posts.
THREAD STARTER
 
Join Date: Jan 2004
15-Feb-2010, 06:46 PM #1
Question IIS 7.5 Win 7 Can't find localhost...
Dear Friends,

I am trying to set up MySQL, PHP and IIS 7.5 in Win 7 Home Premium for some data-based Web development. I installed IIS 7.5, and at the end of the moderately long sequence of detailed directions (with very good illustrations) I was instructed to point my browser to http://localhost/ to see the IIS Splash screen. Well, I saw IIS 7 OK, but what it said was:

Server Error

Internet Information Services 7.5
Error Summary
HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid.
Detailed Error Information
Module IIS Web Core
Notification Unknown
Handler Not yet determined
Error Code 0x80070005
Config Error Cannot read configuration file due to insufficient permissions
Config File \\?\C:\Users\Al\Desktop\GalleryServer\web.config
Requested URL http://localhost:80/
Physical Path
Logon Method Not yet determined
Logon User Not yet determined
Config Source

-1:
0:

I logged on as Administrator (I am in the Administrator group, but I figured why not be Admin his own self) and got the same result.

I have every indication that IIS 7.5 is indeed installed and running (I could uninstall it if I wanted to, etc.). And I get onto the Internet just fine. But localhost is apparently toast.

Any Clues?

Thanks,

Al
exchangekeys's Avatar
exchangekeys exchangekeys is offline
Junior Member with 9 posts.
 
Join Date: Feb 2010
Experience: Beginner
16-Feb-2010, 02:09 PM #2
What happens if you put your web.config file in the C:\inetpub\wwwroot\ folder instead? It sounds like either the web.config doesn't have the read permission, or it wasn't even created... What instructions did you follow, by the way?
Fyzbo's Avatar
Senior Member with 1,683 posts.
 
Join Date: Feb 2002
Location: North Carolina, USA
Experience: Programming-Advanced|EVER
16-Feb-2010, 03:42 PM #3
Your default website instance is pointing to someone's desktop "C:\Users\Al\Desktop\GalleryServer\". You will need to go in to IIS and change the folder it points to to the standard C:\inetpub\wwwroot\, or change the permissions of the folder on the desktop. There are a bunch of profiles that need access including iusr, iwam, and anonymous as well as the asp.net worker process.

Since you want to do PHP development it would make more sense to reconfigure your default website in IIS. You won't need a web.config file for PHP.
alpeabody's Avatar
alpeabody alpeabody is offline
Member with 37 posts.
THREAD STARTER
 
Join Date: Jan 2004
16-Feb-2010, 10:34 PM #4
Reconfigure IIS
"it would make more sense to reconfigure your default website in IIS"

OK, I started the IIS Manager. Now what? I clicked somewhere on Sites, and it says on one line Default Web Site. Then it says ID 1; Status Started (http), Unknown(net.tcp),Unknown(net.pipe),Unknown(ned.msmq), Unknown(msmq.formatname), Binding *.80(http),808.*(net.tcp),*(net.pipe),localhost(net.msmq),localhost(msmq.fo rmatname), Path %SystemDrive%\inetpub\wwwroot

That looks pretty good, like the Default Webg Site is ID 1, started, port 80, pointing to C:\inetpub\wwwroot
Next is says gallery, ID 4, Started(http), localhost on *.80(http), path C:\Users\Al\Desktop\GalleryServer
That directory exists, and contains a file named web.config. it is 15Kbytes in size, and contains a lot of stuff. I will quote the top few lines:

<?xml version="1.0"?>
<configuration>
<configSections>
<sectionGroup name="system.web">
<section name="galleryServerPro" type="GalleryServerPro.Configuration.GalleryServerProConfigSettings, GalleryServerPro.Configuration" allowDefinition="MachineToApplication" restartOnExternalChanges="true" requirePermission="false" />
</sectionGroup>
<section name="cachingConfiguration" type="Microsoft.Practices.EnterpriseLibrary.Caching.Configuration.CacheMana gerSettings, Microsoft.Practices.EnterpriseLibrary.Caching" requirePermission="false" />
<sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
<sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
<section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
<sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">
<section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="Everywhere" />
<section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
<section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
<section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication" />
</sectionGroup>
</sectionGroup>
</sectionGroup>
</configSections>
<connectionStrings>
<clear />
<add name="SqlServerDbConnection" connectionString="Server=.\SQLEXPRESS;Database=GalleryServerPro;uid=Admin;P wd=Joatmon1;Application Name=Gallery Server Pro" />
</connectionStrings>
<appSettings>

I have to tell you, we're way over my head here. Is there any place I can find simple, step by step instructions, like click on this then select that option and then type in"....

I've been working with PCs since 1978, Z80-CP/M 8" floppies, and although I recognize virtually every word in the quoted text above, I haven't a clue if this is where or how I would "reconfigure my default web site..." (to what? Where? How?)

Thanks for your patience and any help you can offer.

Al
Fyzbo's Avatar
Senior Member with 1,683 posts.
 
Join Date: Feb 2002
Location: North Carolina, USA
Experience: Programming-Advanced|EVER
17-Feb-2010, 09:45 AM #5
Someone installed gallery server pro. It was added to your IIS list of websites, but the files were installed on the desktop without proper permissions. Since you have two websites running, both of which are *.80(http), it is defaulting to Gallery Pro. You can stop or remove that website and it should switch back to your default. If you need to have both running it needs a way to determine which to show (often by alias/domain name).
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


Tags
can't get to localhost, iis 7, win 7 home premium

(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑