Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Web Design & Development Web Design & Development
Search Search
Search for:
Tech Support Guy > > >

Solved: PhpMyAdmin:#2002 - The server is not responding (or the local MySQL server's


(!)

Bagslash's Avatar
Bagslash Bagslash is offline
Computer Specs
Junior Member with 2 posts.
THREAD STARTER
 
Join Date: May 2011
Experience: Beginner
02-May-2011, 12:21 PM
Solved: PhpMyAdmin:#2002 - The server is not responding (or the local MySQL server's
Good afternoon,

I was hoping somebody could help me out, I installed Wamp on my pc a while ago and was using it with Joomla and all was going well. I had to start afresh with it all (for various clean up reasons) and uninstalled Wamp. I then reinstalled it and got the error message:

#2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)

when trying to connect to PhpMyAdmin. I tried several times with no luck. I have since tried Xampp to see if MySql would respond differently, but it flags the same error.
I have Googled the issue extensively and there are some resolutions which involve changing various files, but I'll be completely honest and say I haven't got a clue where to find these files (sorry). I have checked the task manager and mysqld.exe is running so that's definitely not an issue, it also listed as ACTIVATED in the Xampp manager.
Please respond to me as if I'm a child as I am so bogged down with it all now!

Thank you so much in advance!

Carla
ehymel's Avatar
ehymel   (Ernie) ehymel is offline
Member with 695 posts.
 
Join Date: Aug 2007
Location: Texas
02-May-2011, 01:38 PM
Definitely sounds like a mysqld problem. Some ideas:

- Are you trying to use a password when there isn't one, or are you using the correct username and password if one is configured?

- Do you have a firewall installed, and if so is it set up to allow connections to mysql?

- Have you tried stopping and re-starting the mysqld service?

- Have you checked your log files for errors?
Bagslash's Avatar
Bagslash Bagslash is offline
Computer Specs
Junior Member with 2 posts.
THREAD STARTER
 
Join Date: May 2011
Experience: Beginner
02-May-2011, 02:05 PM
Thank you so much for replying! After 11 hours of head scratching I think I have just this second cracked it! I went into the my.ini file and changed the setting for mysql socket = "MySQL" to "/tmp/mysql.sock" and then did the same in the php ini file and it suddenly appeared!! I'm chuffed to bits!

Thank you again for taking the time to read my post.

Carla
Corvin666's Avatar
Corvin666 Corvin666 is offline
Computer Specs
Junior Member with 1 posts.
 
Join Date: Jun 2011
Experience: IT professional
08-Jun-2011, 07:22 PM
Quote:
Originally Posted by Bagslash View Post
Thank you so much for replying! After 11 hours of head scratching I think I have just this second cracked it! I went into the my.ini file and changed the setting for mysql socket = "MySQL" to "/tmp/mysql.sock" and then did the same in the php ini file and it suddenly appeared!! I'm chuffed to bits!

Thank you again for taking the time to read my post.

Carla
Thanks a lot for the idea.

The same trick fixed MySQL for Windows7 - I set mysql.default_socket = "c:/tmp/mysql.sock"
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!


Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑