Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Web & Email Web & Email
Search Search
Search for:
Tech Support Guy > > >

Solved: Can't See Embedded Images in Thunderbird


(!)

olabola's Avatar
olabola olabola is offline
Computer Specs
Member with 466 posts.
THREAD STARTER
 
Join Date: May 2012
Location: NY
Experience: Beginner
28-Jul-2012, 06:07 PM #91
Don't give up on me now....we are so close
throoper's Avatar
Computer Specs
Trusted Advisor with 5,020 posts.
 
Join Date: Jan 2007
Experience: Intermediate
28-Jul-2012, 06:15 PM #92
Quote:
Originally Posted by olabola View Post
Don't give up on me now....we are so close
Don't worry, I'm not giving up. I just need to do some digging to see what else might work.
It's going to drive me crazy until I figure out how and why this is happening.
throoper's Avatar
Computer Specs
Trusted Advisor with 5,020 posts.
 
Join Date: Jan 2007
Experience: Intermediate
28-Jul-2012, 06:20 PM #93
Just had a thought. Put in that button I sent and see if it will override the block.
If it does, it doesn't solve the underlying problem but at least it would save you doing the config to load images every time.
olabola's Avatar
olabola olabola is offline
Computer Specs
Member with 466 posts.
THREAD STARTER
 
Join Date: May 2012
Location: NY
Experience: Beginner
28-Jul-2012, 06:40 PM #94
Phewww, Im glad you are not giving up on me, I was worried there for a sec.

OK, I customized the toolbar and added the remote content button, but it doesnt change anything in the looks of any of the emails
throoper's Avatar
Computer Specs
Trusted Advisor with 5,020 posts.
 
Join Date: Jan 2007
Experience: Intermediate
29-Jul-2012, 12:10 AM #95
Still haven't found the how or why the pref keeps changing but I may have a sneaky way around it.
We are going to try creating a user.js file that hopefully will override the prefs.js.

Open the New Profile folder.
Right click an empty spot and on the menu click New>Text Document.
Name the text file user.js and ok the warning about changing the extension.
You should now have a JScript Script File named user.js.
Open it with a text editor (wordpad still my choice) and put this line in the file.

user_pref("permissions.default.image", 0);

Save the change and close the file.
Open TB to the New Profile and see if the config is set to 0 for that line and if the images now show.
olabola's Avatar
olabola olabola is offline
Computer Specs
Member with 466 posts.
THREAD STARTER
 
Join Date: May 2012
Location: NY
Experience: Beginner
29-Jul-2012, 12:14 PM #96
I tried the above, but I think I may have done something wrong because the JS file did not look the same as the original. I included a screenshot of the folder to show you what I mean.
Attached Thumbnails
Solved: Can't See Embedded Images in Thunderbird-userjsfile.jpg  
throoper's Avatar
Computer Specs
Trusted Advisor with 5,020 posts.
 
Join Date: Jan 2007
Experience: Intermediate
29-Jul-2012, 12:41 PM #97
You didn't do it wrong. I'm an idiot because I assume because I show full extensions, everybody else does to.

At the top of the folder, click Tools>Folder Options.
In the Folder Options window, click the View tab.
Scroll down and UNCHECK "Hide extensions for known file types" and click OK.
The name of the user.js should now read user.js.txt.
Just right click it, click Rename and remove the .txt so the full name is simply user.js and OK the dire warning about changing the file type.
It should now change to a Script file and you should be good to go.

Go back into the Folder Options and place a check by "Hide extensions..." and OK.
That saves you from always having to type the full name with extension when you name or rename files.
olabola's Avatar
olabola olabola is offline
Computer Specs
Member with 466 posts.
THREAD STARTER
 
Join Date: May 2012
Location: NY
Experience: Beginner
30-Jul-2012, 05:35 AM #98
I tried to re-do the user file and all seemed to be going well until I checked to see in the config editor if the change took effect...well it didn't and it went back to a 2, and the images did not load. So, I went back to the user file to see if I typed something wrong, and it wouldnt let me open it, I received this error message, I attached it in a screen shot
Attached Thumbnails
Solved: Can't See Embedded Images in Thunderbird-error-message.jpg  
throoper's Avatar
Computer Specs
Trusted Advisor with 5,020 posts.
 
Join Date: Jan 2007
Experience: Intermediate
30-Jul-2012, 08:28 AM #99
The error is because you're trying to run it (double clicked it) instead of right click>Open with>Wordpad to edit it.
olabola's Avatar
olabola olabola is offline
Computer Specs
Member with 466 posts.
THREAD STARTER
 
Join Date: May 2012
Location: NY
Experience: Beginner
30-Jul-2012, 10:10 PM #100
I opened the user file the correct way and the 0 is still in there, but not in the config editore, and of course, the images are not showing up either.
throoper's Avatar
Computer Specs
Trusted Advisor with 5,020 posts.
 
Join Date: Jan 2007
Experience: Intermediate
31-Jul-2012, 07:25 AM #101
Are you sure you have TB opened to the New Profile (Default User 2)?
Changing it to 0 in the config will still load the images while TB is open?
throoper's Avatar
Computer Specs
Trusted Advisor with 5,020 posts.
 
Join Date: Jan 2007
Experience: Intermediate
31-Jul-2012, 08:53 AM #102
Go into the user.js and change the 0 to 1. Save the change and start TB in the New (Default user 2) Profile.
olabola's Avatar
olabola olabola is offline
Computer Specs
Member with 466 posts.
THREAD STARTER
 
Join Date: May 2012
Location: NY
Experience: Beginner
01-Aug-2012, 07:14 AM #103
Quote:
Originally Posted by throoper View Post
Are you sure you have TB opened to the New Profile (Default User 2)?
Changing it to 0 in the config will still load the images while TB is open?
If I change it while its still open the images still load in the new profile, Default User 2, but as soon as I close TB, and open it back up, the config editor changes back to 2
olabola's Avatar
olabola olabola is offline
Computer Specs
Member with 466 posts.
THREAD STARTER
 
Join Date: May 2012
Location: NY
Experience: Beginner
01-Aug-2012, 07:17 AM #104
Quote:
Originally Posted by throoper View Post
Go into the user.js and change the 0 to 1. Save the change and start TB in the New (Default user 2) Profile.
OK, I did this, and although the change stayed as a 1, it made not noted effect to the config editor (because its still a 2) and the images still didnt load
throoper's Avatar
Computer Specs
Trusted Advisor with 5,020 posts.
 
Join Date: Jan 2007
Experience: Intermediate
01-Aug-2012, 07:29 AM #105
Something is wrong here. The user.js takes priority over prefs.js and that's the setting that should load at start.
Let's try putting in a setting that we know doesn't change from what you set in config.

Look in the config and make sure this setting: mailnews.message_display.disable_remote_image is false.
Close TB.
Open the user.js file and put in this line:
user_pref("mailnews.message_display.disable_remote_image", true);

Open TB and see if the line in the config is now set at true instead of false.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑