Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Windows 7 Windows 7
Search Search
Search for:
Tech Support Guy > > >

Can't open "Devices and Printers"


(!)

referee07's Avatar
Member with 1,114 posts.
THREAD STARTER
 
Join Date: Sep 2003
16-Dec-2011, 08:17 PM #1
Can't open "Devices and Printers"
Whenever I try to open "Devices and Printers," the green bar at the top of the next window begins moving from left to right slowly and never completes the trip to the end of the bar and the Devices and Printer window never opens. I have to open "Devices and Printers several times over several days with the same result. Thanks in advance for any and all suggestions regarding this problem.
Deejay100six's Avatar
Deejay100six   (Dave) Deejay100six is offline Deejay100six has a Profile Picture
Computer Specs
Member with 496 posts.
 
Join Date: Sep 2011
Location: Doncaster, England
Experience: Intermediate
17-Dec-2011, 10:15 AM #2
Hi,

First thing I would do is check in device manager to see if any drivers need updating.

Press the Windows + R keys and in the run box type or copy/paste devmgmt.msc

Click ok or press enter.

On the device manager page, look for any yellow question marks or warning symbols.

Also might be worth doing this;

Press the Windows + R keys and in the run box type or copy/paste sfc /scannow (note the space between sfc and /scannow)

Click ok or press enter.

This command will immediately initiate the Windows File Protection service to scan all protected files and verify their integrity, replacing any files with which it finds a problem.

You may be prompted to insert your Windows CD/DVD, please do so.

Let me know if this helps.

Last edited by Deejay100six; 17-Dec-2011 at 10:27 AM..
referee07's Avatar
Member with 1,114 posts.
THREAD STARTER
 
Join Date: Sep 2003
17-Dec-2011, 07:39 PM #3
Deejay100six, thanks for the reply. I ran devmgmt.msc and opened all the different icons fully, and there were no yellow question marks or warning symbols beside any of them. I also ran sfc /scannow, but it appeared that nothing happened. After I hit "okay" a black dialog box flashed on the screen and nothing else happened. Did Windows open the Windows File Protection service and check the files in the background? I just went to the Start Menu and clicked on "Devices and Printers," and, as before, the green progression bar when all the the away across very slowly and nothing appeared as far as devices for printers. I am wondering if this has something to do with the Bluetooth program? When I click on the Bluetooth icon in the tray at the bottom of the screen, and click on "show Bluetooth devices," the same thing happens, i.e., the green progression bar slowly goes across the screen and nothing appears. Also, I am having a problem HotSyncing my iPod via Bluetooth. Anyway, thanks again for your help with this and if you have any more suggestions please let me know. (By the way, I do not have a Windows CD. Windows came installed on my Dell Inspiron laptop computer.)
Deejay100six's Avatar
Deejay100six   (Dave) Deejay100six is offline Deejay100six has a Profile Picture
Computer Specs
Member with 496 posts.
 
Join Date: Sep 2011
Location: Doncaster, England
Experience: Intermediate
17-Dec-2011, 09:16 PM #4
Hi,

Try the steps in this post; http://forums.techguy.org/7796023-post7.html
referee07's Avatar
Member with 1,114 posts.
THREAD STARTER
 
Join Date: Sep 2003
17-Dec-2011, 09:46 PM #5
Deejay100six, thanks again for the response and help. I went to the above link and follow the instructions but had some unexpected results. When I entered "%WINDIR%\system32\spool\printers" there were no files in the print spooler or screen, and so I wasn't able to delete anything. Also, I'm wondering if the instructions are for a Windows system earlier than Windows 7? In the instructions, there is an instruction that says, "Administrative Tools" and "Print Management." I did not find either of these and my computer is running Windows 7. After completing the instructions I try to open "Devices and Printers," and the same thing happened, i.e., the green progression bar slowly went across the screen and when it stopped nothing else happened. Thanks again for the help with this and if you have any more suggestions I would appreciate them.
Deejay100six's Avatar
Deejay100six   (Dave) Deejay100six is offline Deejay100six has a Profile Picture
Computer Specs
Member with 496 posts.
 
Join Date: Sep 2011
Location: Doncaster, England
Experience: Intermediate
17-Dec-2011, 10:02 PM #6
That thread was in the Windows 7 forum so I assumed it would relate to your problem but the thread was never resolved so it was't a guaranteed fix.

I'll have another look for a solution to your problem and get back to you later.
referee07's Avatar
Member with 1,114 posts.
THREAD STARTER
 
Join Date: Sep 2003
18-Dec-2011, 02:04 AM #7
Deejay100six, thanks again for the response. I am wondering why there was nothing when I entered "%WINDIR%\system32\spool\printers?" I should also let you know that my printer prints as advertised with no problems.
Deejay100six's Avatar
Deejay100six   (Dave) Deejay100six is offline Deejay100six has a Profile Picture
Computer Specs
Member with 496 posts.
 
Join Date: Sep 2011
Location: Doncaster, England
Experience: Intermediate
18-Dec-2011, 02:08 PM #8
Hi,

Seems like lots of people have this issue but theres no single solution.

Try this.

Press the Windows + R keys and in the run box type or copy/paste services.msc and click ok or press enter.

In the services window, find Bluetooth Service and Bluetooth Support Service.

Right click and set them both to automatic.

Let me know if this helps.

Are you running Windows 7 Home Edition?
referee07's Avatar
Member with 1,114 posts.
THREAD STARTER
 
Join Date: Sep 2003
18-Dec-2011, 08:53 PM #9
Deejay100six, thanks again for the response. I checked and the " Bluetooth Support Service" was disabled and I set it to "automatic." I then tried to open "Devices and Printers," but got the same result, i.e., the green progression bar slowly went across the screen and after it reached the end nothing appeared regarding printers or devices. Thanks again for the help with this, and any further suggestions will be greatly appreciated.
referee07's Avatar
Member with 1,114 posts.
THREAD STARTER
 
Join Date: Sep 2003
24-Dec-2011, 08:27 AM #10
I still can't open "Devices and Printers." Thanks for all of he suggestions so far but would appreciate any other suggestions on how to fix this issue.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑