Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Windows 7 Windows 7
Search Search
Search for:
Tech Support Guy > > >

Solved: Get Windows to Read Copied desktop.ini File


(!)

:z:'s Avatar
:z: :z: is offline
Computer Specs
Member with 96 posts.
THREAD STARTER
 
Join Date: Feb 2008
Experience: Intermediate
17-Mar-2012, 05:52 PM #1
Solved: Get Windows to Read Copied desktop.ini File
I have been trying to find a way for Windows Vista and 7 to use the Folder.jpg file in a folder as an album artwork icon (in lieu of a folder icon with skewed and obscured artwork), and since Windows no longer natively supports this feature, the best workaround I've been able to find is to replace the folder icon manually. This creates a desktop.ini file with an absolute path to the Folder.ico file I also have in each album folder. I then changed the desktop.ini to reference a relative path, like this:

[.ShellClassInfo]
IconResource=Folder.ico,0


Here's where my questions arise:

1. When I copy that desktop.ini to another folder with a Folder.ico file, Windows doesn't read it, even after restarting the computer. I've searched the web on this and have found thread after thread where people have the same issue, but no one seems to be able to resolve it without manually changing the icon, either through the Explorer interface or using the command prompt. Is there a way I can get Windows to read the manually-copied desktop.ini of every sub-folder in my music directory?

2. On a related note, when I copy my customized folders with the relative-path desktop.ini from my Windows Vista computer to my Windows 7 computer, the artwork doesn't show up there, even for the folders I got to look right in Windows Vista. Am I going to have to manually re-associate the desktop.ini every time I upgrade computers or reinstall the OS?


The album artwork looks so good, but I don't want to go through hundreds of folders and manually associate the folder to read the desktop.ini file. That would take so long, and just the few I've done manually so far have killed my wrist.
Tuntematon's Avatar
Tuntematon Tuntematon is offline
Member with 2 posts.
 
Join Date: Apr 2012
Experience: Intermediate
22-Apr-2012, 10:54 PM #2
I recently had a similar issue, and was able to find a solution.

First, you need to set the Read-Only attribute to the folders whose icons you want to customize. Windows only read Desktop.ini files in folders that are set to Read-Only. Unfortunately, the Read-Only checkbox on the Windows folder options window only applies to the files inside the folder, not the folder itself, so you have to do it with the command line. Open the command prompt (Run > cmd) and navigate to your Music folder:

Code:
cd C:\Documents\Music
Then run this command:

Code:
attrib /s /d +r
It may report some errors about hidden files; ignore them.

Next, open C:\Documents\Music in Windows Explorer, select everything, right-click to bring up the context menu, click Properties, uncheck Read-Only, and press Okay. It will ask if you want to apply the properties to all files and subfolders; press Okay again. This will remove the Read-Only flag from your files that was set with the first command.

Finally, you need to restore the original Read-Only, Hidden, and System attributes on all your Desktop.ini files. Open the command prompt again and navigate to your Music folder again, and run this command to set the required attributes to all the Desktop.ini files in it and all its subfolders:

Code:
attrib /s +r +s +h desktop.ini
Now everything should be set correctly, so you should be able to copy the desktop.ini file around to as many folders as you want, and Windows should pick up on the changes immediately.

References:

Last edited by Tuntematon; 22-Apr-2012 at 11:18 PM..
:z:'s Avatar
:z: :z: is offline
Computer Specs
Member with 96 posts.
THREAD STARTER
 
Join Date: Feb 2008
Experience: Intermediate
23-Apr-2012, 12:04 AM #3
Tuntematon:

Thanks so much! You've just save me a bunch of time! With no one having responded, I had begun the arduous task of manually overriding each folder a few at a time when I have the time. Thankfully, I only have about 10% done so far, so now the rest will go quickly once I convert all the Folder.jpg's into Folder.ico's. That I'm doing by going manually through each folder using ToYcon to do the actual converting. It looks like I could set up a batch process to do this (and also to copy my relative-path desktop.ini file in to all folders), but when I Googled how to do that, I was in over my head technically.

Regarding my second point about copying to other drives, this is working now. I'm not sure why it didn't work at first, but I am able to copy them now and have them retain the icon display.

One final note about your code: My music is stored on my D: drive, so I Googled how to switch directories across drives first. For anyone interested in doing that, it's:

Code:
cd /d d:
Also, I ignored your second and final steps, as I actually want all the folders and files to be read-only. There's no problem in leaving it that way, is there?

Bonus question for you if you have the time. I'm not really familiar with DOS instructions, but guessing from the syntax you gave above, could I use

Code:
attrib +h Folder.ico
to make all of my Folder.ico's that I create to be hidden? I was just planning on doing a search for "Folder.ico" in the Music directory when I was finished and right-clicking them, going to properties, and making them hidden, but doing a search could take a while.

Thanks again!
Tuntematon's Avatar
Tuntematon Tuntematon is offline
Member with 2 posts.
 
Join Date: Apr 2012
Experience: Intermediate
27-May-2012, 01:13 AM #4
You can also switch drives by just typing the drive letter followed by a colon.
Code:
D:
To hide the icons, you would want to add the /s flag to that command; otherwise you'll have to run it separately in every folder that has an icon:

Code:
attrib /s +h Folder.ico
:z:'s Avatar
:z: :z: is offline
Computer Specs
Member with 96 posts.
THREAD STARTER
 
Join Date: Feb 2008
Experience: Intermediate
28-May-2012, 08:25 PM #5
Well, that's easy enough. I got stumped trying to enter cd d: and did a search and the page I found listed the code I had previously shown. Using just d: is much easier.

Thanks again for your help!
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑