Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Windows 7 Windows 7
Search Search
Search for:
Tech Support Guy > > >

Solved: "Program Files(x86)" folder issues


(!)

FallFromINFINITY's Avatar
FallFromINFINITY FallFromINFINITY is offline
Computer Specs
Member with 109 posts.
THREAD STARTER
 
Join Date: May 2008
Location: Western NY
Experience: Intermediate
10-Jan-2010, 01:48 AM #1
Solved: "Program Files(x86)" folder issues
Ok, I have some issues with Windows 7 security features.

Several of the programs I have, including, World of Warcraft, write configuration to files in the program folder. Windows 7 is preventing these changes. Reconfiguring 14 add-ons and graphics settings, for one thing alone, get's kinda annoying. I have several other programs that need to be able to write to the configuration files, from .DAT to .BIN files and everything in between, and this is a major inconvenience.

Anyone know how to turn off this security on the two folders, "Program Files" and "Program Files(x86)"? I've only noticed it in the x86 folder, but I can only assume that it will also happen in the normal folder.
Mumbodog's Avatar
Member with 7,891 posts.
 
Join Date: Oct 2007
Experience: Advanced
10-Jan-2010, 01:44 PM #2
Right click on the folders in question and do properties, select security tab, then click Advanced button, go to Owner tab, who is the current owner?

If it is something other than your user account then change it to your user account, click the edit button, highlight your user account and tick the box "replace owner on sub containers and objects", hit apply. Now close all properties windows.

Do properties again on the folder, then click edit on the security tab, then highlight your user account and tick "full control", hit OK.

See if things work now.

If the original Owner is "SYSTEM" then there will be something else you will need to do before taking ownership and changing permissions.

.
FallFromINFINITY's Avatar
FallFromINFINITY FallFromINFINITY is offline
Computer Specs
Member with 109 posts.
THREAD STARTER
 
Join Date: May 2008
Location: Western NY
Experience: Intermediate
10-Jan-2010, 06:23 PM #3
ok, the user was Laptop\Administrators. I changed the owner to my account Laptop\Rich, then applied the changes and closed the window.

Then i went in and added Laptop\Rich to the permissions menu and gave myself full control.

I tried it and nothing worked. I only tried this on the individual program folder, World of Warcraft. Would I have to change it on Program Files? or would that be bad?

Oh, and I am the only user on the computer, and an administrator.
Elvandil's Avatar
Computer Specs
Moderator with 51,993 posts.
 
Join Date: Aug 2003
Location: Vermont
Experience: "Been through the mill."
10-Jan-2010, 06:32 PM #4
You should get versions that are compatible with 7. If they are too old, they will not work with a new operating system.

Changing security settings is just opening yourself up to problems later. There are a large number of things that the administrator does not have the authority to do.
__________________
Microsoft MVP
異驚の界世 ípןɹoʍ ǝɥʇ ɟo sɹǝpuoʍ ǝɥʇ ɟo ǝuo sı ǝpoɔıun ʞuıɥʇ ı
Mumbodog's Avatar
Member with 7,891 posts.
 
Join Date: Oct 2007
Experience: Advanced
10-Jan-2010, 06:36 PM #5
Quote:
I changed the owner to my account
who was the original owner?

.
FallFromINFINITY's Avatar
FallFromINFINITY FallFromINFINITY is offline
Computer Specs
Member with 109 posts.
THREAD STARTER
 
Join Date: May 2008
Location: Western NY
Experience: Intermediate
10-Jan-2010, 07:00 PM #6
Quote:
who was the original owner?
the original user was Laptop\Administrators

Quote:
You should get versions that are compatible with 7.
and as for the programs, versions for Win7 aren't offered, or at least aren't different from what I've got. Blizzard does not offer any other WoW program than the one I have, nor does NC Soft have alternate versions of their games. Many of the other programs are made by one person or small groups and don't have the ability/want/need to change it. I am confident in the security/safety of my computer, so if changing the permissions and security settings of the Program Files folders would work, I will do it, but I'm not going to change it if it will cause someting else to not work, or if it will change nothing.
Elvandil's Avatar
Computer Specs
Moderator with 51,993 posts.
 
Join Date: Aug 2003
Location: Vermont
Experience: "Been through the mill."
10-Jan-2010, 07:04 PM #7
You'll have to wait for Windows 7 versions to be released if you want them to work properly. The box states clearly what operating systems they work on.
Mumbodog's Avatar
Member with 7,891 posts.
 
Join Date: Oct 2007
Experience: Advanced
10-Jan-2010, 07:11 PM #8
Open an elevated command prompt

type in

attrib<space>-s<space> <the full path to the folder>

hit enter, do this for any program folders giving you problems. See if this helps.

.
FallFromINFINITY's Avatar
FallFromINFINITY FallFromINFINITY is offline
Computer Specs
Member with 109 posts.
THREAD STARTER
 
Join Date: May 2008
Location: Western NY
Experience: Intermediate
11-Jan-2010, 09:03 PM #9
Still nothing. I also tried running it compatibility mode for XP SP2, but nothing, so, I'll go to microsoft support.
TheOutcaste's Avatar
Computer Specs
Member with 9,028 posts.
 
Join Date: Aug 2007
Location: Oregon, USA
Experience: Intermediate
12-Jan-2010, 07:26 AM #10
Install the games into something other than Program Files or Program Files (x86), like C:\Games. This works for many programs, but not all.
Then you won't have issues with the security on the Program folders
Pjotr77's Avatar
Pjotr77 Pjotr77 is offline
Computer Specs
Junior Member with 4 posts.
 
Join Date: Feb 2010
Experience: Beginner
11-Feb-2010, 01:22 PM #11
has your problem already been solved? and if so, how? Because i've exactly the same problem..
(my os is also windows 7 64 bits).
I hope you can help me.
FallFromINFINITY's Avatar
FallFromINFINITY FallFromINFINITY is offline
Computer Specs
Member with 109 posts.
THREAD STARTER
 
Join Date: May 2008
Location: Western NY
Experience: Intermediate
11-Feb-2010, 07:52 PM #12
I found out that Windows 7, for some reason, makes many of the files in program folders Read only. If you know what files, select them and right click > Properties > then uncheck Read only.
If you dont know what files, or have many that need to change, you can do that process on the program's folder or the entire "Program Files" folder, and tell it to apply all changes to subfolders and files.

NOTE: a checkmark means the selected file/folder is read only, a filled box means that some of the selected files or files in the folders are read only, but not all. If this is the case, just click the box until it is empty.


EDIT: TheOutcaste's method works as well, but you need to install the program in the new folder. This one works on already installed files.

Last edited by FallFromINFINITY; 11-Feb-2010 at 07:55 PM.. Reason: ammending
Pjotr77's Avatar
Pjotr77 Pjotr77 is offline
Computer Specs
Junior Member with 4 posts.
 
Join Date: Feb 2010
Experience: Beginner
11-Feb-2010, 09:34 PM #13
Thanks for your fast reply and support. But unfortunately, this doesn't work for me. When I try it for whole program files x86, I┤m getting an ┤acces denied┤ for some folders (even when I run it as an administrator, and I already made myself the owner of the folder). When I try this method for some folders in program files x86 (I indeed have a filled checkbox, so I click till its empty) it seems to work, but when I open properties of the same folder after this, the box is filled again:s
I'm afraid re-installing windows is the only way to solve this, because I've already tried a lot potential solutions, unless you can think of another option?

Thanks
FallFromINFINITY's Avatar
FallFromINFINITY FallFromINFINITY is offline
Computer Specs
Member with 109 posts.
THREAD STARTER
 
Join Date: May 2008
Location: Western NY
Experience: Intermediate
12-Feb-2010, 09:51 PM #14
You may also need to do what Mumbodog said. When he originally posted that, I applied that to all of the folders. It wasn't untill after that I noticed there were read only files. So I had first made all the files non-system files(Mubodog) then I turned off read only. That may be your issue. Or you can just reinstall the programs in different folders.

you wont need to reinstall windows, in fact that wont do anything.
Pjotr77's Avatar
Pjotr77 Pjotr77 is offline
Computer Specs
Junior Member with 4 posts.
 
Join Date: Feb 2010
Experience: Beginner
13-Feb-2010, 11:49 AM #15
re´nstalling the programs in another folder doesn't work unfortunately, because some programs (like steam, Java, 3dMark) need to write a folder in program files x86.
When I open a command prompt, and I type the commands Mumbodog told me to do, it says it cant find the path to the folder. I left the spaces and I used capitals in '<the full path to the folder>'. So how should I type Program Files (x86) in the command prompt?

(I'm sorry when I don't make myself clear enough: I'm not an advanced user)
Email This Email  Print This Print  Bookmark This Bookmark  Tweet This Send to Facebook Send to MySpace Send to StumbleUpon Digg This | More Services More
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


Tags
program files, program files x86, windows 7 64 bit

(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑