Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Windows 7 Windows 7
Search Search
Search for:
Tech Support Guy > > >

System Restore error: 0x8007001f, A device is not functioning


(!)

Arbabender's Avatar
Arbabender Arbabender is offline
Computer Specs
Junior Member with 2 posts.
THREAD STARTER
 
Join Date: Aug 2010
Experience: Advanced
19-Aug-2010, 06:37 AM #1
Question System Restore error: 0x8007001f, A device is not functioning
I recently installed PartitionMagic 8.0 on my computer. After checking through the 'compatibility issues' dialog boxes (and having used it on another Win7 Ultimate PC) I proceeded to run it.

As it ran, I received various 'error' reports about one of my hard drives. I clicked yes, thinking that nothing bad would happen, and PMagic still wouldn't start, Error 117.

So I called it a night and went back to it in the morning to find that it wouldn't start. The System Recovery tool that automatically started didn't fix it, and I selected System Restore from the advanced options menu. It wouldn't start, and at the time I didn't really read the error, but I think it was different.

Went back to it later, hoping by some black magic that it would start, and it obviously didn't. I inserted the install disk to see if I could repair it. I again selected advanced to find System Restore again. Upon selecting it, I was greeted with this:

Code:
There was an unexpected error:
A device attached to the system is not functioning. (0x8007001F)

Please close System Restore and try again.
After closing and re-opening it, I got the same message.

I have a lot of important data, and about 400GB worth of my 1TB HD filled, and don't want to lose it all, so how to I get either

1) System Restore to work
2) Fix my HD from what I suspect is PMagic

or

3) Re-install W7 without losing all of my data?

Thanks in advance,
Rorschach112's Avatar
Senior Member with 2,392 posts.
 
Join Date: Oct 2008
19-Aug-2010, 08:24 AM #2
this should get system restore working again


Please download OTM
  • Save it to your desktop.
  • Please double-click OTM to run it. (Note: If you are running on Vista, right-click on the file and choose Run As Administrator).
  • Copy the lines in the codebox below to the clipboard by highlighting ALL of them and pressing CTRL + C (or, after highlighting, right-click and choose Copy):

    Code:
    :Processes
    
    :Services
    
    :Reg
    
    :Files
    ipconfig /flushdns /c
    
    :Commands
    [purity]
    [resethosts]
    [emptytemp]
    [CREATERESTOREPOINT]
    [EMPTYFLASH]
    [Reboot]
  • Return to OTM, right click in the "Paste Instructions for Items to be Moved" window (under the yellow bar) and choose Paste.
  • Click the red Moveit! button.
  • Copy everything in the Results window (under the green bar) to the clipboard by highlighting ALL of them and pressing CTRL + C (or, after highlighting, right-click and choose copy), and paste it in your next reply.
  • Close OTM and reboot your PC.
Note: If a file or folder cannot be moved immediately you may be asked to reboot the machine to finish the move process. If you are asked to reboot the machine choose Yes. In this case, after the reboot, open Notepad (Start->All Programs->Accessories->Notepad), click File->Open, in the File Name box enter *.log and press the Enter key, navigate to the C:\_OTMoveIt\MovedFiles folder, and open the newest .log file present, and copy/paste the contents of that document back here in your next post.
Arbabender's Avatar
Arbabender Arbabender is offline
Computer Specs
Junior Member with 2 posts.
THREAD STARTER
 
Join Date: Aug 2010
Experience: Advanced
21-Aug-2010, 09:43 PM #3
Quote:
Originally Posted by Rorschach112 View Post
this should get system restore working again


Please download OTM
  • Save it to your desktop.
  • Please double-click OTM to run it. (Note: If you are running on Vista, right-click on the file and choose Run As Administrator).
  • Copy the lines in the codebox below to the clipboard by highlighting ALL of them and pressing CTRL + C (or, after highlighting, right-click and choose Copy):

    Code:
    :Processes
    
    :Services
    
    :Reg
    
    :Files
    ipconfig /flushdns /c
    
    :Commands
    [purity]
    [resethosts]
    [emptytemp]
    [CREATERESTOREPOINT]
    [EMPTYFLASH]
    [Reboot]
  • Return to OTM, right click in the "Paste Instructions for Items to be Moved" window (under the yellow bar) and choose Paste.
  • Click the red Moveit! button.
  • Copy everything in the Results window (under the green bar) to the clipboard by highlighting ALL of them and pressing CTRL + C (or, after highlighting, right-click and choose copy), and paste it in your next reply.
  • Close OTM and reboot your PC.
Note: If a file or folder cannot be moved immediately you may be asked to reboot the machine to finish the move process. If you are asked to reboot the machine choose Yes. In this case, after the reboot, open Notepad (Start->All Programs->Accessories->Notepad), click File->Open, in the File Name box enter *.log and press the Enter key, navigate to the C:\_OTMoveIt\MovedFiles folder, and open the newest .log file present, and copy/paste the contents of that document back here in your next post.
Hey, thanks for that, but whenever I try to start my system, it fails to load and then immediately attempts to fix it. If I could find a way to get Windows to load, I could then follow these instructions and restore to a past time.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


Tags
computer, error 0x8007001f, system restore, windows 7

(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


Similar Threads
Title Thread Starter Forum Replies Last Post
System Restore Problems BurglarBill Windows Server 5 17-Aug-2010 11:05 AM
Solved: System Restore - Will Not Restore lagunasrfr Windows Vista 38 07-Jan-2010 08:12 PM
System Restore Question - hope this is the right section for that. MilliJoolz Windows XP 4 20-Aug-2009 09:24 PM
Major XP Issues / No Updates / No Restore / IE Not Functioning HELP!!!! dirtyp3944 Windows XP 3 27-May-2009 09:25 AM
System restore is not working even after fresh install of XP? bspkumar Windows XP 14 28-Apr-2009 12:43 PM

WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑