Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Windows Vista Windows Vista
Search Search
Search for:
Tech Support Guy > > >

Dual Monitor settings not saved


(!)

SteveC65's Avatar
SteveC65 SteveC65 is offline
Computer Specs
Junior Member with 13 posts.
THREAD STARTER
 
Join Date: Feb 2007
Experience: Intermediate
22-Feb-2007, 04:11 AM #1
Dual Monitor settings not saved
Having just installed Vista Ultimate on my laptop I have now set-up dual monitors with my main monitor to the left of my laptop (the laptop sits on a shelf to the right of my main monitor)… setting up the dual monitor system was easy, using the mobility center to specify the main monitor is on the left… and then using display properties to finalize the settings.

All works well, except that every time I reboot the computer I have to reset the settings, they do not save… my question therefore is this, is there a way to ensure Vista saves these settings?
loserOlimbs's Avatar
Computer Specs
Member with 7,800 posts.
 
Join Date: Jun 2004
Location: Wichita, KS
22-Feb-2007, 02:10 PM #2
Did you install the drivers for the graphics, might help... any more info you could give would help also (Laptop model, GFX, etc.)
SteveC65's Avatar
SteveC65 SteveC65 is offline
Computer Specs
Junior Member with 13 posts.
THREAD STARTER
 
Join Date: Feb 2007
Experience: Intermediate
22-Feb-2007, 05:13 PM #3
The computer is an Acer Travelmate 5625WSMi (Laptop) with 2GB of RAM, a 2GHZ Duo Core Processor and Vista installed easily… with no troubles, the problem I have is that having laptop positioned to the right of the second monitor… with the second monitor being the main monitor…

Setting this is easy, however when rebooting it remembers the setting whilst initially booting or it appears to, however when the system fully boots it reverts back to the monitor on the right being the main monitor and not the monitor on the left… to me it appears as if the display properties are not saved, and the default setup is applied as the boot finishes.

This as you can imagine is annoying more than anything… because the set-up would be perfect if this could be resolved.

Thanks for your help.
loserOlimbs's Avatar
Computer Specs
Member with 7,800 posts.
 
Join Date: Jun 2004
Location: Wichita, KS
22-Feb-2007, 06:26 PM #4
So you have a Geforce 7900 mobile graphics, do you have the Vista drivers and software from Nvidia?
HectorAP's Avatar
HectorAP HectorAP is offline
Junior Member with 16 posts.
 
Join Date: Sep 2002
Location: Hialeah, FL
22-Feb-2007, 10:45 PM #5
I am having similar problems on my HP, everytime the computer is turned on, or comes back from sleep, I have to reset the dual monitor alignment settings.

Recently, I even started having a problem where out of nowhere, the computer treats the monitor attached to the laptop as "number 1" and defaults to it automatically.

Stupid buggy crap!
SteveC65's Avatar
SteveC65 SteveC65 is offline
Computer Specs
Junior Member with 13 posts.
THREAD STARTER
 
Join Date: Feb 2007
Experience: Intermediate
22-Feb-2007, 11:52 PM #6
It's actually a Geforce Go 7300 and we have the Nvidia drivers from Microsoft installed... that's the laptop monitor... the other monitor is a Samsung L1952S
SteveC65's Avatar
SteveC65 SteveC65 is offline
Computer Specs
Junior Member with 13 posts.
THREAD STARTER
 
Join Date: Feb 2007
Experience: Intermediate
24-Feb-2007, 09:04 PM #7
I’ve tried to install the latest drivers for my graphics card, however every time I try the NVIDIA software says it cannot locate a suitable driver for my set-up… and I’m left with the generic PNP ones from Microsoft.

Help
DarkNite's Avatar
DarkNite DarkNite is offline
Computer Specs
Junior Member with 3 posts.
 
Join Date: Mar 2007
Experience: Advanced
27-Mar-2007, 11:37 AM #8
Multiple Monitor Issue
I wonder if this is an nVidia drive issue or a Vista issue. It seems to be fairly consistent. It appears that Vista insists on the external monitor being the primary monitor. Mine resets itself every time it comes out of standby, re-boot, screen saver, and even just locking and immediately unlocking the laptop.
SteveC65's Avatar
SteveC65 SteveC65 is offline
Computer Specs
Junior Member with 13 posts.
THREAD STARTER
 
Join Date: Feb 2007
Experience: Intermediate
27-Mar-2007, 06:09 PM #9
This is how we solved the problem... we waited for about a month until Acer brought out their updated drivers... we loaded in the Nvidia drivers and we now use the settings within the Nvidia drivers to control our display... we can change primary monitors, etc... complete freedom and VISTA of course remembers all of them... so the initial advice was spot on, the problem with most laptops is that they use a slight variation of the main Nvidia dirvers and so you have trouble updating... in my opinion

Steve
DarkNite's Avatar
DarkNite DarkNite is offline
Computer Specs
Junior Member with 3 posts.
 
Join Date: Mar 2007
Experience: Advanced
27-Mar-2007, 07:37 PM #10
I have a Dell Latitude D820 with an nVidia Quadro NVS 120M. I downloaded and installed the most recent nVidia drivers from Dell. I did this a soon as I installed Vista on the laptop. I have set the setting using the nVidia Control panel and that has half fixed the problem (didn't mention that part in the earlier post). I am able to set my laptop monitor as my primary (number 1) and it holds that setting. What is annoying still is that it does not hold the setting for which side of the laptop the external monitor is on. I have my external monitor, a Dell 2007WFP, sitting on the left side and when the laptop comes out of sleep or lock it always puts it on the right side. This I still have not been able to fix.

At work my external is on the right because of my desk position and at home it is on the left because of my desk position/configuration. I have a docking station for both setups. With XP it would retain the monitor configurations for each docking station. Vista seems to want to retain the configuration I initially installed with (work desk with the monitor in the right) no matter which monitor is set as primary.
DarkNite's Avatar
DarkNite DarkNite is offline
Computer Specs
Junior Member with 3 posts.
 
Join Date: Mar 2007
Experience: Advanced
27-Mar-2007, 07:38 PM #11
I hope that didn't sound unappreciative. I appreciate your previous response.
eshin's Avatar
eshin eshin is offline
Junior Member with 1 posts.
 
Join Date: Apr 2007
04-Apr-2007, 08:04 PM #12
I had the same problem. Windows Vista couldn't save my settings (second monitor at left side of my primary monitor).

I found two possible solutions:

1) Get the latest driver (my case nvidia chipset) from the Windows update , not the one provided for your notebook manufactory. And then, get the latest driver for your second monitor. Without this monitor driver the Windows Vista TMM was not able to save my settings. If you are lucky, like I was, it will work like a charm.

2) Second option, in case you don't find the latest drivers. Here is a temporary solution. Do not let the Windows TMM manage your multiple monitors. To do that... Go to Task Scheduler, in Active Task List, Find TMM task line, disable it - trigger on logon disabled (or delete it - save/export task before do it). Bingo, restart your windows, problem solved. Now you have your settings working.
The only inconvenient in this solution is that Windows will not recognize automatically the unplug/plug monitor. It's not a problem for people who use two monitors plugged most the time.

For more information about TMM (http://download.microsoft.com/downlo...monManager.doc)

Last edited by eshin; 05-Apr-2007 at 01:22 AM..
martin123456789's Avatar
martin123456789 martin123456789 is offline
Computer Specs
Junior Member with 1 posts.
 
Join Date: Jun 2007
Experience: Advanced
27-Jun-2007, 08:21 AM #13
Happens on Windows XP Pro as well
I'm experiencing the same issue as the others on a Dell Latitude D820 but I'm running Windows XP Pro, not vista so I figured I'd add this to the thread.

For me it's a morning surprise though, sometimes my dual settings sick, (laptop as main on the left with 5 year old 19" ViewSonic G790 on the right and going through a port replicator), sometimes they need resetting. It may have something to do with using my laptop at home without extra monitors or replicator, when I do that, I think the settings may stick... not sure.

I've been running dual monitors on our corporate standard build for years and have recently had a laptop upgrade from DELL M60 to D820 so, I'd have to agree with others that it may be the NVIDIA drivers. I've run though the wizard and duplicated my choices, next I'll see if DELL has a driver upgrade for Windows XP

Martin.
elangsto's Avatar
elangsto elangsto is offline
Junior Member with 1 posts.
 
Join Date: Jul 2007
Experience: Intermediate
16-Jul-2007, 06:26 PM #14
Happens on Win XP too !! How frustrating ...
I have a Dell Inspiron 8200 and I recently came across an extra monitor. It seems that like everyone else I can get it set up fine but then when I either (1) restart or (2) suspend my computer, then the settings get mucked up.

My particular case is that WinXP insists that the external monitor is the primary monitor and it appears to think that it's also attached to my laptop! However, once I tell it extend my desktop to the other monitor, then it properly recognizes the monitors for what they are.
JonnyHonda's Avatar
JonnyHonda JonnyHonda is offline
Computer Specs
Junior Member with 1 posts.
 
Join Date: Jul 2007
18-Jul-2007, 03:26 AM #15
I have a Tosh Sat Pro, with the nVidia graphics, and have the same problem. I have a two tiered desk so I want my monitor on top of each other, like elangsto it resets the positions every time the display comes out of suspend ro a restart, I'ts definitely the drivers.

My Graphics card is the geforce Go 7600 512mb bios version 5.73.22.10a2
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑