Advertisement

There's no such thing as a stupid question, but they're the easiest to answer.
Login
Search

Advertisement

Windows Vista Windows Vista
Search Search
Search for:
Tech Support Guy > > >

Vista - No Internet, Can't ping anything, can't get DHCP address


(!)

ukzshab's Avatar
ukzshab ukzshab is offline
Junior Member with 2 posts.
 
Join Date: Jul 2007
Experience: Intermediate
20-Jul-2007, 06:30 AM #31
No sorry. I had an interview yesterday and have been concentrating on that! I think I'll re-install next.
jwill911's Avatar
jwill911 jwill911 is offline
Junior Member with 1 posts.
 
Join Date: Jul 2007
Experience: Intermediate
27-Jul-2007, 02:42 PM #32
I've seen similar behavior with a new Vista Home PC we bought at work to test a reported DHCP problem. Tracing the DHCP protocol with Wireshark I see the Vista box send "Discovers" without a reply from our system. Then if I open a "cmd" window and issue "ipconfig /renew", immediately the DHCP server sends an "Offer" and all is good. Doing a trace to the same DHCP server with WinXP no trouble at all just
Discover ->
<- Offer
Request->
<-Ack

I've been trying to see what the difference is between the successful and failed "Discover" UDP packets so far don't see any. I was googling to see if anyone else had already discovered it when I ran across this.
Not sure if this helps or makes it more confusing.
Regards,
jw
killvista's Avatar
killvista killvista is offline
Junior Member with 1 posts.
 
Join Date: Aug 2007
01-Aug-2007, 05:01 PM #33
Hey guys, Suprise I'm having the same problem. My scneario is this.
I have a few Xp machines hooked up through a Netgear switch at work. I can connect to the internet with the Xp's and obtain an address automatically. If I hook my Vista (yay VISTA!) laptop up I cannot get to the internet. IP6 has limitted connectivity.

One solution I did not see posted here was the Registry edit solution. I have not tried it yet, but if it works I will let you know.
california_kiwi's Avatar
california_kiwi california_kiwi is offline
Junior Member with 1 posts.
 
Join Date: Aug 2007
Experience: Advanced
02-Aug-2007, 11:48 PM #34
Smile Potential Fix
All,

I experienced the same issues, and have discoverd a potential solution. I will describe what lead to my problem, observations, and the fix that has worked for me and allowed me to use my laptop again to write this.

Problem:
- 2 installations occurred on my laptop.
1) Installed an old version of PCAnywhere (v11) onto my Windows Vista laptop
2) LiveUpdate installed updates onto my laptop

- After a reboot, I had no issues
- After a shutdown and logging back into my laptop the following day, I could not access the internet nor could I even access a local network drive

Observations:
- I could not PING localhost (Result 'General Failure')
- In my list of installed programs, I noticed 2 LiveUpdate type applications, the original that was installed with my laptop, and new one installed the day I installed PCAnywhere

Solution:
- I uninstalled PCAnywhere, the secondary LiveUpdate, and Symantec Norton Internet Security.
- I left the remaining LiveUpdate (It game me a warning, so I thought I'd try to reconnect to the internet before removing that as well).
- After a reboot and power off/on of my wireless network, I was reconnected to the internet.

While I uninstalled all the Symantec applications with the exception of the LiveUpdate, my suspicion is that it was the secondary 'Liveupdate' like application from Symantec.

I hope this leads everyone to solving their problems with this. It was very annoying.

Good luck!

California_Kiwi
Searchingfor's Avatar
Searchingfor Searchingfor is offline
Junior Member with 1 posts.
 
Join Date: Aug 2007
04-Aug-2007, 09:33 AM #35
I had the same problem after spending days on the phone with my ISP, Microsoft (whom i refused to pay $69 to help me), sony...I used good old google and was directed to the Microsoft page below. It worked immediately and prevented me from hurling my computer out the window in frustration. Good luck!

http://support.microsoft.com/kb/928233/en-us

Windows Vista cannot obtain an IP address from certain routers or from certain non-Microsoft DHCP servers
View products that this article applies to.
Article ID : 928233
Last Review : March 15, 2007
Revision : 1.3
Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/) Description of the Microsoft Windows registry
SYMPTOMS
Consider the following scenario: You connect a Windows Vista-based computer to a network.
A router or other device that is configured as a Dynamic Host Configuration Protocol (DHCP) server is configured on the network.
The router or the other device does not support the DHCP BROADCAST flag.
In this scenario, Windows Vista cannot obtain an IP address.
Back to the top

CAUSE
This issue occurs because of a difference in design between Windows Vista and Microsoft Windows XP Service Pack 2 (SP2). Specifically, in Windows XP SP2, the BROADCAST flag in DHCP discovery packets is set to 0 (disabled). In Windows Vista, the BROADCAST flag in DHCP discovery packets is not disabled. Therefore, some routers and some non-Microsoft DHCP servers cannot process the DHCP discovery packets.
Back to the top

RESOLUTION
Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.To resolve this issue, disable the DHCP BROADCAST flag in Windows Vista. To do this, follow these steps: 1. Click Start, type regedit in the Start Search box, and then click regedit in the Programs list.

If you are prompted for an administrator password or for confirmation, type your password, or click Continue.
2. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Inter faces\{GUID}
In this registry path, click the (GUID) subkey that corresponds to the network adapter that is connected to the network.
3. On the Edit menu, point to New, and then click DWORD (32-bit) Value.
4. In the New Value #1 box, type DhcpConnDisableBcastFlagToggle, and then press ENTER.
5. Right-click DhcpConnDisableBcastFlagToggle, and then click Modify.
6. In the Value data box, type 1, and then click OK.
7. Close Registry Editor.

Back to the top

MORE INFORMATION
If the router or the non-Microsoft DHCP server does not support the DHCP BROADCAST flag, you can set the following registry entry as follows:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Inter faces\{GUID}

Value name: DhcpConnForceBroadcastFlag
Value type: REG_DWORD
Value data: 0
Note A data value of 0 disables this registry entry. You can use this registry entry to prevent Windows Vista from using the DHCP BROADCAST flag. After you set this registry entry, Windows Vista never uses the DHCP BROADCAST flag.
Back to the top


--------------------------------------------------------------------------------

APPLIES TO
Windows Vista Business
Windows Vista Enterprise
Windows Vista Home Basic
Windows Vista Home Premium
Windows Vista Ultimate
Windows Vista Enterprise 64-bit edition
Windows Vista Home Basic 64-bit edition
Windows Vista Home Premium 64-bit edition
Windows Vista Ultimate 64-bit edition
Windows Vista Starter

Back to the top

Keywords: kbnetwork_generalbroadband kbnetwork_routerissues kbexpertisebeginner kbhardware kbtshoot kbprb KB928233

Back to the top
ssutton's Avatar
ssutton ssutton is offline
Junior Member with 1 posts.
 
Join Date: Aug 2007
Experience: Intermediate
05-Aug-2007, 01:25 PM #36
Firmware
I'm having the same problem with a few laptops, I'm going to try the registry alteration next. One thing that may help is making sure your wireless router/accesspoint has the latest firmware, this has solved a number of instances of this issue. But not always...unfortunately

What's bothering me most with this issue is that it will pull a DHCP address and connect correctly to the internet and work just fine. For a few minutes... then it is back to the autoconfig ipv4 address. But it seems so...random...it will suddenly work ...i wont even be doing something on it...

Last edited by ssutton; 05-Aug-2007 at 01:33 PM..
computertechie's Avatar
computertechie computertechie is offline
Senior Member with 135 posts.
THREAD STARTER
 
Join Date: Jul 2007
Location: England
Experience: Loads
16-Aug-2007, 04:16 AM #37
Did anyone ever get the definitive solution for this problem?
NOCIT's Avatar
NOCIT NOCIT is offline
Junior Member with 1 posts.
 
Join Date: Aug 2007
Experience: Advanced
16-Aug-2007, 10:00 AM #38
Quote:
Originally Posted by computertechie
Did anyone ever get the definitive solution for this problem?
I have very recently run into this situation (169.254 IP, error 1231 on ping, etc), and what it turned out to be for me was the SSID Broadcast being disabled. I had to go into the wireless connection's properties and tell Vista to connect to the network even if it wasn't broadcasting. Then, finally, it gave me an IP and the Internet.

This was on a Dell laptop behind a Linksys WAP and a Netgear router.

Last edited by NOCIT; 16-Aug-2007 at 10:35 AM..
nickademous's Avatar
nickademous nickademous is offline
Junior Member with 1 posts.
 
Join Date: Sep 2007
Experience: Advanced
05-Sep-2007, 03:15 PM #39
got one working!
...but i'm not sure what fixed it...
i'm working on a gateway gm5407E from Costco, with vista home premium. it refused to get an ip via dhcp, but when i entered static ip/gateway/dns #s it all worked fine.

the dhcp started working shortly after i:
1 reset the ip settings to automatic
2 tried the "netsh winsock reset catalog, and "netsh int ip reset reset.log" commands (i also got the "Reseting Echo Request, failed. Access is denied." message)
3 rebooted the computer and rebooted the router at the same time. (not a factory reset, just unplugged and replugged.)


the other thing i tried was to enable the RIP listener under windows features in the add remove programs gizmo, but i don't think that was it, i just turned it back off, and it's still working so far.

fingers crossed!
good luck all.
Wiz.au's Avatar
Wiz.au Wiz.au is offline
Junior Member with 3 posts.
 
Join Date: Sep 2007
27-Sep-2007, 02:11 AM #40
Angry Chalk up another!
Same deal here, Vista Business, Asus Laptop. Static addressed all network cards, and still nothing. I'm sure it's to do with the "IPv6 Tunelling" to make it work with IPv4 networks for a "smooth migration"!! And something to do with the "ISATAP" Adapter??

We have a Microsoft DHCP Server (SBS2003) running!! So the Registry edit SHOULDN'T solve the problem. But I'm going to try it anyway!

Obviously this problem has been going on for months,. Someone has to have a solution other than a re-install!! ??
Wiz.au's Avatar
Wiz.au Wiz.au is offline
Junior Member with 3 posts.
 
Join Date: Sep 2007
27-Sep-2007, 04:39 AM #41
Ok, BTDT, Still nothing
Ok, did all the registry edits, even disabled IPv6, I did all the DHCP Broadcast flags settings. Static addressed both the wired & wireless cards. All the same. Even trying to ping myself I get "General Failure"

I'm going to have to recommend a re-install to the client.??
Supacon's Avatar
Supacon Supacon is offline
Junior Member with 2 posts.
 
Join Date: Oct 2007
Experience: Advanced
01-Oct-2007, 11:58 PM #42
Hey Guys:
I've been following this thread and doing everything advised in it. I've got the same problems as the original poster. I got so frustrated that I even installed Vista again from scratch, and guess what?!

Same bloody problem!

But I FINALLY FIXED IT!

I was overclocking a new processor and must have rebooted a hundred times. When I finally gave up, reset to stock settings and booted Vista, I couldn't get a DHCP address. I tried many, many things, and after I restored my original vista installation, since reinstalling didn't work, I tried plugging in another network card, then plugged the network cable into that card and started Windows.

I couldn't believe that Vista didn't have a driver ready to load for the venerable 3C509C, so I got pissed and thought I'd try plugging the network cable back into the onboard NIC, and IT FINALLY WORKED!

I got an IP and could get on the net right away. So is that all you have to do? Shut down the computer and boot with the network cable unplugged? Mighty weird, I must say.
computertechie's Avatar
computertechie computertechie is offline
Senior Member with 135 posts.
THREAD STARTER
 
Join Date: Jul 2007
Location: England
Experience: Loads
02-Oct-2007, 04:11 AM #43
Seems like it's a major flaw in Vista. The network works alright one moment, then just stops without the user making any changes. A good reason to avoid using Vista. I wonder if the forthcoming service pack will sort out this issue?
Supacon's Avatar
Supacon Supacon is offline
Junior Member with 2 posts.
 
Join Date: Oct 2007
Experience: Advanced
02-Oct-2007, 11:07 AM #44
Man, one can only hope. These networking glitches in Vista are pretty terrible. Networking is one component they definitely made a lot of changes to, unnecessarily because things seemed to work pretty good in XP. I've administered many, many XP systems since it came out, and never have experienced things like this with its networking.

The worst thing about XP in the beginning was to make filesharing work, but I think that was mainly just not having a sufficient understanding of the permissions that it used and such. This kind of stuff is beyond pathetic though :P
lunarlander's Avatar
Computer Specs
Member with 5,554 posts.
 
Join Date: Sep 2007
02-Oct-2007, 03:41 PM #45
Try uninstall TCP/IP and reinstalling it.
As Seen On

BBC, Reader's Digest, PC Magazine, Today Show, Money Magazine
WELCOME TO TECH SUPPORT GUY!

Are you looking for the solution to your computer problem? Join our site today to ask your question. This site is completely free -- paid for by advertisers and donations.

If you're not already familiar with forums, watch our Welcome Guide to get started.


Tags
dhcp, internet, ip address, vista

(clock)
THIS THREAD HAS EXPIRED.
Are you having the same problem? We have volunteers ready to answer your question, but first you'll have to join for free. Need help getting started? Check out our Welcome Guide.

Search Tech Support Guy

Find the solution to your
computer problem!




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools


WELCOME
You Are Using: Server ID
Trusted Website Back to the Top ↑